Zen Cart Logo
Forums / Installing on a Linux/Unix Server / /zc_install/index.php is writeable by others

/zc_install/index.php is writeable by others

Locked

Views: 3,159

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
23 Aug 2010, 11:10 PM
#1
nigelt74 avatar

nigelt74

Totally Zenned

Join Date:
Sep 2005
Location:
Waikato, New Zealand
Posts:
1,558
Plugin Contributions:
1

/zc_install/index.php is writeable by others

Help i get the following error when trying to set up a new site

Internal Server Error

File "/chroot/home/mysite/mysite.com/html/zc_install/index.php" is writeable by others

Zencart was uploaded as a single file then I had the hosting people unzip it (as there is no unzip function in the filemanager)

any ideas

23 Aug 2010, 11:33 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: /zc_install/index.php is writeable by others

Since every server is different, and especially apparently yours, it's best to work with your hosting company to determine the correct permissions they should have assigned to the files when they unzipped them.

24 Aug 2010, 12:31 AM
#3
richphitzwell avatar

richphitzwell

Zen Follower

Join Date:
Jul 2010
Location:
My heart will always be in the NorEast
Posts:
110
Plugin Contributions:
0

Re: /zc_install/index.php is writeable by others

I dont know how you installed your site and if you for whatever reason had the root as zc_install, but typically after install you delete zc_install and all the files in it.

**update, sorry I reread it
in your browser go to mysite.com/html/zc_install and it should walk you through it at that point. html being the root folder for your cart.

24 Aug 2010, 1:35 AM
#4
nigelt74 avatar

nigelt74

Totally Zenned

Join Date:
Sep 2005
Location:
Waikato, New Zealand
Posts:
1,558
Plugin Contributions:
1

Re: /zc_install/index.php is writeable by others

richphitzwell:

I dont know how you installed your site and if you for whatever reason had the root as zc_install, but typically after install you delete zc_install and all the files in it.

**update, sorry I reread it
in your browser go to mysite.com/html/zc_install and it should walk you through it at that point. html being the root folder for your cart.

Thats exactly what I did, and thats where I get the error, I think I'll jus unzip on my local machine and upload iot unzipped thats normally fairly idiot proof

24 Aug 2010, 5:09 AM
#5
richphitzwell avatar

richphitzwell

Zen Follower

Join Date:
Jul 2010
Location:
My heart will always be in the NorEast
Posts:
110
Plugin Contributions:
0

Re: /zc_install/index.php is writeable by others

nigelt74:

Thats exactly what I did, and thats where I get the error, I think I'll jus unzip on my local machine and upload iot unzipped thats normally fairly idiot proof

You also have a db that would need to be assigned to the cart prior to this. If this is what you did, then I will refer back to the other poster and call your host. Really there is only two things going on, the db and the files. the files can be copied over. the db can be copied over. its the link between the two that has to be specified and it appears to be either you don't have a db setup or the link is not setup properly between the two but the easiest way is to ask the host if you have not done this before.

24 Aug 2010, 5:16 AM
#6
nigelt74 avatar

nigelt74

Totally Zenned

Join Date:
Sep 2005
Location:
Waikato, New Zealand
Posts:
1,558
Plugin Contributions:
1

Re: /zc_install/index.php is writeable by others

richphitzwell:

You also have a db that would need to be assigned to the cart prior to this. If this is what you did, then I will refer back to the other poster and call your host. Really there is only two things going on, the db and the files. the files can be copied over. the db can be copied over. its the link between the two that has to be specified and it appears to be either you don't have a db setup or the link is not setup properly between the two but the easiest way is to ask the host if you have not done this before.

its nothing to do with the database, you don't need a database setup to view the install page which is where you enter the database details, to go any further than that you need a working database, but my problem was that i wan't even able to view the install file, as soon as i went to the directory there was an error

anyway it was solved by uploading an unzipped copy