Zen Cart Logo
Forums / Installing on a Linux/Unix Server / 2008 MySQL client ran out of memory

2008 MySQL client ran out of memory

Locked

Views: 3,291

Results 1 to 2 of 2
This thread is locked. New replies are disabled.
25 Aug 2010, 6:00 PM
#1
377704497 avatar

377704497

New Zenner

Join Date:
Mar 2009
Posts:
14
Plugin Contributions:
0

2008 MySQL client ran out of memory

Can anyone help me with the below error?
it's only one category that is giving that error. The rest of the site is working fine.follow the URL beow and you will see that error.:(

http://chinaglobaltrader.com/index.php?main_page=index&cPath=27
2008 MySQL client ran out of memory
in:
[select p.products_image, pd.products_name, p.products_quantity, p.products_id, p.products_type, p.master_categories_id, p.manufacturers_id, p.products_price, p.products_tax_class_id, pd.products_description, IF(s.status = 1, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status =1, s.specials_new_products_price, p.products_price) as final_price, p.products_sort_order, p.product_is_call, p.product_is_always_free_shipping, p.products_qty_box_status from zen_products_description pd, zen_products p left join zen_manufacturers m on p.manufacturers_id = m.manufacturers_id, zen_products_to_categories p2c left join zen_specials s on p2c.products_id = s.products_id where p.products_status = 1 and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and p2c.categories_id = '27' order by p.products_sort_order, pd.products_name]

2013 Lost connection to MySQL server during query
in:
[select count(*) as total from zen_sessions where sesskey = '04fba6c77b5f15cb003344ba1b69a54a']

26 Aug 2010, 12:41 PM
#2
vger avatar

vger

Past Contributor

Join Date:
Nov 2004
Location:
Norfolk, United Kingdom
Posts:
3,189
Plugin Contributions:
0

Re: 2008 MySQL client ran out of memory

It can be one of a few things:

  1. The SQL server is just overloaded.
  2. There can be a problem with the query itself
  3. There can be a problem with a corrupted session (access the db via phpMyAdmin, access the 'sessions' table and elect to Empty/Truncate that table - but not to 'Drop' it). This will clear all sessions.

Vger