Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Error After Moving site to GoDaddy

Error After Moving site to GoDaddy

Locked

Views: 2,156

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
26 Aug 2010, 8:39 AM
#1
nathanlee0921 avatar

nathanlee0921

New Zenner

Join Date:
May 2010
Posts:
18
Plugin Contributions:
0

Error After Moving site to GoDaddy

Hello Everyone,

I recently moved my zen cart store to a new hosting company which is GoDaddy. I'm moving my Zen Cart 3.8. What I did was:

  1. I downloaded my database and files. I saved them to my PC.
  2. On the new hosting, I uploaded all my files and create a new database with the exact same user name and password.
  3. I changed the IP address pointing to my domain name plus the name sever to match my hosting.

But now Zen Cart is not working. It's just a blank page and gives me a fatal error when I tried to log into the admin area.

I know I did follow these instruction step by step, but do I have to. https://www.zen-cart.com/tutorials/index.php?article=100.

For example, why do I need to upload a fresh install of Zen Cart?

I don't know if anyone else have the same problem and have fixed it. Please help.

26 Aug 2010, 8:55 AM
#2
martinvelikov avatar

martinvelikov

New Zenner

Join Date:
Nov 2009
Posts:
16
Plugin Contributions:
0

Re: Error After Moving site to GoDaddy

You still need to edit the ZenCart configuration file:

<path_to_your_zencart>/includes/configure.php

The options you need to alter are:

define('DIR_FS_CATALOG', '<FULL PATH TO YOUR ZEN CART HERE>');

In the database connections you should make sure the correct database details are entered. Note that possibly the database name and the username for it does not fully match the ones from your previous host. In most cases there is a prefix which is for example your account name. Check this out.

26 Aug 2010, 10:03 AM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error After Moving site to GoDaddy

The reason why the tutorial advises you to do a fresh clean install is so that it can build the correct configure.php file content for you automatically. That eliminates all the guesswork of trying to figure out what to put in all the settings ... and saves everyone here on the forum from having to spend many hours over several days trying to help you guess what should be put where.
Sounds like it might have been a good idea for you too.