Zen Cart Logo
Forums / General Questions / Create Account PHP 500 error

Create Account PHP 500 error

Locked

Views: 6,666

Results 1 to 13 of 13
This thread is locked. New replies are disabled.
22 Sep 2010, 4:09 PM
#1
karimm avatar

karimm

New Zenner

Join Date:
Nov 2008
Posts:
53
Plugin Contributions:
0

Create Account PHP 500 error

Create Account Internal 500 error / blanks.

When a customer creates a account my website times out with a 500 error.
The customer is created in the database, but no welcome email has been send.

You should normaly see create_account_succes, but he times out before.

email works on the server, and email can be send to the customer that has been created.

I have been debugging for days and looking over all the modules now i feel really stuppid.
Help from the specialists would be very welcome !!

My server specs:

IIS 7.5
PHP 5.2.14 fast-cgi
Mysql 5.1.49
hmailserver 5.3.3-B1879

HTTP Server: Microsoft-IIS/7.5
PHP versie: 5.2.14 (Zend versie: 2.2.0) PHP Memory Limiet: 128M PHP Safe Mode: Off
PHP File Uploads: On Max Grootte: 2M POST Max Grootte: 8M
Database Data Grootte: 18,928 kB Database Index Grootte: 4,074 kB


Trace Logging for Failed Requests IIS
Shows :

FailedReqLogFiles

  1. -MODULE_SET_RESPONSE_ERROR_STATUS

ModuleName FastCgiModule
Notification 128
HttpStatus 500
HttpReason Internal Server Error
HttpSubStatus 0
ErrorCode 0
ConfigExceptionInfo
Notification EXECUTE_REQUEST_HANDLER
ErrorCode The operation completed successfully. (0x0)


zen-cart logs shows different errors, i have created multiple users and the problem always happends.

PHP Fatal error: Maximum execution time of 300 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 265
line 265: $time_end = explode (' ', microtime());

PHP Fatal error: Maximum execution time of 300 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 250
line 250: $zp_result_array = @mysql_fetch_array($zp_db_resource);

PHP Fatal error: Maximum execution time of 30 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 241
line 241: $time_start = explode(' ', microtime());

PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 264
line 264: empty
line 265: $time_end = explode (' ', microtime());

PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 252
line 252: while (list($key, $value) = each($zp_result_array)) {

PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 162
line 162: function Execute($zf_sql, $zf_limit = false, $zf_cache = false, $zf_cachetime=0) {

PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 240
line 240: } else {
line 241: $time_start = explode(' ', microtime());

PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 161
line 161: empty
line 162: function Execute($zf_sql, $zf_limit = false, $zf_cache = false, $zf_cachetime=0) {

PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 249
line 249: $obj->EOF = false;

PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 246
line 246: $obj->resource = $zp_db_resource;

PHP Fatal error: Maximum execution time of 30 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 251
line 251: if ($zp_result_array) {

PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 243
line 243: if (!$this->db_connected) $this->set_error('0', DB_ERROR_NOT_CONNECTED);

PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\classes\db\mysql\query_factory.php on line 250
line 250: $zp_result_array = @mysql_fetch_array($zp_db_resource);

PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\functions\functions_gvcoupons.php on line 75
line 75: $id1=substr($ccid, $random_start,$length);

PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\HostingSpaces\wwwroot\v2\includes\functions\functions_gvcoupons.php on line 82
line 82: if ($rs->RecordCount() == 0) $good_result = 1;


22 Sep 2010, 4:14 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Create Account PHP 500 error

Looks like your database engine is extremely slow.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

23 Sep 2010, 9:27 AM
#3
karimm avatar

karimm

New Zenner

Join Date:
Nov 2008
Posts:
53
Plugin Contributions:
0

Re: Create Account PHP 500 error

Hello Drbyte,

thank you for your reply, i have enabled display parse Time:

Parse Time: 0.481 - Number of Queries: 218 - Query Time: 0.12301582409668

i tought my website was fast, but how can i speed up the database engine ? database type=myisam and the collaction= utf8_general_ci.

My my.ini setting

"[client]
port=3306

[mysql]
default-character-set=utf8
port=3306
character-set-server=utf8
collation-server=utf8_general_ci
sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"
max_connections=100
query_cache_size=0
table_cache=256
tmp_table_size=9M
thread_cache_size=8
myisam_max_sort_file_size=100G
myisam_sort_buffer_size=18M
key_buffer_size=11M
read_rnd_buffer_size=256K
sort_buffer_size=256K
innodb_additional_mem_pool_size=2M
innodb_flush_log_at_trx_commit=1
innodb_log_buffer_size=1M
innodb_buffer_pool_size=18M
innodb_log_file_size=10M
innodb_thread_concurrency=10

regards,

23 Sep 2010, 9:58 AM
#4
karimm avatar

karimm

New Zenner

Join Date:
Nov 2008
Posts:
53
Plugin Contributions:
0

Re: Create Account PHP 500 error

These are my php.ini setting, only the settings that are enabled :D

engine = On
zend.ze1_compatibility_mode = off
asp_tags = Off
precision = 14
y2k_compliance = On
output_buffering = on
zlib.output_compression = Off
unserialize_callback_func=
serialize_precision = 100
allow_call_time_pass_reference = Off
safe_mode = Off
safe_mode_gid = Off
safe_mode_include_dir =
safe_mode_exec_dir =
safe_mode_allowed_env_vars = PHP_
safe_mode_protected_env_vars = LD_LIBRARY_PATH
open_basedir =
disable_functions =
disable_classes =
expose_php = On
max_input_time = 60
;max_input_nesting_level = 64
memory_limit = 128M
error_reporting = "E_ALL & ~E_DEPRECATED"
display_errors = Off
display_startup_errors = Off
log_errors_max_len = 1024
ignore_repeated_errors = Off
ignore_repeated_source = Off
report_memleaks = On
track_errors = Off
variables_order = "GPCS"
register_globals = Off
register_long_arrays = Off
register_argc_argv = Off
auto_globals_jit = On
post_max_size = 8M
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
auto_prepend_file =
auto_append_file =
default_mimetype = "text/html"
default_charset = "UTF-8"
always_populate_raw_post_data = On
doc_root =
user_dir =
enable_dl = off
file_uploads = On
upload_max_filesize = 2M
max_file_uploads = 20
allow_url_fopen = On
allow_url_include = Off
default_socket_timeout = 60
upload_tmp_dir="C:\Windows\Temp"
session.save_path = C:\Windows\Temp
cgi.fix_pathinfo = 1
html_errors = Off
log_errors = On
error_log = C:\Windows\Temp\PHP_via_FastCGI_errors.log
cgi.force_redirect = 0
fastcgi.impersonate = 1
fastcgi.logging = 0
max_execution_time = 30
extension_dir = "C:\Program Files (x86)\PHP\ext"
date.timezone = "Europe/Amsterdam"
define_syslog_variables = Off
SMTP = 127.0.0.1
smtp_port = 25
sql.safe_mode = Off
odbc.allow_persistent = On
odbc.check_persistent = On
odbc.max_links = -1
odbc.defaultlrl = 4096
odbc.defaultbinmode = 1
mysql.allow_persistent = off
mysql.max_persistent = -1
mysql.max_links = -1
mysql.default_port =
mysql.default_socket =
mysql.default_host =
mysql.default_user =
mysql.default_password =
mysql.connect_timeout = 60
mysql.trace_mode = off
mysqli.max_links = -1
mysqli.default_port = 3306
mysqli.default_socket =
mysqli.default_host = 127.0.0.1
mysqli.default_user =
mysqli.default_user =
mysqli.reconnect = on
session.save_handler = files
session.use_cookies = 1
session.name = PHPSESSID
session.auto_start = 0
session.cookie_lifetime = 0
session.cookie_path = /
session.cookie_domain =
session.cookie_httponly =
session.serialize_handler = php
session.gc_probability = 1
session.gc_divisor = 1000
session.gc_maxlifetime = 1440
session.bug_compat_42 = 0
session.bug_compat_warn = 1session.entropy_length = 0
session.entropy_file =
session.cache_limiter = nocache
session.cache_expire = 180
session.cache_expire = 180
session.use_trans_sid = 0
session.hash_function = 0
session.hash_bits_per_character = 5
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"
[PHP_MYSQLI]
extension=php_mysqli.dll
[PHP_PDO]
extension=php_pdo.dll
[PHP_SOAP]
extension=php_soap.dll
[PHP_ZIP]
extension=php_zip.dll

[PHP_WINCACHE]
extension=php_wincache.dll

extension=php_pdo_sqlsrv.dll
extension=php_sqlsrv.dll
[PHP_SNMP]
extension=php_snmp.dll
[PHP_BZ2]
extension=php_bz2.dll
[PHP_CURL]
extension=php_curl.dll
[PHP_GD2]
extension=php_gd2.dll
[PHP_GETTEXT]
extension=php_gettext.dll
[PHP_IMAP]
extension=php_imap.dll
[PHP_MBSTRING]
extension=php_mbstring.dll
[PHP_MYSQL]
extension=php_mysql.dll
[PHP_OPENSSL]
extension=php_openssl.dll
[PHP_SHMOP]
extension=php_shmop.dll
[PHP_SOCKETS]
extension=php_sockets.dll
[PHP_TIDY]
extension=php_tidy.dll
[PHP_XMLRPC]
extension=php_xmlrpc.dll
[PHP_XSL]
extension=php_xsl.dll
[PHP_EXIF]
extension=php_exif.dll
[PHP_MCRYPT]
extension=php_mcrypt.dll

23 Sep 2010, 2:50 PM
#5
karimm avatar

karimm

New Zenner

Join Date:
Nov 2008
Posts:
53
Plugin Contributions:
0

Re: Create Account PHP 500 error

Drbyte can you please point me in the right direction ?

23 Sep 2010, 2:56 PM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Create Account PHP 500 error

When did this "start" happening?
What addons do you have installed?
What customizations have you made to the site?
What version of Zen Cart?

actually, there are dozens of questions you've not answered. Click "Reply" below and answer the questions above and all the questions asked in the "Posting Tips" section of that screen.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

23 Sep 2010, 4:56 PM
#7
karimm avatar

karimm

New Zenner

Join Date:
Nov 2008
Posts:
53
Plugin Contributions:
0

Re: Create Account PHP 500 error

What version of Zen Cart?
Version V1.3.8a

When did this "start" happening?
I dont know exactly, i thought it happend because i moved the website to a new server.
But now i see it also happends on the old server.

What addons do you have installed?
admin_login_as_customer_v2-1
ask_a_question_1-8
best_sellers_page_Alpha2
better_together_2-0
categories_dressing_2-7-3
change_product_name_to_proper_case_1
cold_steel_template_v1-0
column_divider_pro_cdp_v0-4
column_layout_grid_for_product_listing_1-3-8
cross_sell__just_another_cross_sell_mod_rev186
cross_sell_advanced
css_horizontal_dynamic_menu_pauls_edition_1-1
debug_error_logging_utility_1-0
dutch_languagepack_zencart138av20081016
export_shipping_information_1-2-4
german_language_pack_20081111
google_mapinator_0-12
ideal_sitebox
image-handler_2.0-zc12
improved_attributes_controller_1-1b
improved_sitemap_display_1-0-1
jscroller_sidebox_package_v1-0-1
languagecurrency_links_in_header_1-0
Manufacturers All - 1
master_password
module_manager_rev16zip
multilanguage_ezpages_1-3-0-5v2-02
multisite_admin_tools_0.2
multisite_module_Beta0-4-1
product_filter_by_attribute_and_price_range_0-7
promo_better
recently_viewed_items_1-0
rss_feed_2-1-4
scheduled_events_1-3-8a
security_patch_v138_20090619
sitemapxml__formerly_google_sitemap_2-1-0
sitemapxml_ezpages
smart_backgrounds_2-1-1
stock_by_attributes_4-7MULTIADD
super_orders_2-0rev47
tabbed_products_pro_v1-05
utf_support_for_zencart_1-0-1
zen_lightbox_1-5
expiring sales
database cache

Website is hosted on a dedicated Server with only a few other websites.
Specs: Quadcore Intel 5310 proc, 2gb mem, sas 3gb harddrives.

23 Sep 2010, 5:53 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Create Account PHP 500 error

I'm guessing your problem is related to one of your zillion addons.
Test a fresh install of the latest version and see if it happens.
If the new version doesn't have the same problem, then work on upgrading, and testing between each addon you install.
If the new version does have the same problem, then you'll have to sort out the problem with your hosting company.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

24 Sep 2010, 8:57 AM
#9
karimm avatar

karimm

New Zenner

Join Date:
Nov 2008
Posts:
53
Plugin Contributions:
0

Re: Create Account PHP 500 error

I will install a fresh zen-cart to check if the problems remain or if the problems are due to the added add-ons.

Thanks for you time.

Regards,

Martijn

28 Sep 2010, 9:19 PM
#10
karimm avatar

karimm

New Zenner

Join Date:
Nov 2008
Posts:
53
Plugin Contributions:
0

Re: Create Account PHP 500 error

I have installed a fresh version of V1.3.8a and it works fine.
So the server config is oke.

I'am really lost and can't fix it because i don't know php so i can't debug it.

Is there some one with some spare time who knows what he is doing and wants to earn 100euro ? (with paypal) :smile:

i now have redirected the 500 error to the check_out_success page (hoping my customer will stay longer the 30 seconds)

Just PM me you want to earn 100 euro.

Regards,

Martijn

28 Sep 2010, 9:41 PM
#11
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Create Account PHP 500 error

karimm:

What version of Zen Cart?
Version V1.3.8a

When did this "start" happening?
I dont know exactly, i thought it happend because i moved the website to a new server.
But now i see it also happends on the old server.

karimm:

I have installed a fresh version of V1.3.8a and it works fine.
So the server config is oke.
More specifically, it means that a FRESH install of v1.3.8a is okay too.

So, since your heavily-modified version is NOT okay, **that means your problem is in one or more of the modifications you've added/made.
**

Thus, as I said before, you need to sort out which addon is causing the problem for you:> DrByte:

I'm guessing your problem is related to one of your zillion addons.
Test a fresh install of the latest version and see if it happens.
If the new version doesn't have the same problem, then work on upgrading, and testing between each addon you install.
If the new version does have the same problem, then you'll have to sort out the problem with your hosting company.

karimm:

What addons do you have installed?
admin_login_as_customer_v2-1
ask_a_question_1-8
best_sellers_page_Alpha2
better_together_2-0
categories_dressing_2-7-3
change_product_name_to_proper_case_1
cold_steel_template_v1-0
column_divider_pro_cdp_v0-4
column_layout_grid_for_product_listing_1-3-8
cross_sell__just_another_cross_sell_mod_rev186
cross_sell_advanced
css_horizontal_dynamic_menu_pauls_edition_1-1
debug_error_logging_utility_1-0
dutch_languagepack_zencart138av20081016
export_shipping_information_1-2-4
german_language_pack_20081111
google_mapinator_0-12
ideal_sitebox
image-handler_2.0-zc12
improved_attributes_controller_1-1b
improved_sitemap_display_1-0-1
jscroller_sidebox_package_v1-0-1
languagecurrency_links_in_header_1-0
Manufacturers All - 1
master_password
module_manager_rev16zip
multilanguage_ezpages_1-3-0-5v2-02
multisite_admin_tools_0.2
multisite_module_Beta0-4-1
product_filter_by_attribute_and_price_range_0-7
promo_better
recently_viewed_items_1-0
rss_feed_2-1-4
scheduled_events_1-3-8a
security_patch_v138_20090619
sitemapxml__formerly_google_sitemap_2-1-0
sitemapxml_ezpages
smart_backgrounds_2-1-1
stock_by_attributes_4-7MULTIADD
super_orders_2-0rev47
tabbed_products_pro_v1-05
utf_support_for_zencart_1-0-1
zen_lightbox_1-5
expiring sales
database cache

Website is hosted on a dedicated Server with only a few other websites.
Specs: Quadcore Intel 5310 proc, 2gb mem, sas 3gb harddrives.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

30 Sep 2010, 5:39 PM
#12
karimm avatar

karimm

New Zenner

Join Date:
Nov 2008
Posts:
53
Plugin Contributions:
0

Re: Create Account PHP 500 error

Oke, after days of checking php code i found the error.
It's was not the code but a admin setting (error). :clap:

In the admin panel -> Gift Certificate/Coupons
Only •Coupon Admin is avaible !

the following menu's are missing
•Gift Certificates Queue
•Mail Gift Certificate
•Gift Certificates sent

When i set the following settings the ######## hit the fence.:laugh:

Configuration -> gv coupons -> New Signup Discount Coupon ID# = none
New Signup Gift Voucher Amount = 10

Drbyte, can you help me with a query to create the missing menu's

Thanks,

Regards,

martijn

30 Sep 2010, 5:48 PM
#13
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Create Account PHP 500 error

You can turn the Gift Voucher support on/off by installing or removing the ot_gv module from Admin->Modules->Order Total.
Similarly with coupons.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.