Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / Text errors in database upgrade 1.3.8a to 1.3.9g

Text errors in database upgrade 1.3.8a to 1.3.9g

Locked

Views: 1,033

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
15 Oct 2010, 2:45 AM
#1
mom0fgirls avatar

mom0fgirls

New Zenner

Join Date:
Oct 2008
Posts:
8
Plugin Contributions:
0

Text errors in database upgrade 1.3.8a to 1.3.9g

After following the instructions and successfully upgrading, the product descriptions in my database (and therefore site) have errors. I've found 2 types so far:

  1. I originally had TM symbols (™) embedded in 41 product descriptions. These were all transformed into the character sequence 'â„¢' in the upgraded database (products_description!products_description).

There are several descriptions showing this here.

  1. There are now 1188 occurrences of the character 'Â' at seemingly random locations in many product descriptions. Many of these are at end of sentences, but others are in the middle of sentences. There is no obvious character(s) that were replaced or modified during the upgrade.

There are several examples in the descriptions here.

What's the cause of these problems? Is it a bug in the upgrade process, or did I have something wrong with my descriptions?

The best way to correct this appears to be to edit the upgraded database (SQL) dump and then read it back in. Any other options?

Thanks,
Jerry

15 Oct 2010, 3:06 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Text errors in database upgrade 1.3.8a to 1.3.9g

Looks like you exported your data in one character set but imported it in another.

The usual upgrade procedure doesn't actually require an export/import of your live data. Did you move it to another server or something?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

15 Oct 2010, 3:44 AM
#3
mom0fgirls avatar

mom0fgirls

New Zenner

Join Date:
Oct 2008
Posts:
8
Plugin Contributions:
0

Re: Text errors in database upgrade 1.3.8a to 1.3.9g

The upgrade instructions said to make a new database, backup the old one, and restore into the new one. That's what I did, unfortunately overlooking the mismatch in character set.

15 Oct 2010, 4:09 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Text errors in database upgrade 1.3.8a to 1.3.9g

I need to clarify something ...

The upgrade instructions do indeed guide you to make a new database and import the old data into it ... for testing purposes.
Once testing is done, the instructions guide you to repeat the upgrade on the live database after uploading the updated files to the live site.

After that, your test database and test files are no longer needed, and your live site continues on with normal operation and sales.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.