Forums / Installing on a Linux/Unix Server / Xampp: Can't access admin login

Xampp: Can't access admin login

Locked

Views: 5,666

Results 1 to 7 of 7
This thread is locked. New replies are disabled.
1 Nov 2010, 4:42 PM
#1
meltdown avatar

meltdown

Totally Zenned

Join Date:
Jun 2006
Location:
My family and I live in Brighton, England
Posts:
947
Plugin Contributions:
0

Xampp: Can't access admin login

Hello!

I've successfully completed the following:
*Installed Xampp
*Run zc_install
*Created and accessed my new database at localhost/phpmyadmin *Accessed my store at localhost/site_new/index.php.
*Completed the mandatory security changes to the config files and admin folder

However, I am unable to access my admin login. Depending on config file settings I either get the "Hello. Thank you for loading Zen Cart" page or a blank page. This is true for admin/login.php as well.

What are the appropriate settings for the config files for Xampp? For example, should the "define('HTTP_SERVER')" & "define('DIR_FS_SQL_CACHE)" areas be altered, as well?

Thanks so much!!

1 Nov 2010, 6:37 PM
#2
vger avatar

vger

Past Contributor

Join Date:
Nov 2004
Location:
Norfolk, United Kingdom
Posts:
3,189
Plugin Contributions:
0

Re: Xampp: Can't access admin login

The install probably did not write data to the admin/includes/configure.php file.

Use the root includes/configure.php file entries as a guide, but remember that they are different files.

Vger

2 Nov 2010, 7:01 AM
#3
meltdown avatar

meltdown

Totally Zenned

Join Date:
Jun 2006
Location:
My family and I live in Brighton, England
Posts:
947
Plugin Contributions:
0

Re: Xampp: Can't access admin login

Hi - Thanks for the reply.

Re-install... still unsuccessful. Accessing my store or admin file displays the "Hello. Thank you for loading Zen Cart" page. Additionally, it states that DIR_FS_CATALOG not valid or not set.

I've installed my Xampp on C: drive. I assume my physical path to be as follows:

C:/xampp/htdocs/site_new

What should my DIR_FS_CATALOG be?

Variations of the following all errors:

define('DIR_FS_CATALOG', '/htdocs/site_new/');

Thanks

2 Nov 2010, 7:05 AM
#4
meltdown avatar

meltdown

Totally Zenned

Join Date:
Jun 2006
Location:
My family and I live in Brighton, England
Posts:
947
Plugin Contributions:
0

Re: Xampp: Can't access admin login

MeltDown:

Hi - Thanks for the reply.

Re-install... still unsuccessful. Accessing my store or admin file displays the "Hello. Thank you for loading Zen Cart" page. Additionally, it states that DIR_FS_CATALOG not valid or not set.

I've installed my Xampp on C: drive. I assume my physical path to be as follows:

C:/xampp/htdocs/site_new

What should my DIR_FS_CATALOG be?

Variations of the following all errors:

define('DIR_FS_CATALOG', '/htdocs/site_new/');

Thanks
Now I can access the admin login page but attempting to enter throws the following error:

Object not found!

The requested URL was not found on this server

Entering the store url throws this error:

1146 Table 'test_db.configuration' doesn't exist
in:
[select configuration_key as cfgkey, configuration_value as cfgvalue from configuration]

2 Nov 2010, 7:14 AM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Xampp: Can't access admin login

1146 Table 'test_db.configuration' doesn't existThat's telling you that the table named "configuration" cannot be found in the database named "test_db", as specified in your /includes/configure.php file. So, either you've supplied the wrong database name, or the wrong db-prefix, or haven't actually run zc_install to build the database yet.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

2 Nov 2010, 1:22 PM
#6
meltdown avatar

meltdown

Totally Zenned

Join Date:
Jun 2006
Location:
My family and I live in Brighton, England
Posts:
947
Plugin Contributions:
0

Re: Xampp: Can't access admin login

DrByte:

That's telling you that the table named "configuration" cannot be found in the database named "test_db", as specified in your /includes/configure.php file. So, either you've supplied the wrong database name, or the wrong db-prefix, or haven't actually run zc_install to build the database yet.
Yep, I left the prefix zen_ out of the equation - Thanks Doc.

Now I see the "Congratulations! You have successfully installed...", although the stylesheet.css is obviously not being called.

Any idea on the Object not found! error?

Thanks

2 Nov 2010, 7:03 PM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Xampp: Can't access admin login

Just a guess, but maybe you've made incorrect edits when renaming your admin folder?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.