Zen Cart Logo
Forums / General Questions / Coupon Admin - 1064 You have an error in your SQL syntax

Coupon Admin - 1064 You have an error in your SQL syntax

Locked

Views: 1,035

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
1 Nov 2010, 10:28 PM
#1
tobindonal avatar

tobindonal

New Zenner

Join Date:
Oct 2010
Location:
ireland
Posts:
23
Plugin Contributions:
0

Coupon Admin - 1064 You have an error in your SQL syntax

1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-0,' at line 1
in:
[select coupon_id, coupon_code, coupon_amount, coupon_type, coupon_start_date,coupon_expire_date,uses_per_user,uses_per_coupon,restrict_to_products, restrict_to_categories, date_created,date_modified, coupon_active, coupon_zone_restriction from coupons where coupon_active='Y' and coupon_type != 'G' limit -0, ]
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

Hi,
I am a newbie, with very little knowledge of sql etc :(

Version 1.3.9h upgraded recently from g.

add-on installed is jgallery

all changes made to site have been using the override with my own template.

I only recently started on zen cart and have been trying every aspect of the cart before going live...

i tried this evening to open coupon admin as part of this process and got the error message above...i'm lost... can anyone help me with this?

i went through the upgrade process from 1.3.9g to 1.3.9h a couple of days back, and it all seemed to work ok, so im unsure whether or not this has caused the issue. i don't know because this is my first time trying to use the coupon admin feature

thanks

donal

1 Nov 2010, 11:22 PM
#2
tobindonal avatar

tobindonal

New Zenner

Join Date:
Oct 2010
Location:
ireland
Posts:
23
Plugin Contributions:
0

Re: Coupon Admin - 1064 You have an error in your SQL syntax

just to add to this its only the "coupon admin" that i have an issue with from admin - gift certificate/coupons

the other options:
gift certificate queue
mail gift certificate
gift certificate sent
all seem to be functioning fine...

i can also purchase the gift certs from the cart and they populate the database...i have logged into sql and checked that all fields in the database are ok using "table check" etc.

1 Nov 2010, 11:28 PM
#3
tobindonal avatar

tobindonal

New Zenner

Join Date:
Oct 2010
Location:
ireland
Posts:
23
Plugin Contributions:
0

Re: Coupon Admin - 1064 You have an error in your SQL syntax

ok...
apologies for the post...
i figured it out, not that i completely understand it :no:

basically because under GV Coupons in the configuration, i had no values populated for:

Maximum Discount Coupons Per Page
Maximum Discount Coupon Report Results Per Page

once i populated values, not that i completely understand what the values do...the issue is resolved...

donal