Zen Cart Logo
Forums / General Questions / 1064 error on Send E-Mail Customer Page

1064 error on Send E-Mail Customer Page

Locked

Views: 1,463

Results 1 to 14 of 14
This thread is locked. New replies are disabled.
22 Nov 2010, 2:10 PM
#1
cinbou avatar

cinbou

New Zenner

Join Date:
Aug 2007
Posts:
91
Plugin Contributions:
0

1064 error on Send E-Mail Customer Page

I'm trying to e-mail all my customers to notify them of an upcoming sale. However, I get the following error message on the 'Send E-mail to Customers Page"

1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'as s left join zen_customers as c on c.customers_id = s.customers_id' at line 1
in:
[select c.customers_firstname, c.customers_lastname, s.email_address as customers_email_address from as s left join zen_customers as c on c.customers_id = s.customers_id ]
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

Any idea how to fix it?

Thanks!

22 Nov 2010, 3:50 PM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: 1064 error on Send E-Mail Customer Page

Any idea how to fix it?
Not from the information you have provided
Zen Ver
server type OS
php ver
mysql ver

http://www.zen-cart.com/forum/faq.php

23 Nov 2010, 12:19 AM
#3
cinbou avatar

cinbou

New Zenner

Join Date:
Aug 2007
Posts:
91
Plugin Contributions:
0

Re: 1064 error on Send E-Mail Customer Page

Thanks for the reply. Below is the additional info:

Zencart Version: 1.3.9h
MySQL: 5.1.47
PHP: 5.2.14
OS: Linux

23 Nov 2010, 12:33 AM
#4
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: 1064 error on Send E-Mail Customer Page

OK, You should have no platform version issues

Do any emails get sent when an order is placed?

If yes, As this is an admin function, one can check the admin files for errors but it is easier to just reload ALL the /admin files from a fresh distribution with your FTP Client
This will replace all the files and if using a good FTP client any errors will be reported

23 Nov 2010, 12:40 AM
#5
cinbou avatar

cinbou

New Zenner

Join Date:
Aug 2007
Posts:
91
Plugin Contributions:
0

Re: 1064 error on Send E-Mail Customer Page

Yes, e-mail do get sent to customers when orders are placed. So, what you are saying is that all I need to do is reload the "Admin" files to my new "renamed" admin folder?

I'll give it a try.

23 Nov 2010, 12:56 AM
#6
cinbou avatar

cinbou

New Zenner

Join Date:
Aug 2007
Posts:
91
Plugin Contributions:
0

Re: 1064 error on Send E-Mail Customer Page

Just did a fresh install of the Admin folder and I'm still getting the same error?

What else can I do to figure it out?

23 Nov 2010, 1:06 AM
#7
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: 1064 error on Send E-Mail Customer Page

Searh this forum for "1064 error"

Check the similar posts listed at the bottom of this thread

23 Nov 2010, 1:39 AM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 1064 error on Send E-Mail Customer Page

Looks like you had the Newsletter Subscribe addon installed at one point but have hacked out various traces of it incorrectly.
You'll need to fix that bad query you've got in the query_builder table in your database.

23 Nov 2010, 2:52 AM
#9
cinbou avatar

cinbou

New Zenner

Join Date:
Aug 2007
Posts:
91
Plugin Contributions:
0

Re: 1064 error on Send E-Mail Customer Page

Thanks! My site was hacked before I moved over to 1.3.9h. I suspect that had something to do with it as my e-mail is now working (after deleting the newsletter details), but the "from" in the e-mail is automatically populating as the "hackers" e-mail.

I can change the "from" email address when I send an e-mail to customers, but do you know where I would go to replace the "hackers" e-mail with my own?

Thanks so much!

23 Nov 2010, 4:12 AM
#10
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 1064 error on Send E-Mail Customer Page

Admin->Configuration->Email Options

7 Dec 2010, 4:50 PM
#11
chriscops avatar

chriscops

New Zenner

Join Date:
Mar 2010
Posts:
18
Plugin Contributions:
0

Re: 1064 error on Send E-Mail Customer Page

DrByte:

Looks like you had the Newsletter Subscribe addon installed at one point but have hacked out various traces of it incorrectly.
You'll need to fix that bad query you've got in the query_builder table in your database.

I have this same problem. I installed and uninstalled the newsletter subscribe addon. What do I need to do to fix the query_builder table in the database?

copsprotectiveservices.com

version 1.3.9.h
PHP Version: 5.2.14

7 Dec 2010, 7:28 PM
#12
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 1064 error on Send E-Mail Customer Page

chriscops:

I have this same problem. I installed and uninstalled the newsletter subscribe addon. What do I need to do to fix the query_builder table in the database?
Delete the bad entries, or edit them to match the original entries. The original entries can be found in the /zc_install/sql/mysql_zencart.sql file.

7 Dec 2010, 10:23 PM
#13
chriscops avatar

chriscops

New Zenner

Join Date:
Mar 2010
Posts:
18
Plugin Contributions:
0

Re: 1064 error on Send E-Mail Customer Page

Thanks! I was just a little nervous about going in there and messing with the database.

7 Dec 2010, 10:27 PM
#14
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 1064 error on Send E-Mail Customer Page

Rightly so :blush:
Do a database backup first ;)