Zen Cart Logo
Forums / Basic Configuration / All of My Images have Disappeared!

All of My Images have Disappeared!

Locked

Views: 1,000

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
28 Nov 2010, 12:29 AM
#1
lavs avatar

lavs

New Zenner

Join Date:
Mar 2009
Posts:
85
Plugin Contributions:
0

All of My Images have Disappeared!

Today, I have no images of my products. I have had no problems until this morning, my hosting service says it's not them :(

When I try to add an image in Admin, I get no picture in the preview, just the 'broken' image icon. My store doesn't show any pictures at all, just the name of the product x 2.

Images have been uploaded successfully (until today) in my zen--cart/images folder. They are all still there, but I don't know what steps to take to fix this. Any suggestions?

My site is http://vintageknits.com/zen-cart

28 Nov 2010, 12:35 AM
#2
nigelt74 avatar

nigelt74

Totally Zenned

Join Date:
Sep 2005
Location:
Waikato, New Zealand
Posts:
1,558
Plugin Contributions:
1

Re: All of My Images have Disappeared!

lavs:

Today, I have no images of my products. I have had no problems until this morning, my hosting service says it's not them :(

When I try to add an image in Admin, I get no picture in the preview, just the 'broken' image icon. My store doesn't show any pictures at all, just the name of the product x 2.

Images have been uploaded successfully (until today) in my zen--cart/images folder. They are all still there, but I don't know what steps to take to fix this. Any suggestions?

My site is http://vintageknits.com/zen-cart

What version of zen-cart are you running, have you changed anything recently?

when i try to view an image i get this error

500 Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator www@ and inform them of the time the error occurred, and anything you might have done that may have caused the error.
Reason: Error parsing access file

28 Nov 2010, 12:37 AM
#3
lavs avatar

lavs

New Zenner

Join Date:
Mar 2009
Posts:
85
Plugin Contributions:
0

Re: All of My Images have Disappeared!

Currently using Zen Cart 1.3.8a; my ISP was supposed to be installing the latest version for me, doesn't seem to have been completed (or even started from what I can see). Could that be causing the problem?

28 Nov 2010, 12:42 AM
#4
nigelt74 avatar

nigelt74

Totally Zenned

Join Date:
Sep 2005
Location:
Waikato, New Zealand
Posts:
1,558
Plugin Contributions:
1

Re: All of My Images have Disappeared!

lavs:

Currently using Zen Cart 1.3.8a; my ISP was supposed to be installing the latest version for me, doesn't seem to have been completed (or even started from what I can see). Could that be causing the problem?

Not sure, but it rules out the issue i thought it might be :)

28 Nov 2010, 1:59 AM
#5
nigelt74 avatar

nigelt74

Totally Zenned

Join Date:
Sep 2005
Location:
Waikato, New Zealand
Posts:
1,558
Plugin Contributions:
1

Re: All of My Images have Disappeared!

lavs:

Currently using Zen Cart 1.3.8a; my ISP was supposed to be installing the latest version for me, doesn't seem to have been completed (or even started from what I can see). Could that be causing the problem?

ask them if they have changed anything on the server, like upgrading php or something, because it shouldn't just break, if you haven't made any changes

28 Nov 2010, 2:37 AM
#6
lavs avatar

lavs

New Zenner

Join Date:
Mar 2009
Posts:
85
Plugin Contributions:
0

Re: All of My Images have Disappeared!

I will check on that Monday, when someone with knowledge is available. I'm pretty sure it's something on their end, despite the CS rep's assurance that it's 'Zen Cart's fault' :smile:

28 Nov 2010, 6:33 PM
#7
celtic avatar

celtic

Zen Follower

Join Date:
Feb 2010
Posts:
154
Plugin Contributions:
0

Re: All of My Images have Disappeared!

Lavs,

The 500 error is only happening when trying to access your /images folder (hence all the images missing).

Try deleting the .htaccess file that is in that folder (make a backup first) as it sounds more like a permissions thing than anything.

Maybe you tried changing access settings in your web host's control panel or something, or possibly your host did ########-up the upgrade of zen-cart, but it would still most likely be a .htaccess setting rather than a zencart one.

28 Nov 2010, 7:38 PM
#8
lavs avatar

lavs

New Zenner

Join Date:
Mar 2009
Posts:
85
Plugin Contributions:
0

Re: All of My Images have Disappeared!

thanks!! That did the trick (deleting the .htaccess file). Should I reinstall that file elsewhere, or is it ok to just delete it?

28 Nov 2010, 9:53 PM
#9
nigelt74 avatar

nigelt74

Totally Zenned

Join Date:
Sep 2005
Location:
Waikato, New Zealand
Posts:
1,558
Plugin Contributions:
1

Re: All of My Images have Disappeared!

Thats odd, the .htaccess is what i would have suggested except it wasn't included in 1.3.8 (I think), you could always try using the .htaccess from a 1.3.9 install as that has the requisite exemptions/allowances to let images work

.htaccess from 1.3.9h

#
# @copyright Copyright 2003-2010 Zen Cart Development Team
# @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
# @version $Id: .htaccess 16111 2010-04-29 22:39:02Z drbyte $
#
# This is used with Apache WebServers
#
# The following blocks direct HTTP requests to all filetypes in this directory recursively, except certain approved exceptions
# It also prevents the ability of any scripts to run. No type of script, be it PHP, PERL or whatever, can normally be executed if ExecCGI is disabled.
# Will also prevent people from seeing what is in the dir. and any sub-directories
#
# For this to work, you must include either 'All' or at least: 'Limit' and 'Indexes' parameters to the AllowOverride configuration in your apache/conf/httpd.conf file.
# Additionally, if you want the added protection offered by the OPTIONS directive below, you'll need to add 'Options' to the AllowOverride list, if 'All' is not specified. 
# Example:
#<Directory "/usr/local/apache/htdocs">
#  AllowOverride Limit Options Indexes
#</Directory>
###############################

# deny *everything*
<FilesMatch ".*">
  Order Allow,Deny
  Deny from all
</FilesMatch>

# but now allow just *certain* necessary files:
<FilesMatch ".*\.(jpe?g|JPE?G|gif|GIF|png|PNG|swf|SWF)$" >
  Order Allow,Deny
  Allow from all
</FilesMatch>

IndexIgnore */*


## NOTE: If you want even greater security to prevent hackers from running scripts in this folder, uncomment the following line (if your hosting company will allow you to use OPTIONS):
# OPTIONS -Indexes -ExecCGI