Zen Cart Logo
Forums / All Other Contributions/Addons / Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

Views: 84,097

Results 21 to 40 of 660
9 Dec 2010, 8:16 PM
#21
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

cyberian37:

I think that the installation is very simple and I put all files at the right place, that should not be an issue at all. Well the language file issue points at something missing that Zen Cart can't find.. I can't see your store files.. So I am entirely unsure what the issue is..

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

9 Dec 2010, 8:19 PM
#22
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

There are NO language files in this folder.. Are you SURE you uploaded EVERYTHING??? Are the Edit Orders language files in place??

cyberian37:

Well I am using lite_red template. Actually yes I was thinking that must be something wrong using that template together with this module, but the fact it that this template is not installed in admin area and the fault is appear only in admin area. Maybe I did merge wrong my files, probably, but as more I am thinking about I don't know where, which make me mad ... :frusty:

And I have own renamed admin area, that's the first thing I did after installation.

I put there my original files, everything working just fine, no error anywhere.

Would you be so kind to review my last recent changes.

Thank you very much in advance.

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

9 Dec 2010, 8:26 PM
#23
cyberian37 avatar

cyberian37

New Zenner

Join Date:
Dec 2010
Location:
Well... across all the world, a while here then there...
Posts:
13
Plugin Contributions:
0

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

Ok here is my complete admin folder. The configuration is deleted only because I do publish the file here. The rest is exactly as it is.

http://http://www.easy-share.com/1913239531/myadminfolder.zip

Thank you.

9 Dec 2010, 9:53 PM
#24
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

cyberian37:

Ok here is my complete admin folder. The configuration is deleted only because I do publish the file here. The rest is exactly as it is.

http://http://www.easy-share.com/1913239531/myadminfolder.zip

>  
> Thank you.Not for nothing, but I don't have free time to spare to examine your entire admin folder in detail.. A quick glance at the file contents and I noticed that I didn't see an **orders.php** file.. 
 
I have provided you with enough guidance as to the nature of your problem and possible fixes.. My suggestion at this point is for you to back out all of the Edit Order files and edits you have made and start over.. 
 
The error you have is either due to an incorrect/incomplete Edit Orders install or because there is another issue in your store which is creating the missing language file errors. Edit Orders was tested by a number of folks prior to being submitted to the downloads, and it works PERFECTLY out the box..

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

9 Dec 2010, 10:18 PM
#25
cyberian37 avatar

cyberian37

New Zenner

Join Date:
Dec 2010
Location:
Well... across all the world, a while here then there...
Posts:
13
Plugin Contributions:
0

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

Well orders.php it's there. But thank you anyway, I guess that's I miss out something ... probably.

9 Dec 2010, 10:34 PM
#26
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

cyberian37:

Well orders.php it's there. But thank you anyway, I guess that's I miss out something ... probably.
Seriously here's what I suggest.. Something is WRONG with your install and if I had free time I really would take a detailed look.. (honest!:smile:)

Try the following..

  • Roll back to the version of your store BEFORE you installed Edit Orders
  • TEST.. Make sure EVERYTHING works..
  • Re-download Edit Orders (your download MAY be corrupted)
  • Re-Install Edit Orders.
  • TEST..
  • Let me know what your result is..
    BTW.. you did not say..

Are you running Zen Cart v1.3.9??
Are you running any other mods??

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

9 Dec 2010, 11:24 PM
#27
cyberian37 avatar

cyberian37

New Zenner

Join Date:
Dec 2010
Location:
Well... across all the world, a while here then there...
Posts:
13
Plugin Contributions:
0

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

Well I can see that there is something wrong, just can't figure out what that could be. I did re-installation atleast 50 time and spend 2 days on it ... I will just give up, because I can't try anything else as I did everything so far.

I just made the last try now and it say the same as in the beginning :

[09-Dec-2010 16:52:54] PHP Warning:  require(includes/languages/1.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/xxxx/includes/init_includes/init_languages.php on line 35
[09-Dec-2010 16:52:54] PHP Warning:  require(includes/languages/1.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/xxxx/includes/init_includes/init_languages.php on line 35
[09-Dec-2010 16:52:54] PHP Fatal error:  require() [<a href='function.require'>function.require</a>]: Failed opening required 'includes/languages/1.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/xxxx/includes/init_includes/init_languages.php on line 35

It's a bit shame, but what more is left I don't know. Maybe I will try to apply this mode into the fresh installation to see if that will work for me, to ensure I done my part correct. If that will work then there must be something.

Yes I run 1.3.9h version.

Actually I have Captcha and Backup mods installed.

It's quite strange, the fault occur only if I did edit or add something new into the current order, otherwise everything is ok.

Thanks for your effort.

9 Dec 2010, 11:32 PM
#28
clydejones avatar

clydejones

Deceased

Join Date:
Nov 2005
Location:
Colorado Springs, CO USA
Posts:
7,017
Plugin Contributions:
12

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

cyberian37:

Well I can see that there is something wrong, just can't figure out what that could be. I did re-installation atleast 50 time and spend 2 days on it ... I will just give up, because I can't try anything else as I did everything so far.

I just made the last try now and it say the same as in the beginning :

[09-Dec-2010 16:52:54] PHP Warning: require(includes/languages/1.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/xxxx/includes/init_includes/init_languages.php on line 35
[09-Dec-2010 16:52:54] PHP Warning: require(includes/languages/1.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/xxxx/includes/init_includes/init_languages.php on line 35
[09-Dec-2010 16:52:54] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required 'includes/languages/1.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/xxxx/includes/init_includes/init_languages.php on line 35

> 
> It's a bit shame, but what more is left I don't know. Maybe I will try to apply this mode into the fresh installation to see if that will work for me, to ensure I done my part correct. If that will work then there must be something.
> 
> Yes I run 1.3.9h version.
> 
> Actually I have Captcha and Backup mods installed.
> 
> It's quite strange, the fault occur only if I did edit or add something new into the current order, otherwise everything is ok.
> 
> Thanks for your effort.

Zen Cart is looking for a file named **1.php** which should be located in includes/languages

You need to check the language pack(s) you are using and upload the missing file.

NOTE: We are sorry that Clyde is no longer with us.
We are grateful for all his contributions to the Zen Cart community.

9 Dec 2010, 11:36 PM
#29
cyberian37 avatar

cyberian37

New Zenner

Join Date:
Dec 2010
Location:
Well... across all the world, a while here then there...
Posts:
13
Plugin Contributions:
0

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

I already done that and I see that there should be a file called "1.php" as it says, but if I put there such file (just copy and rename english.php) as I have not any file like that, then it ill show the error say englishenglish.php missing, even "english.php" is there together with that file.

So there must be something else which I don't know...

Thanks.

10 Dec 2010, 1:07 AM
#30
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

cyberian37:

I already done that and I see that there should be a file called "1.php" as it says, but if I put there such file (just copy and rename english.php) as I have not any file like that, then it ill show the error say englishenglish.php missing, even "english.php" is there together with that file.

So there must be something else which I don't know...

Thanks.
And as I have stated repeatedly this is likely because something else you've installed is the REAL root of the issue..

cyberian37:

It's a bit shame, but what more is left I don't know. Maybe I will try to apply this mode into the fresh installation to see if that will work for me, to ensure I done my part correct. If that will work then there must be something.This is my next suggestion.. Can't get to the heart of the matter unless it's CLEAR which other module is causing the conflict..

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

10 Dec 2010, 8:24 PM
#31
cyberian37 avatar

cyberian37

New Zenner

Join Date:
Dec 2010
Location:
Well... across all the world, a while here then there...
Posts:
13
Plugin Contributions:
0

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

Well it's working now, but what come up is an other problem in case I do try to change Status. Actually I can't, because otherwise come a page says this :

1054 Unknown column 'track_id1' in 'field list'
in:
[INSERT INTO orders_status_history (orders_id, orders_status_id, date_added, customer_notified, comments, track_id1, track_id2, track_id3, track_id4, track_id5) VALUES ('1', '3', now(), '1', '', '', '', '', '', '')]
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

In fact if I don' type anything into the Comments, the page just refresh and say that is updated, but it not. And if I try to type something into the Comments then become that Error.

Any idea ?

10 Dec 2010, 8:36 PM
#32
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

[/quote]

cyberian37:

Well it's working now
So for the benefit of the community what WAS the real issue that caused your language file issues??

cyberian37:

but what come up is an other problem in case I do try to change Status. Actually I can't, because otherwise come a page says this :

1054 Unknown column 'track_id1' in 'field list'
in:
[INSERT INTO orders_status_history (orders_id, orders_status_id, date_added, customer_notified, comments, track_id1, track_id2, track_id3, track_id4, track_id5) VALUES ('1', '3', now(), '1', '', '', '', '', '', '')]
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

>  
> Any idea ?
 
Did you install the Ty Package Tracker files that come with Edit Orders??
 
Do you have Ty Package Tracker module installed (NOT part of the Edit Orders files)??
 
Did you set the Edit Orders "Ty Package Tracker Module Switch" to TRUE??
 
From the Edit Orders readme:
> **Ty Package Tracker Users** 
> - >
- If you have installed **Ty Package Tracker** and would like to use **Ty Package Tracker** with **Edit Orders** please read the "How to Use" tab
>
 
AND..
 
> Ty Package Tracker Files (**You MUST have Ty Package Tracker installed to use the Ty Package Tracker integration features**)
> 
> - >
- If you are running Ty Package Tracker, install the **3_TyPackage_Tracker_Files** files. Go to Admin > Configuration > Edit Orders. Then simply set the Ty Package Track flag to "True" to activate the Ty Package Tracker fields in Edit Orders.
> 
 
From the Edit Orders admin:
> If you have the Ty Package Tracker module installed, set this option to TRUE so that Ty Package Tracker fields will display in Edit Orders

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

13 Dec 2010, 4:34 PM
#33
dvdtitan avatar

dvdtitan

New Zenner

Join Date:
Apr 2007
Posts:
87
Plugin Contributions:
0

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

I had the simple edit order smod installed. I have uninstalled it and installed this mod, however when i do so it kills my admin geeraitng the following error in the cache:

[13-Dec-2010 15:10:25] PHP Fatal error:  Cannot redeclare zen_db_scrub_in() (previously declared in /admin/includes/functions/extra_functions/super_orders_functions.php:142) in /admin/includes/functions/extra_functions/common_orders_functions.php on line 53
```I think this may be becuase of edits made to general.php (admin) and orders.php (admin) that i made when installing simple edit orders but i can't figure out what i need to change.
13 Dec 2010, 4:48 PM
#34
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

DVDTitan:

I had the simple edit order smod installed. I have uninstalled it and installed this mod, however when i do so it kills my admin geeraitng the following error in the cache:

[13-Dec-2010 15:10:25] PHP Fatal error: Cannot redeclare zen_db_scrub_in() (previously declared in /admin/includes/functions/extra_functions/[B]super_orders_functions.php[/B]:142) in /admin/includes/functions/extra_functions/[B]common_orders_functions.php[/B] on line 53

 
If you look at the error it tells you EXACTLY which file(s) are calling the error..
 
> Cannot redeclare zen_db_scrub_in() (previously declared in /admin/includes/functions/extra_functions/**super_orders_functions.php**:142) in /admin/includes/functions/extra_functions/**common_orders_functions.php** on line 53
In this case it's a Super Orders file (**super_orders_functions.php**) and a file from this mod (**common_orders_functions.php**).. 
 
Sounds like you are running one of the Super Order v.2.0 varieties -- dunno which specific SO version you are running.. I do know this error would only occur if you are runing a version of Super Orders prior to the upcoming Super Orders v3.0 (currently submitted pending approval)
 
The readme in Edit Orders v3.0 Rev1a has a specific section which covers Super Orders users. I posted about this in this thread as well..
 
<http://www.zen-cart.com/forum/showpost.php?p=968098&postcount=3>
 
If you are not using the v3.0 Rev1a files, you need to download them and follow the instructions for doing the required Super Orders update to make this error stop..

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

13 Dec 2010, 5:19 PM
#35
dvdtitan avatar

dvdtitan

New Zenner

Join Date:
Apr 2007
Posts:
87
Plugin Contributions:
0

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

Thanks for this info. I have done this but the admin still breaks this time with a different error message:

[13-Dec-2010 17:17:13] PHP Fatal error:  Cannot redeclare zen_get_payment_type_name() (previously declared in /admin/includes/functions/extra_functions/super_orders_functions.php1:32) in /adminincludes/functions/extra_functions/super_orders_functions.php on line 41

Any idea what could be causing this?

13 Dec 2010, 6:16 PM
#36
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

DVDTitan:

Thanks for this info. I have done this but the admin still breaks this time with a different error message:

[13-Dec-2010 17:17:13] PHP Fatal error: Cannot redeclare zen_get_payment_type_name() (previously declared in /admin/includes/functions/extra_functions/super_orders_functions.php1:32) in /adminincludes/functions/extra_functions/super_orders_functions.php on line 41

>  
> Any idea what could be causing this?Did you install the Super Orders patch files that come with the Rev1a files????? It looks like you did and just renamed the old ones to super_orders_functions.php1. You cannot do that or you will continue to get this error.. The error is telling that there are TWO files attempting to declare the SAME function.. (which WILL continue to cause this error if you do not remove one. in this case you need to delete **super_orders_functions.php1**
 
> Cannot redeclare zen_get_payment_type_name() (previously declared in /admin/includes/functions/extra_functions/**super_orders_functions.php1**:32) in /adminincludes/functions/extra_functions/**super_orders_functions.php** on line 41
You need to REPLACE the super_orders_functions.php in your store with the one included in the Super Orders patch files that come with Edit Order v3.0 Rev1a. You CANNOT leave the old functions file in the same folder (even if you have renamed it)..

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

13 Dec 2010, 6:31 PM
#37
dvdtitan avatar

dvdtitan

New Zenner

Join Date:
Apr 2007
Posts:
87
Plugin Contributions:
0

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

jeez, i made hard work of that didn't i? It's been a long day! That sorted, will play around with it now.

Thanks for your help.

13 Dec 2010, 6:38 PM
#38
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

DVDTitan:

jeez, i made hard work of that didn't i? It's been a long day! That sorted, will play around with it now.

Thanks for your help.No worries.. Glad it's all sorted out now.. :smile:

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

14 Dec 2010, 11:05 AM
#39
dvdtitan avatar

dvdtitan

New Zenner

Join Date:
Apr 2007
Posts:
87
Plugin Contributions:
0

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

Me again :blush:

whilst i can edit orders in orders.php there is no ability to edit orders in the same way in either super orders or the Ty package tracker.

I have added all the files & SQL but there is no ability to edit through anything other than orders.php.

Am i missing something here?

14 Dec 2010, 1:17 PM
#40
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Edit Orders v3.0 for ZC 1.3.9 [Support Thread]

DVDTitan:

Me again :blush:

whilst i can edit orders in orders.php there is no ability to edit orders in the same way in either super orders or the Ty package tracker.

I have added all the files & SQL but there is no ability to edit through anything other than orders.php.

Am i missing something here?if you are talking about adding an "Edit Orders" button to Ty Package Tracker's tracker.php file, then you are right there is no such mechanism. You can try using a file comparison program and merge into tracker.php the required code from orders.php..

Frankly I never understood why Ty Package Tracker used what amounts to a "parallel" version of orders.php. The Super Orders like navigation and the Ty Package Tracker fields could have EASILY been incorporated into the default orders.php eliminating the NEED for two flavors of orders.php.

As for Super Orders.. If you uploaded the files in the Super Orders v1.3.9 patch folder and installed the SQL file, all you need to do is "turn on" Edit Orders in Super Orders and vice versa.

It looks like I inadvertently left out the step to turn on the Edit Orders buttons/icons in Super Orders. So do this:

Go to Admin > Configuration > Edit Orders. Set the "Super Orders Module Switch" to "True". This swaps the Edit Orders buttons that normally return you to orders.php to return you to super_orders.php.

THEN

Admin > Configuration > Super Orders. Set the "Edit Orders Module Switch" to "True". This will activate the buttons and icons that link Edit Orders to Super Orders.

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.