Zen Cart Logo
Forums / General Questions / Broken downloads (digital delivery)

Broken downloads (digital delivery)

Locked

Views: 721

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
15 Dec 2010, 11:00 PM
#1
motorsep avatar

motorsep

New Zenner

Join Date:
Nov 2010
Posts:
16
Plugin Contributions:
0

Broken downloads (digital delivery)

I set up a shop and it appeared to function properly.
When I tested it, I was able to download file (digital delivery) with no issues.

However, not everyone is that lucky. I'd say 70% of my customers either download ~370Mb of the file (~412Mb is the correct size) or if they download it at all, after so many attempts, they get corrupted archive.

I spoke to my hosting admin and he said there is nothing wrong on his end.

Has anyone had that issue? How can I fix the issue?

Thank you.

16 Dec 2010, 3:14 PM
#2
mprough avatar

mprough

Totally Zenned

Join Date:
Nov 2007
Location:
Woodbine, Georgia, United States
Posts:
4,288
Plugin Contributions:
39

Re: Broken downloads (digital delivery)

PHP Version
Zen Cart Version
User's browsers
Link to site

???

~Melanie

16 Dec 2010, 3:25 PM
#3
motorsep avatar

motorsep

New Zenner

Join Date:
Nov 2010
Posts:
16
Plugin Contributions:
0

Re: Broken downloads (digital delivery)

PHP Version: 5.2.14 (Zend: 2.2.0)
PHP Memory Limit: 96M
PHP Safe Mode: Off
PHP File Uploads: On
Max Size: 64M

Zen Cart v1.3.9h

FF, Chrome, Opera

http://www.steel-storm.com/shoppe

Thanks.

16 Dec 2010, 3:29 PM
#4
mprough avatar

mprough

Totally Zenned

Join Date:
Nov 2007
Location:
Woodbine, Georgia, United States
Posts:
4,288
Plugin Contributions:
39

Re: Broken downloads (digital delivery)

Maybe a timing out or max post size issue with the webhost config, try this

http://www.zen-cart.com/wiki/index.php/Downloads

Just set one up and test it. You might check your server error logs and Zen Carts debug logs for some clues as well.

~Melanie

16 Dec 2010, 3:47 PM
#5
motorsep avatar

motorsep

New Zenner

Join Date:
Nov 2010
Posts:
16
Plugin Contributions:
0

Re: Broken downloads (digital delivery)

Apache logs contain no errors, neither do broken downloads :/
Where can I find Zen Carts debug logs ?

EDIT: There is nothing that I don't know on that Wiki page you linked me to :)

How do I raise a timing out value and max post size value?

16 Dec 2010, 3:49 PM
#6
mprough avatar

mprough

Totally Zenned

Join Date:
Nov 2007
Location:
Woodbine, Georgia, United States
Posts:
4,288
Plugin Contributions:
39

Re: Broken downloads (digital delivery)

In your cache folder

16 Dec 2010, 3:56 PM
#7
motorsep avatar

motorsep

New Zenner

Join Date:
Nov 2010
Posts:
16
Plugin Contributions:
0

Re: Broken downloads (digital delivery)

Hmm..

[16-Dec-2010 10:23:12] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /*/public_html/shoppe/includes/modules/pages/download/header_php.php on line 227

if (DOWNLOAD_IN_CHUNKS != 'true') {

$zco_notifier->notify('NOTIFY_DOWNLOAD_WITHOUT_REDIRECT___COMPLETED', $origin_filename);

// This will work on all systems, but will need considerable resources

readfile(DIR_FS_DOWNLOAD . $origin_filename);    <<<<<<<<<<<< - Line 227
16 Dec 2010, 4:55 PM
#8
mprough avatar

mprough

Totally Zenned

Join Date:
Nov 2007
Location:
Woodbine, Georgia, United States
Posts:
4,288
Plugin Contributions:
39

Re: Broken downloads (digital delivery)

You server's PHP config failed to deliver the download as it timed out due to execution time.

Your webhost *might take care of this for you. If you are on a shared server with no ini file, then they will not increase for the whole server just for you.

~Melanie

16 Dec 2010, 5:53 PM
#9
vger avatar

vger

Past Contributor

Join Date:
Nov 2004
Location:
Norfolk, United Kingdom
Posts:
3,189
Plugin Contributions:
0

Re: Broken downloads (digital delivery)

A 412 Mbs file size is substantial, especially if more than one person at a time are downloading it. The download may be passed off to Apache to handle and this can tie up an enormous amount of Apache resources on the whole server - slowing down delivery of other people's sites on the same server.

You need either a VPS or full Dedicated Server for downloads of that size. Shared Hosting is not suitable.

Vger