Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / Error Msg After "Upgrade Database" clicked

Error Msg After "Upgrade Database" clicked

Locked

Views: 1,222

Results 1 to 7 of 7
This thread is locked. New replies are disabled.
19 Dec 2010, 12:44 AM
#1
scriptjunkie avatar

scriptjunkie

Totally Zenned

Join Date:
Jul 2008
Posts:
772
Plugin Contributions:
0

Error Msg After "Upgrade Database" clicked

Hi There,

I'm upgrading from 138a to 139h. I followed all the instructions and the steps in order.

When I got to the point where it was time to click on "Update Database", I clicked the button and got this error message:

1253 COLLATION 'latin1_general_ci' is not valid for CHARACTER SET 'utf8'
in:
[CREATE TABLE zen_counter_history_clean as SELECT * FROM zen_counter_history WHERE 1 GROUP BY startdate COLLATE latin1_general_ci;]

Suggestions on the issue and the resolution?

TIA :smile:

19 Dec 2010, 1:02 AM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Error Msg After "Upgrade Database" clicked

When I got to the point where it was time to click on "Update Database", I clicked the button and got this error message:
You have Evidently changed the DB to be used with UTF8 character set. If that's what you want to continue using, then change the DB_CHARSET in /zc_install/includes/installer_params.php to 'utf8' before using zc_install.

19 Dec 2010, 1:47 AM
#3
scriptjunkie avatar

scriptjunkie

Totally Zenned

Join Date:
Jul 2008
Posts:
772
Plugin Contributions:
0

Re: Error Msg After "Upgrade Database" clicked

Hi Kobra,

Thanks for the fast response :)

I never touch my database unless specifically instructed, and only when I have specific steps to follow because I'm not familiar enough with it to avoid screwing it up :P

I'm wondering if UTF8 is a default setting on my server.

At any rate, before I go make this change to that file, is there another character set I should be using in my database that's better or more universal than UTF8?

And if so, is there a tut somewhere that will help me learn how to change that in PHPMyAdmin?

TIA :smile:

19 Dec 2010, 1:52 AM
#4
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Error Msg After "Upgrade Database" clicked

At any rate, before I go make this change to that file, is there another character set I should be using in my database that's better or more universal than UTF8?
Default ZenCart is latin_swedish_ci
utf8 is also fine and it really depends upon the language you are using
And if so, is there a tut somewhere that will help me learn how to change that in PHPMyAdmin?
Googe phpmyadmin or mysql and collation

19 Dec 2010, 1:55 AM
#5
scriptjunkie avatar

scriptjunkie

Totally Zenned

Join Date:
Jul 2008
Posts:
772
Plugin Contributions:
0

Re: Error Msg After "Upgrade Database" clicked

ok, in PHPMyAdmin, I see this:

MySQL connection collation

It has a drop down box of various char sets to choose from.

Would I want to select this option, per the error:

latin1_general_ci'

And if so, will this affect other databases I have, such as WordPress?

19 Dec 2010, 1:56 AM
#6
scriptjunkie avatar

scriptjunkie

Totally Zenned

Join Date:
Jul 2008
Posts:
772
Plugin Contributions:
0

Re: Error Msg After "Upgrade Database" clicked

Ok :) Disregard my last post :)

I'll leave it at UTF8 and change the file per your suggestion :)

Thanks a bunch!

19 Dec 2010, 2:32 AM
#7
scriptjunkie avatar

scriptjunkie

Totally Zenned

Join Date:
Jul 2008
Posts:
772
Plugin Contributions:
0

Re: Error Msg After "Upgrade Database" clicked

Worked like a charm :clap:

Thanks again!