Zen Cart Logo
Forums / General Questions / Fatal error - can't load admin or store?

Fatal error - can't load admin or store?

Views: 995

Results 1 to 5 of 5
13 Jan 2011, 4:27 PM
#1
itseemedsosimple avatar

itseemedsosimple

New Zenner

Join Date:
Aug 2009
Location:
St. Louis, MO
Posts:
69
Plugin Contributions:
0

Fatal error - can't load admin or store?

Installed 1.3.8a.1 on 3/8/2010.
Loaded Cold Steel Template.
Added an SSL certificate and Authorize.net module.
Hosted at godaddy.
Server technologies: LINUX, PHP 5.1, CGI 2.0, PERL 5.0, PYTHON 2.4, RUBY 1.8.4, MYSQL 4.1, 5.0

Site was established to secure entry fees and donations for charitable organization, was operational in March 2010 and ran successfully through the end of May 2010. Have not accessed it since then. Getting ready to start the 3on3 tourney again in May 2011, so was wanting to update site.

When trying to display zencart store:
Fatal error: Call to a member function get_template_part() on a non-object in /home/content/52/5122352/html/3on3/index.php on line 29

That line 29 says:
$directory_array = $template->get_template_part($code_page_directory, '/^header_php/');

When trying to login to admin:

<form name="login" action=" Fatal error: Call to undefined function zen_href_link() in /home/content/52/5122352/html/3on3/admin/login.php on line 60

Line 60 reads: <form name="login" action="<?php echo zen_href_link(FILENAME_LOGIN, '', 'SSL'); ?>" method = "POST">

http://hopeunlimitedkirkwood.org/3on3/

http://hopeunlimitedkirkwood.org/3on3/admin/login.php

Did query 'fatal error' and saw LOTS of stuff in the forum, but nothing specific to this dual edged problem. Have no idea how to proceed, any help appreciated. Thanks, tg

21 Jan 2011, 5:43 PM
#2
itseemedsosimple avatar

itseemedsosimple

New Zenner

Join Date:
Aug 2009
Location:
St. Louis, MO
Posts:
69
Plugin Contributions:
0

Re: Fatal error - can't load admin or store?

itseemedsosimple:

Installed 1.3.8a.1 on 3/8/2010.
Loaded Cold Steel Template.
Added an SSL certificate and Authorize.net module.
Hosted at godaddy.
Server technologies: LINUX, PHP 5.1, CGI 2.0, PERL 5.0, PYTHON 2.4, RUBY 1.8.4, MYSQL 4.1, 5.0

Site was established to secure entry fees and donations for charitable organization, was operational in March 2010 and ran successfully through the end of May 2010. Have not accessed it since then. Getting ready to start the 3on3 tourney again in May 2011, so was wanting to update site.

When trying to display zencart store:
Fatal error: Call to a member function get_template_part() on a non-object in /home/content/52/5122352/html/3on3/index.php on line 29

That line 29 says:
$directory_array = $template->get_template_part($code_page_directory, '/^header_php/');

When trying to login to admin:

<form name="login" action=" Fatal error: Call to undefined function zen_href_link() in /home/content/52/5122352/html/3on3/admin/login.php on line 60

Line 60 reads: <form name="login" action="<?php echo zen_href_link(FILENAME_LOGIN, '', 'SSL'); ?>" method = "POST">

http://hopeunlimitedkirkwood.org/3on3/

http://hopeunlimitedkirkwood.org/3on3/admin/login.php

Did query 'fatal error' and saw LOTS of stuff in the forum, but nothing specific to this dual edged problem. Have no idea how to proceed, any help appreciated. Thanks, tg

No replies yet - did I leave something out?

21 Jan 2011, 7:20 PM
#3
stevesh avatar

stevesh

Black Belt

Join Date:
Feb 2005
Location:
Lansing, Michigan USA
Posts:
19,793
Plugin Contributions:
2

Re: Fatal error - can't load admin or store?

It may be that your host upgraded to a new version of PHP in the interim. You will need to upgrade to version 1.3.9h to be sure, but also check post #26 here:

http://www.zen-cart.com/forum/showthread.php?t=50534&page=3

21 Jan 2011, 10:24 PM
#4
itseemedsosimple avatar

itseemedsosimple

New Zenner

Join Date:
Aug 2009
Location:
St. Louis, MO
Posts:
69
Plugin Contributions:
0

Re: Fatal error - can't load admin or store?

stevesh:

It may be that your host upgraded to a new version of PHP in the interim. You will need to upgrade to version 1.3.9h to be sure, but also check post #26 here:

http://www.zen-cart.com/forum/showthread.php?t=50534&page=3

Thanks, but the fix at the thread listed is already included in the original 1.3.8a fileset download. Checked with the host and they claim no change on PHP version.

Might you have another suggestion than upgrade to 1.3.9h cause 1. I have other 1.3.8a stores working fine, and
2. the site listed in my original post is a pro bono, so I'm not too inspired to do the tedious legwork on the upgrade.

Could there be another solution?