Zen Cart Logo
Forums / General Questions / Unable to update products

Unable to update products

Views: 1,331

Results 1 to 16 of 16
1 Oct 2011, 12:16 AM
#1
danodemano avatar

danodemano

New Zenner

Join Date:
Sep 2011
Posts:
10
Plugin Contributions:
0

Unable to update products

Alright all, I hope this is in the correct place. Anyway I'm having a slight issue updating products and (I suspect) adding them though I haven't tried to add.

Everything was working properly until I installed an SSL cert. Now it is broke. When I edit a product I hit preview and the window that opens up is empty except the picture, price, and navigation info (can provide more info if needed). If I then hit update it seems to go but it doesn't actually change anything about the product.

I have done some searching and can't seem to find any answers either on Google or this site. I am using v1.3.9h with the ultimate SEO addon (http://www.zen-cart.com/index.php?main_page=product_contrib_info&products_id=231) installed if that helps. I have made a few other small tweaks also to display a Facebook "like" button and a Google+ "+1" button on the product pages but can't see how that would change my ability to edit the products.

I looked through the logs and the only thing I see is it complaining that I don't have a favicon.ico for the site. I have full root access to the server on which the site is installed.

I suspect that it's related to the SSL cert as I was able to edit products without a problem before I installed it. I just don't know where to turn to find an answer.

Oh and I have tried from multiple browsers from a number of different computers with the same result. Some throw an error about redirecting to a non-SSL site when I hit preview but I don't know why. I DID follow the tutorials steps (https://www.zen-cart.com/tutorials/index.php?article=14) for changing to an SSL site.

Transactions do work fine, I have run a non-SSL one and just ran an SSL one without a problem.

Any help would be greatly appreciated, thanks!!

--
Dan

1 Oct 2011, 12:26 AM
#2
danodemano avatar

danodemano

New Zenner

Join Date:
Sep 2011
Posts:
10
Plugin Contributions:
0

Re: Unable to update products

I stand corrected, I just found this though I don't know why.


[Fri Sep 30 19:53:25 2011] [error] [client 192.xxx.xxx.3] client denied by server configuration: /var/www/html/xxx/xxxadmin/includes/javascript/spiffyCal/includes, referer: https://www.madhooker.com/xxxadmmin/product.php?page=1&product_type=1&cPath=70&pID=186&action=new_product

I replaced a few things with xxx to obfuscate some data. Not sure if it's related. Thanks again!

1 Oct 2011, 12:39 AM
#3
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,809
Plugin Contributions:
15

Re: Unable to update products

My finger would point at the SEO add-on. Zen Cart does everything required by SEs just fine. Take a look at the thread for the add-on for a possible solution. You may have to wade through a lot of horror stories to find something.:no:
Your answer while my typing. Do your have Salemaker or the Calendar Box?

1 Oct 2011, 1:08 AM
#4
danodemano avatar

danodemano

New Zenner

Join Date:
Sep 2011
Posts:
10
Plugin Contributions:
0

Re: Unable to update products

I do not have the Salemaker or the Calendar Box, no. And I don't know how it does, the links it (Zen cart) generated were terrible when it comes to SEO far as I can tell. Not to mention when it comes to a person remembering them. I will look through that addon thread though. I don't see that it affects the admin pages however which is why I was perplexed.

1 Oct 2011, 1:13 AM
#5
danodemano avatar

danodemano

New Zenner

Join Date:
Sep 2011
Posts:
10
Plugin Contributions:
0

Re: Unable to update products

If you think it would make a difference I would be happy to go through and remove the SEO stuff I added from the addon, that's not really a big deal. I just couldn't see how it was that. Once again, thanks!

1 Oct 2011, 1:29 AM
#6
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,809
Plugin Contributions:
15

Re: Unable to update products

Well, we're kind of grasping at straws here as we find out more each time you post. If everyone would start out by following the posting tips, it would get most problems solved in half the time. I'm wondering why you would have spiffyCal without one of the mods that uses it.
Your problem could be many things but it's hard to be psychic.:P
As to SEO, we have several sites that rank high without ever touching what ZC itself creates. And, folks remembering a URL? Don't know of anyone who does, but I know a LOT that can bookmark in a heartbeat.

1 Oct 2011, 1:37 AM
#7
danodemano avatar

danodemano

New Zenner

Join Date:
Sep 2011
Posts:
10
Plugin Contributions:
0

Re: Unable to update products

dbltoe:

Well, we're kind of grasping at straws here as we find out more each time you post. If everyone would start out by following the posting tips, it would get most problems solved in half the time. I'm wondering why you would have spiffyCal without one of the mods that uses it.
Your problem could be many things but it's hard to be psychic.:P
As to SEO, we have several sites that rank high without ever touching what ZC itself creates. And, folks remembering a URL? Don't know of anyone who does, but I know a LOT that can bookmark in a heartbeat.

Wait what? You lost me. I did follow everything best I could tell. And I don't have spiffyCal. I'm sorry if what I have posted is not satisfactory as I don't really know where to start. I'm quite good with PHP but didn't want to just start ripping apart the code and looking for problems.

It worked with the SEO addon up until I installed the SSL cert, that's all I know.

1 Oct 2011, 1:41 AM
#8
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,809
Plugin Contributions:
15

Re: Unable to update products

Take a look at the posting tips. Little things like PHP version, ZC version, Windows vs Linux, etc. can make a big difference.

And, unless someone has hacked your post #2, it specifically states you have a problem in the spiffyCal directory.:huh:

1 Oct 2011, 1:53 AM
#9
danodemano avatar

danodemano

New Zenner

Join Date:
Sep 2011
Posts:
10
Plugin Contributions:
0

Re: Unable to update products

I did post my zencart version in the first post, v1.3.9h. PHP version 3.4.5 and MySQL version 5.5.14. This is Fedora 15.

I didn't think it mattered SINCE IT WAS WORKING BEFORE THE SSL CERT.

I don't recall installing that though so maybe it was part of something else I was messing with. What is spiffyCal?

1 Oct 2011, 2:10 AM
#10
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,809
Plugin Contributions:
15

Re: Unable to update products

I do hope you meant something like PHP 5.3.4.5.
Anyway, spiffyCal is used with many features in ZC including some mods. Hence one of the questions in the posting tips - what mods are installed.
Have you checked the permissions on the file mentioned in post #2. It's telling you that the process is blocked. If a permission is okay, then we need to find out what's "denying the client."

1 Oct 2011, 2:22 AM
#11
danodemano avatar

danodemano

New Zenner

Join Date:
Sep 2011
Posts:
10
Plugin Contributions:
0

Re: Unable to update products

This is what Yum says: Package php-5.3.8-1.fc15.x86_64 already installed and latest version.

Other than the Facebook like and G+ button that's all the mods I have I believe. I would be happy to share more info about the install if needed, just let me know.

Permissions are 777 on that directory for the moment while I work out the bugs.

Sorry if this wireless keyboard misses stuff from time to time.

1 Oct 2011, 3:36 AM
#12
nigelt74 avatar

nigelt74

Totally Zenned

Join Date:
Sep 2005
Location:
Waikato, New Zealand
Posts:
1,558
Plugin Contributions:
1

Re: Unable to update products

Ok, you seem to be checking the webserver logs which is good, BUT

have you checked your /cache folder, as this is where zencart stores php errors with filenames like

mydedug-23072011-12345.log
or
mydedug-adm-23072011-12345.log (especially these adm ones for admin)

Cheers

1 Oct 2011, 1:54 PM
#13
danodemano avatar

danodemano

New Zenner

Join Date:
Sep 2011
Posts:
10
Plugin Contributions:
0

Re: Unable to update products

There is no sign of any errors in the cache folder, not from the past few days anyway. How does the admin side handle SSL? I have it set to use it but if I disable my forces SSL redirect in my .htaccess file I am able to edit the products again. It looks like after the login to the admin area it no longer uses SSL?

This is what I'm using for the SSL rewrite in my .htaccess file:

RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

Is that what's causing the problems? I also noticed that I can't change any configuration options with the forces SSL.

Thanks!

1 Oct 2011, 6:29 PM
#14
danodemano avatar

danodemano

New Zenner

Join Date:
Sep 2011
Posts:
10
Plugin Contributions:
0

Re: Unable to update products

Alright I took the easy way out and just tweaked the rule forcing SSL to exclude the admin area from this requirement and everything seems to be fine now. In case anyone was wondering this is what I did to the rule:

RewriteRule ^(admin|xxxadmin)($|/) - [L]
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

Thanks everyone!!!

1 Oct 2011, 9:27 PM
#15
nigelt74 avatar

nigelt74

Totally Zenned

Join Date:
Sep 2005
Location:
Waikato, New Zealand
Posts:
1,558
Plugin Contributions:
1

Re: Unable to update products

yes that is probably what was causing it

If you want to force ssl for the admin do that in your admin config file, set them both to https

// Define the webserver and path parameters
define('HTTP_SERVER', 'https://www.YOUR_SHOP.com');
define('HTTPS_SERVER', 'https://www.YOUR_SHOP.com');
define('ENABLE_SSL', 'true');

On this page
https://www.zen-cart.com/tutorials/index.php?article=14
read the note that is part of point 3

danodemano:

Alright I took the easy way out and just tweaked the rule forcing SSL to exclude the admin area from this requirement and everything seems to be fine now. In case anyone was wondering this is what I did to the rule:

RewriteRule ^(admin|xxxadmin)($|/) - [L]
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

Thanks everyone!!!

1 Oct 2011, 10:09 PM
#16
danodemano avatar

danodemano

New Zenner

Join Date:
Sep 2011
Posts:
10
Plugin Contributions:
0

Re: Unable to update products

OHHHHHH I feel stupid now. I missed that note when I was setting up the SSL. :oops: Thanks a million!!!