Forums / Upgrading to 1.5.x / Backwards Compatibility Mods 1.5.x to 1.3.x

Backwards Compatibility Mods 1.5.x to 1.3.x

Started by skipwater on 30 Nov 2011, 1:19 AM · Views: 1,086

Results 1 to 5 of 5
30 Nov 2011, 1:19 AM
#1
skipwater avatar

skipwater

Totally Zenned

Join Date:
Jun 2008
Location:
Washington, DC
Posts:
775
Plugin Contributions:
1

Backwards Compatibility Mods 1.5.x to 1.3.x

I have updated one of my mods Monthly Sales Tax Summary to ZC 1.5.x and with this it will not run under ZC 1.3.x

The issue is 1.5.x no longer has a admin/includes/boxes/extra_boxes folder for the admin menus. It now uses Admin Page Registration (which I like).

To make the 1.5.x version backwards compatible I could just add admin/includes/boxes/extra_boxes/menu file to the install zip file of the 1.5.x version and the mod would work with both 1.3.x and 1.5.x

Doing that would add folders to 1.5.x that are unused and adding the Admin Page Registration file to 1.3.x that is unused.

Yes the install read me file could state if version x just upload xyz but who reads the readme file.

Is this something we want to stay away from?
So just leave it with two mod version?

Skip

• 446F63746F722057686F •

30 Nov 2011, 5:29 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,515
Plugin Contributions:
176

Re: Backwards Compatibility Mods 1.5.x to 1.3.x

You have several options:

a) Leave the old attachments for the old ZC version, and just make the latest zip work with 1.5.0. This is what I'd recommend.

b) Add an extra "only_for_139" folder to your zip and explain its purpose in the readme
c) Write manual instructions in the readme for doing it by hand for those using the old version, and encourage them to upgrade instead.

d) see (a) above
e) see (a) above :blush:

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

30 Nov 2011, 5:58 AM
#3
gjh42 avatar

gjh42

Black Belt

Join Date:
Jul 2005
Location:
Upstate NY
Posts:
21,876
Plugin Contributions:
8

Re: Backwards Compatibility Mods 1.5.x to 1.3.x

The old version(s) will still be available in Free Addons. Just put a note in the new version description that it is only for v1.5+, and older version users should download the previous mod version.
Then put a similar note in the new readme.
And expect questions in the support thread "I installed the new version on my v1.3.9 site... why isn't it working?"

30 Nov 2011, 10:11 AM
#4
jynxy avatar

jynxy

New Zenner

Join Date:
Jul 2005
Posts:
34
Plugin Contributions:
0

Re: Backwards Compatibility Mods 1.5.x to 1.3.x

Personally i think its about time the downloads section was updated ?

why not have the options for 1.3x mods and 1.5x mods, also why not be able to choose when the mod was last updated, so newest first ? personally i dont want to download a mod that was last updated in 2006 when there is one for 2010/2011.

That way people wont get confused on what files do what etc. can also help with security issues as you dont want 1.3x files in with 1.5x

30 Nov 2011, 1:28 PM
#5
skipwater avatar

skipwater

Totally Zenned

Join Date:
Jun 2008
Location:
Washington, DC
Posts:
775
Plugin Contributions:
1

Re: Backwards Compatibility Mods 1.5.x to 1.3.x

Thanks that's what I will do leave the two versions with added info in the readme files.

Skip

• 446F63746F722057686F •