Zen Cart Logo
Forums / Upgrading to 1.5.x / After moving to a new server, admin are blank without any error info

After moving to a new server, admin are blank without any error info

Views: 1,773

Results 1 to 6 of 6
20 Jan 2012, 11:02 AM
#1
boomup avatar

boomup

New Zenner

Join Date:
Jan 2012
Posts:
48
Plugin Contributions:
0

After moving to a new server, admin are blank without any error info

I moved my website to a new server, the front end works well, but the admin page is blank without any error information, i tried many kinds of method, there is still not error log file available, i am really frustrated now, how can i get the error information?

20 Jan 2012, 12:39 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: After moving to a new server, admin are blank without any error info

How exactly did you "move to a new server"?
Did you follow these instructions? https://www.zen-cart.com/tutorials/index.php?article=100
Which steps did you miss?

Did it work correctly with the basic install before you imported your old data? Or did you test that?

20 Jan 2012, 3:15 PM
#3
boomup avatar

boomup

New Zenner

Join Date:
Jan 2012
Posts:
48
Plugin Contributions:
0

Re: After moving to a new server, admin are blank without any error info

I exported and restored the database, and moved files to new server, and changed two configure.php files. it works well on front end. in order to test I built a new folder, and then built a text file, and I could visit it through URL, but in the existed folder, after building a text file, when I try to visit it through URL, it responded me a Error 403 or blank page without any error information, I tried many folders, all was like that, and then I set the permission to 777, 755 and 644, all was as before, looks it is strange, now I don't know how to debug

20 Jan 2012, 10:53 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: After moving to a new server, admin are blank without any error info

A fresh install of Zen Cart does not give a 403 error or a blank page, unless you're missing files from the upload or your server's configuration is incompatible with the included .htaccess directives intended to prevent abuse by hackers.

A 403-Forbidden response means that your server is blocking access. That could be caused by a permissions problem on the files, or a domain configuration problem blocking PHP scripts, or a myriad of other things. Your hosting company will be best equipped to explain what exactly is causing the 403 response based on their server configuration.

You did say it works fine on the old server, right? And on the new server a new install doesn't even work? That's a server config issue or a missing files issue. So, talk to your host's tech support.

21 Jan 2012, 4:14 AM
#5
boomup avatar

boomup

New Zenner

Join Date:
Jan 2012
Posts:
48
Plugin Contributions:
0

Re: After moving to a new server, admin are blank without any error info

Thank you very much, DrByte

I fixed , at configure.php define('DIR_FS_CATALOG', '/srv/www/domain.com/public_html/'); I forgot to add the last /, and after added it, works well

21 Jan 2012, 4:19 AM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: After moving to a new server, admin are blank without any error info

Next time I suggest you follow the tutorial I mentioned so that you don't have the same problem.