Zen Cart Logo
Forums / Upgrading to 1.5.x / Error after Upgrade from 1.3.9h

Error after Upgrade from 1.3.9h

Views: 2,837

Results 1 to 11 of 11
28 Jan 2012, 7:02 PM
#1
deepfrydaniel avatar

deepfrydaniel

New Zenner

Join Date:
May 2007
Posts:
29
Plugin Contributions:
0

Error after Upgrade from 1.3.9h

I've been trying to update to 1.5, but I'm having some problems. When I do a fresh install with a new database the site works fine, but when I try to upgrade using my old database I'm getting an internal server error. you can see the error message at http://www.sorrystaterecords.com/zen15.

When I upgrade the database I only get 4 exceptions, none of which seem like a big deal... it seems like maybe one of the table names changed index to idx but that had already been done in whatever version I was using.

Any ideas?

28 Jan 2012, 7:54 PM
#3
deepfrydaniel avatar

deepfrydaniel

New Zenner

Join Date:
May 2007
Posts:
29
Plugin Contributions:
0

Re: Error after Upgrade from 1.3.9h

Well, there is no debug file in the cache folder, so I'm unsure of how to proceed.

28 Jan 2012, 10:35 PM
#5
deepfrydaniel avatar

deepfrydaniel

New Zenner

Join Date:
May 2007
Posts:
29
Plugin Contributions:
0

Re: Error after Upgrade from 1.3.9h

OK, I looked through the server's error logs and the only one I found that seems like it could be the source of the problem is this one:

[Sat Jan 28 14:00:34 2012] [error] [client 67.228.186.240] client denied by server configuration: /home/sorrscom/public_html/zen15/includes/filenames.php

Any ideas about what might be causing that? I tried re-uploading filenames.php but it didn't seem to solve anything.

28 Jan 2012, 11:09 PM
#6
deepfrydaniel avatar

deepfrydaniel

New Zenner

Join Date:
May 2007
Posts:
29
Plugin Contributions:
0

Re: Error after Upgrade from 1.3.9h

Update: this has been resolved. Turned out it was an error in configure.php.

28 Jan 2012, 11:24 PM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error after Upgrade from 1.3.9h

deepfrydaniel:

[Sat Jan 28 14:00:34 2012] [error] [client 67.228.186.240] client denied by server configuration: /home/sorrscom/public_html/zen15/includes/filenames.phpThat's to be expected. The zc_install program caused that when it was checking for security protections compatibility.

deepfrydaniel:

Update: this has been resolved. Turned out it was an error in configure.php.
Thanks for confirming that your alterations to the file caused problems, and putting them back to proper settings allowed things to work properly again.

31 Jan 2012, 12:54 AM
#8
stressedout72 avatar

stressedout72

New Zenner

Join Date:
Apr 2009
Posts:
11
Plugin Contributions:
0

Re: Error after Upgrade from 1.3.9h

I also am getting an error. everything was fine untill i installed lightbox_mod. i did a complete reinstall of zen V 1.5 and when i get to the database upgrade in the zen cart auto setup i get an error. "Admin Password required to proceed with upgrade". the funny thing is i have placed the correct password and user in the boxes and i get nothing!!Attachment #10092 also i get this error on the index page of my shop http://blendedelegancellc.com
"Your database appears to need patching to a higher level. See Admin->Tools->Server Information to review patch levels."

here is what i get when i finish the zc1.5 upgrade and go to my admin. https://shop.blendedelegancellc.com/rodnjoni2012admin/index.php

"database upgrade required. please run the 1.3.9-to-1.5.0 upgrade via zc_install"

I cannot log into my admin at all.
not sure how to solve this issue. please help.

BTW i was already upgraded to 1.5

have Ashley pink mod

Any help would be great and i am sorry if i placed this in the wrong spot.

31 Jan 2012, 1:42 AM
#9
rescoccc avatar

rescoccc

Totally Zenned

Join Date:
May 2010
Location:
WA State
Posts:
1,700
Plugin Contributions:
2

Re: Error after Upgrade from 1.3.9h

If I understand you correctly, you had 1.50 installed and working until you installed Zen Lightbox? Have you tried uninstalling it by removing the new files it adds, putting back copies of the files it changes, and running the uninstall SQL patch? Since you can't log in to your admin, you'll need to run the patch from phpMyAdmin.

12 Oct 2014, 2:42 PM
#10
bigandrew avatar

bigandrew

New Zenner

Join Date:
Oct 2014
Location:
Georgia
Posts:
74
Plugin Contributions:
0

Re: Error after Upgrade from 1.3.9h

deepfrydaniel:

Update: this has been resolved. Turned out it was an error in configure.php.

I'm trying to fix this same problem today, what was the problem with your config file?? I can't figure this out. Thank you!

13 Oct 2014, 2:20 PM
#11
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Error after Upgrade from 1.3.9h

bigandrew:

I'm trying to fix this same problem today, what was the problem with your config file?? I can't figure this out. Thank you!

You are posting to a very old thread here, and the problem with your config file may not be the same as the problem with the OP's config file (and that is assuming your problem is caused by an error in the same file).

If you can't identify the error yourself, the best thing to do is post a copy of your config file(s) so that we can take a look at them.

Before doing this though you will need to ensure that you delete/obfuscate the database login details as well as the name of your admin folder.

It would also help if you could provide a little detail about the problem(s) you are having.. Quite often 'the same problem' is far removed from the actual problem.

Cheers
RodG