Zen Cart Logo
Forums / Upgrading to 1.5.x / Host upgraded to php 5.3.10 - store pages blank now

Host upgraded to php 5.3.10 - store pages blank now

Locked

Views: 3,588

Results 1 to 12 of 12
This thread is locked. New replies are disabled.
31 Mar 2012, 6:03 PM
#1
nosnip13 avatar

nosnip13

New Zenner

Join Date:
Mar 2012
Posts:
5
Plugin Contributions:
0

Host upgraded to php 5.3.10 - store pages blank now

I have been running version 1.3.8a on a website I maintain, without trouble.

My host upgraded to php 5.3.10 and now of course my store does not work. When accessing the store or the admin area, I get a blank page or a 500 server error.

I download and installed the patch found here: http://www.zen-cart.com/forum/showthread.php?t=140960 and nothing has changed. Everything is still blank.

I was going to do the upgrade on my zencart, BUT since the host has already upgraded the php, I can not get into my admin area to get information required for shipping and payment modules or remove the modules as the instructions say to do.

The site is located at: http://www.tailormaidbowstrings.com/shop/

Any help would be greatly appreciated!

Thank you!
Michelle

31 Mar 2012, 7:30 PM
#2
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,102
Plugin Contributions:
56

Re: Host upgraded to php 5.3.10 - store pages blank now

You can start with this tutorial ...

31 Mar 2012, 9:36 PM
#3
nosnip13 avatar

nosnip13

New Zenner

Join Date:
Mar 2012
Posts:
5
Plugin Contributions:
0

Re: Host upgraded to php 5.3.10 - store pages blank now

I looked at that page before posting here. I upload each file in the ASCII mode individually. (I actually did it a second time just to be sure too, as I discovered it was not working) All file sizes are correct once uploaded.

I didn't edit any of the files before uploading them. I just uploaded and overwrote what was there as the instructions said to, since I had not customized any of them in the earlier version.

When I check my server error logs, there are no errors that relate to this issue.

I guess I am off to download and install the debugger mentioned on the page you linked to and give that a try.

I will post an update once I have run the debugger.

31 Mar 2012, 10:08 PM
#4
nosnip13 avatar

nosnip13

New Zenner

Join Date:
Mar 2012
Posts:
5
Plugin Contributions:
0

Re: Host upgraded to php 5.3.10 - store pages blank now

Ok, I installed the debugger and checked the log file after accessing the page. In the error it showed the application_top.php file couldn't find the initsytem.php file.

I checked my site and sure enough, there was not one there. I looked in my original install files and could not find one either.

I checked in the upgrade I had downloaded for the newest version of zen cart and it was in there, so I took a chance and uploaded it and it appears everything on the main part of the store is working, I can now access it and it appears I can place orders and access my admin area.

Thank you for your help!

1 Apr 2012, 2:17 AM
#5
coolcarpartsonline avatar

coolcarpartsonline

Totally Zenned

Join Date:
Feb 2008
Posts:
1,386
Plugin Contributions:
0

Re: Host upgraded to php 5.3.10 - store pages blank now

It could be server issue too.

I have both versions on my server, some sites still run on 5.2.x and others are on 5.3.x. I only had issue with one addon but I fixed the issue manually.

4 Apr 2012, 6:52 PM
#6
nosnip13 avatar

nosnip13

New Zenner

Join Date:
Mar 2012
Posts:
5
Plugin Contributions:
0

Re: Host upgraded to php 5.3.10 - store pages blank now

Well all is not as good in the world as I thought. Even though the above mention solved my immediate problem, now I have found another.

When a customer goes to place an order, they can put items in the cart, etc, but when they click on checkout, it just reloads the same page they were on.

AND in the admin area, when you click on a customers order to view details, the order page is blank. It has the back button on the top right, but no order details.

I ran the debugger again and when I try to do either of the things I just mentioned, these are the errors I receive:

04-Apr-2012 15:23:53 UTC] PHP Deprecated: Function ereg() is deprecated in /home/tailorma/public_html/shop/includes/classes/db/mysql/query_factory.php on line 139

[04-Apr-2012 15:23:59 UTC] PHP Deprecated: Function ereg() is deprecated in /home/tailorma/public_html/shop/includes/classes/db/mysql/query_factory.php on line 177

Anyone have any ideas on how to solve this?

Michelle

4 Apr 2012, 10:11 PM
#7
fairestcape avatar

fairestcape

Totally Zenned

Join Date:
Mar 2008
Location:
Cape Town & London (depends on the season)
Posts:
2,957
Plugin Contributions:
0

Re: Host upgraded to php 5.3.10 - store pages blank now

I have NO IDEA if this will work... and if it does, it is a TEMPORARY and probably UNRELIABLE FIX...

You MUST upgrade properly.

Send a COPY of query_factory.php via FTP to your hard drive

Open it for editing

Find lines 139 and 177

They are:

              if (!ereg('^[0-9]', $key)) {

Change to:

              if (!preg_match('/^[0-9]/', $key)) {

SAVE the file on your hard drive

Make the SERVER file of query_factory.php a BACKUP by re-naming it to query_factory.BAK

FTP your edited file to the same location:

includes/classes/db/mysql/


Doc Byte will probably pick up on this and let us know if I am wrong. If this assists you in gaining access to locked out areas/processes, then use that access to begin your upgrade.

6 Apr 2012, 9:36 PM
#8
nosnip13 avatar

nosnip13

New Zenner

Join Date:
Mar 2012
Posts:
5
Plugin Contributions:
0

Re: Host upgraded to php 5.3.10 - store pages blank now

Ok, I am going to pull my hair out!

That didn't work, so I went ahead with a full upgrade. I have followed the upgrade instructions. I have backed up and imported my old database, etc.

I get right up to the point of "Using your browser, surf to /zc_install/index.php and choose "Database Upgrade" when prompted."

When I go to the url, the page loads BLANK. I have searched the faq here and read all of that. I re-uploaded the files, making sure they were uploaded in ASCII (I used the "auto" choice the first time around on my wsftp, and didn't trust it so I have re-uploaded them manually)

When I check the debugger cache, I am getting these messages:

[06-Apr-2012 20:45:23 UTC] PHP Warning: require(includes/languages/english/index.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/tailorma/public_html/store_new/zc_install/index.php on line 48

[06-Apr-2012 20:45:23 UTC] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required 'includes/languages/english/index.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tailorma/public_html/store_new/zc_install/index.php on line 48

I have double checked that those files referenced there do in fact exist!

Line 48 of zc_install/index.php is

  require($language_page_directory . $current_page . '.php');

It created another file called DSP1E4.log that contains

Apr 06 2012 14:45 --
Specified language file not found. Defaulting to english. (includes/languages/english.php)

and a third file called sess_c2aa76cecec3565fc14c60fd4af60ac1 that contains
hpJF6FwjY_qEpfEulJK5lylNqOZnS2otbPkIp_1vGQfL2axpT3hUR6AjPoQ7Md8K_UuIubYd9t0cpOycunWJqEIKZ9ZZdZfr7vDuR7XdjujfRKwEyAVqfxyurG_QP068ud5JZyGmOeFw0_mWUM4H4rabxcRH60zAD4gXbEYkZo0.

What am I doing wrong here?

Michelle

6 Apr 2012, 11:00 PM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Host upgraded to php 5.3.10 - store pages blank now

Since the errors about /includes/languages/english/index.php are COMING FROM a script that sits in the zc_install folder, that means that your upload must have skipped uploading the** /zc_install/**includes/languages/english/index.php file, and the /zc_install/includes/languages/english.php file too. And, when that happens it's likely an indication that more files are also missing. And that suggests that your upload probably experienced timeouts when you were transferring files.

17 Apr 2012, 4:45 PM
#10
dab avatar

dab

New Zenner

Join Date:
Jan 2007
Location:
UK
Posts:
62
Plugin Contributions:
0

Re: Host upgraded to php 5.3.10 - store pages blank now

My host is also in the process of updating to PHP 5.3.10, and today one of my 1.3.7 sites stopped working with a 500 server error.

When I checked with them they said the full upgrade had not been done yet - but they had installed SuPHP which they said does not allow files to be writeable by group. They changed some permissions, and my site was back online - the admin section also needed the same treatment for it to work.

I have a 1.5 test site, and that wasn't affected. Not sure what will happen with the 1.3.7 site once the PHP 5.3.10 upgrade is done.

17 Apr 2012, 8:33 PM
#11
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Host upgraded to php 5.3.10 - store pages blank now

dab:

Not sure what will happen with the 1.3.7 site once the PHP 5.3.10 upgrade is done.
It will be broken, because v1.3.7 is not compatible with PHP 5.3.x

22 Apr 2012, 8:56 AM
#12
dab avatar

dab

New Zenner

Join Date:
Jan 2007
Location:
UK
Posts:
62
Plugin Contributions:
0

Re: Host upgraded to php 5.3.10 - store pages blank now

Thanks for the info, I have now upgraded successfully from v1.3.7 to v1.5 using the instructions on the forum. I know it should of been done long ago, but I had been putting it off.