cyberbaffled:
I've deleted all the Zen Cart files associated with the "php bug"
Even the files that didn't apparently exist? (rhetorical question).
cyberbaffled:
and uploaded completely new files,
freshly unzipped. Then I've done an install from scratch.
This is why the previous question is rhetorical. With a new/fresh install what you did prior to this is no longer relevant.
cyberbaffled:
And I get the exact same previously copied error message
Would I be wrong in assuming that you ignored my advice and still tried to install into a folder with a space character?
cyberbaffled:
when I attempt to open the filename/admin dashboard.
"filename/admin dashboard" obviously has some meaning for you, but to me, it sounds like gobbledegook.
cyberbaffled:
Without the /admin suffix to the domain url the starter ZenCart file opens.
More gobbledegook, but this time I think I know what you are trying to say.
You are apparently trying to navigate to http://yourdomain.com/admin/ and you are getting a page not found error? (not to be confused with a "no such file" error).
If this is the case, it is possibly because according to your original 'php bug' report, the admin section of your store is to be found at
http://yourdomain.com/alpha-admin/ or perhaps
http://yourdomain.com/Zen Cart/alpha-admin/
The 'correct' one of these will be determined by your Apache (webserver) settings based on where it expects to find the document root folder.
cyberbaffled:
The issue can't be the space in the folder Zen Cart because I previously opened the admin process with that file name.
You DO realise that I'm actually trying to help you, don't you?
OK, so my original suspicion may be incorrect according to your experience, but that doesn't in any way change the fact that filenames and folders that contain space characters will cause all sorts of unexpected problems.
If you are unwilling to take advice and suggestions then what is the point of us given them to you?
cyberbaffled:
Then I lost the admin process when I changed the db password; my previous posts.
Regardless of what has gone wrong in the past, when we recommend/suggest a 'fresh install' we actually mean, completely start from scratch. This means 'forgetting' about what has gone before because those mistakes/errors are in the past and would be no longer relevant to the current situation.
I could be way off the mark in regards to the space in the folder name being the immediate cause of the current problem, but as long as you insist that this isn't going to cause an issue (either now, or with some future function/feature) then you are building your store on a shaky foundation, and I feel I won't be doing you any favours by accepting your own observation that this isn't the cause and trying to help you move past it because it'll only come back and 'bite' you in some other way.
So please do a fresh install into a folder with no spaces in the names. Also use a newly created database so that there is no connection between the old installs and the fresh install.
Chances are that you'll not have any further problems. Very few people actually have difficulties with a fresh installation (unlike upgrades, which are significantly more complex)
Oh, and before I forget (again) do be careful with file permissions, because although I previously stated that
application-top.php with file permissions of 777 is a security risk, there are many servers that are setup in such a way that the server itself will produce a "500 error" (or similar) when they encounter such files, this could also be part of your 'php bug' (I originally discounted this under the assumption that you set the permissions this way in an attempt to fix the failure to open the file in the 1st place).
We both know the problems with making assumptions though.
Cheers
Rod
ps. Further in regards to space characters in folder names... as an example, check out the two links I entered earlier in this message.. Now note how the one with the space character in the name is a badly formed (incomplete) link? Do you still think spaces are a good idea?