Zen Cart Logo
Forums / General Questions / 500 Server Error The website encountered an error

500 Server Error The website encountered an error

Views: 1,270

Results 1 to 12 of 12
25 May 2012, 10:49 AM
#1
alasdair avatar

alasdair

New Zenner

Join Date:
May 2012
Posts:
5
Plugin Contributions:
0

500 Server Error The website encountered an error

I am completely confused on this error- I cant work out why its doing it. Every time i go to my website (getutech.com) i get a server error and it says " The website encountered an error while retrieving http://getutech.com/. It may be down for maintenance or configured incorrectly.". I've checked all the other threads on this error and the Zen Cart page on it (http://www.zen-cart.com/content.php?105-why-am-i-getting-500-internal-server-error) and i can't get it to work.
The strange thing is that the back end works fine, but the front end doesn't work at all.
I've contacted my hosting provider and they didn't offer any suggestions and the error logs they gave me wern't helpful.

Any suggestions for what I could do to fix this?

25 May 2012, 12:26 PM
#2
mprough avatar

mprough

Totally Zenned

Join Date:
Nov 2007
Location:
Woodbine, Georgia, United States
Posts:
4,290
Plugin Contributions:
39

Re: 500 Server Error The website encountered an error

What have you recently changed?

Check includes/templates/your_template/html_header.php
Check includes/configure.php
Check all .htaccess files

~Melanie

25 May 2012, 10:04 PM
#3
alasdair avatar

alasdair

New Zenner

Join Date:
May 2012
Posts:
5
Plugin Contributions:
0

Re: 500 Server Error The website encountered an error

mprough:

What have you recently changed?

Check includes/templates/your_template/html_header.php
Check includes/configure.php
Check all .htaccess files

~Melanie

I have not changed htaccess files or html headder and the only thing I changed in configure.php was this:

define('HTTP_SERVER', 'https://getutech.com');
define('HTTPS_SERVER', 'https://getutech.com');
define('HTTP_CATALOG_SERVER', 'https://getutech.com');
define('HTTPS_CATALOG_SERVER', 'https://getutech.com');

// secure webserver for admin? Valid choices are 'true' or 'false' (including quotes).
define('ENABLE_SSL_ADMIN', 'true');

25 May 2012, 10:37 PM
#4
joejoejoe avatar

joejoejoe

Zen Follower

Join Date:
Oct 2011
Location:
AZ
Posts:
383
Plugin Contributions:
0

Re: 500 Server Error The website encountered an error

Is there a reason you're pointing the http to https (1st and 3rd lines)?

26 May 2012, 12:03 AM
#5
mprough avatar

mprough

Totally Zenned

Join Date:
Nov 2007
Location:
Woodbine, Georgia, United States
Posts:
4,290
Plugin Contributions:
39

Re: 500 Server Error The website encountered an error

Alasdair:

I have not changed htaccess files or html headder and the only thing I changed in configure.php was this:

define('HTTP_SERVER', 'https://getutech.com');
define('HTTPS_SERVER', 'https://getutech.com');
define('HTTP_CATALOG_SERVER', 'https://getutech.com');
define('HTTPS_CATALOG_SERVER', 'https://getutech.com');

// secure webserver for admin? Valid choices are 'true' or 'false' (including quotes).
define('ENABLE_SSL_ADMIN', 'true');

That is your ADMIN configure, what is in includes/configure.php?

~Melanie

26 May 2012, 4:01 AM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 500 Server Error The website encountered an error

joejoejoe:

Is there a reason you're pointing the http to https (1st and 3rd lines)?
Yes. If you read take a look at your own file and read the comments in the lines above that part, you'll see why. v1.5.0 and newer.

26 May 2012, 9:04 PM
#7
alasdair avatar

alasdair

New Zenner

Join Date:
May 2012
Posts:
5
Plugin Contributions:
0

Re: 500 Server Error The website encountered an error

That is my Includes configure.php file not admin. Should it be different?

26 May 2012, 10:21 PM
#8
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,099
Plugin Contributions:
56

Re: 500 Server Error The website encountered an error

Yes, your /includes/configure.php and ADMIN/includes/configure.php should be different ...

26 May 2012, 11:06 PM
#9
alasdair avatar

alasdair

New Zenner

Join Date:
May 2012
Posts:
5
Plugin Contributions:
0

Re: 500 Server Error The website encountered an error

Oh, I think I may have got the two files mixed up so now I have a copy of admin configure.php in includes folder (as you can tell, I'm new to zen cart :smile:). How do I get another configure.php file for the frontend includes folder (not admin)?

27 May 2012, 12:53 PM
#10
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,099
Plugin Contributions:
56

Re: 500 Server Error The website encountered an error

Go back to your "stock" zen-cart zip-file and locate the /includes/dist-configure.php file. Make a copy of that file and edit the server and database information to match your admin's configure.php and then use that edited information/file to replace your /includes/configure.php file.

27 May 2012, 2:31 PM
#11
alasdair avatar

alasdair

New Zenner

Join Date:
May 2012
Posts:
5
Plugin Contributions:
0

Re: 500 Server Error The website encountered an error

thanks for all your help, I've fixed it now :D

27 May 2012, 10:09 PM
#12
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,099
Plugin Contributions:
56

Re: 500 Server Error The website encountered an error

Yeah! :clap: I'm glad you got it sorted out.