New Zenner
- Join Date:
- Apr 2012
- Posts:
- 11
- Plugin Contributions:
- 0
Lost Access to Admin while going LIVE
Answering questions in order on POSTING TIPS:
- No, no previous post on this subject
- zencart version 150
- Have never upgraded, installed newest edition in Jan.
- no addons
- one-click install from GoDaddy
- customized outside from install using a few java apps but for the most part original. (unless you count the fubar changes)
- not a display issue ATM but url is https://www.adamsappletn.com JIC.
- Host GoDaddy
- Yes we have looked & searched both FAQ & the FORUM for all related questions and answers and even some adjacent answers.
- Problem started yesterday (6/21/12) afternoon aprox 4pm est.
- We tested & workout all issues pre-live setup. The issue came from attempting to go live.
Linx os config2.2\server on GoDaddy.com
PC OS Windows 7
While trying to move the site & contents from a subfolder to the root folder we gained access to the main page & none of the other links worked. And we couldn't get back into the admin to change the configuration/sessions and edit the main route link. When that happened we used the fix_cache_key.php to regain access to the admin in zencart through the server ftp but the website wasn't showing correctly. It had all the links but was missing images, tables & templates. To try and get the site looking right we went and reworked the configure.php files in admin/. & admin/includes/. After several more steps & tweeking including reloading all the files from back up (locking us out of admin again) & reloading the database from backup, we got several more errors.
Right now we are able to have the site functional in the root but have temporarily moved it back into a subfolder with a temp html site in place. In either case we still don't have access to the admin access in zencart. There's not even an error just a blank white screen. We have the htaccess file disabled by a tech on Godaddy support from receiving a 403: forbidden error. Looking at the subfolder back up, where it was originally & working with access to admin, there is no htaccess file to begin with. Where there is now an htaccess_denied (changed by tech support) in the root folder.
If someone can please explain why the htaccess folder isn't in the original zencart site created.
Does it show up after the move from a subfolder to a root folder?
If so is it the reason the site is unusable or undesirable when placed in the root folder?
Or is it the cause for our lock out of zencart admin? Or both?
We think we have the configure.php files done correctly after searching several posts on the forum & faqs. But here is a screen shot just in case they may be done incorrectly.
Also if there is something that we haven't come across we are open to all suggestions.