Zen Cart Logo
Forums / General Questions / Suddenly customers having problems downloading

Suddenly customers having problems downloading

Views: 536

Results 1 to 2 of 2
17 Aug 2012, 8:56 PM
#1
amandacreation avatar

amandacreation

New Zenner

Join Date:
Aug 2012
Posts:
2
Plugin Contributions:
0

Suddenly customers having problems downloading

I run a digital scrapbooking store using zen cart. Recently I started getting a slew of emails from customers that they were unable to download their files fully. The file would be 15MB and only 3MB would download. They go to unzip the files and get error message that the files are invalid. I have told them to go back and try again and make sure they only download one file at a time, and sometimes that works and sometimes that doesn't. Customers that have previously not had a problem in my store are now having this problem. They are experiencing this problem in my store and not in other stores. My files are all valid and there is nothing wrong with them...something is going wrong through the transfer. People keep telling me its user error, that its the customers fault and problem, but nearly EVERY order coming through my store is having this problem...and this was not the case up until about a week ago. What could it be? I am at a loss, and if I don't get it fixed I will have to probably just close my store because I can't keep up with the emails of things not working and resetting download links. Any help is greatly appreciated!

18 Aug 2012, 12:44 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Suddenly customers having problems downloading

When something "suddenly" stops working, you need to backtrack and find out what changed in any/all pieces involved.
From the Posting Tips that show up every time you click "new" or "reply" for a post here: > WHEN did the problem "start"? How does that compare with other events of your hosting company, changes you've made to your site files/addons, or your admin settings, etc?

  • changes made in your store, by you, such as new addons, version upgrades, changes to PHP files or admin settings, etc
  • changes your hosting company made to the server, including PHP versions, PHP settings, Apache settings, IIS upgrades, server rebuilds, site move to another server, etc
  • changes made to your store by unauthorized visitors who have fraudulently gained access to your site by stealing passwords or otherwise hacking in through some vulnerability in other code, etc

It's not uncommon to see the symptoms you describe suddenly happen after the hosting company has made changes. Granted, they'll rarely fess up to it, but it quite often is that. And those kinds of symptoms occur far more frequently on Windows/IIS hosting servers than on Linux/Apache servers.