Zen Cart Logo
Forums / Upgrading to 1.5.x / admin_activity_log Error when reseting admin log on IIS Server

admin_activity_log Error when reseting admin log on IIS Server

Locked

Views: 2,281

Results 1 to 10 of 10
This thread is locked. New replies are disabled.
24 Aug 2012, 5:53 PM
#1
chadderuski avatar

chadderuski

Totally Zenned

Join Date:
Apr 2006
Location:
Dark Side of the Moon
Posts:
986
Plugin Contributions:
0

admin_activity_log Error when reseting admin log on IIS Server

More fun with IIS. This should be an easy fix, but I want to make sure I have the correct default value for 'gzpost':

[24-Aug-2012 15:10:32 UTC] PHP Fatal error: 1364:Field 'gzpost' doesn't have a default value :: insert into zen_admin_activity_log (access_date, admin_id, page_accessed, page_parameters, ip_address) values (now(), '2', 'Log reset by {xxxx[2]}.', '', 'xx.xx.216.90') in \web\domain.com\includes\classes\db\mysql\query_factory.php on line 101

This doesn't happen on apache.

So, what should gzpost default to?

Thanks!

-chadd

24 Aug 2012, 6:32 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: admin_activity_log Error when reseting admin log on IIS Server

As shown here: https://github.com/zencart/zencart/commit/a4f2d78d1d6fc562068e3b445ea0798af4ab9917, simply add the one-line for ```
gzpost => ''

Don't do the other changes shown there, since they're specific to the new version.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

24 Aug 2012, 7:08 PM
#3
chadderuski avatar

chadderuski

Totally Zenned

Join Date:
Apr 2006
Location:
Dark Side of the Moon
Posts:
986
Plugin Contributions:
0

Re: admin_activity_log Error when reseting admin log on IIS Server

Thanks Doc! That did the trick!

15 Oct 2012, 3:21 AM
#4
su35 avatar

su35

Zen Follower

Join Date:
Oct 2011
Posts:
168
Plugin Contributions:
0

Re: admin_activity_log Error when reseting admin log on IIS Server

Hi DrByte. I have the same problem on Apache. Unfortunately, I couldn't open the link that you listed above (404). Could you give me more direction?
Thanks

15 Oct 2012, 3:32 AM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: admin_activity_log Error when reseting admin log on IIS Server

link updated

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

16 Oct 2012, 2:29 AM
#6
su35 avatar

su35

Zen Follower

Join Date:
Oct 2011
Posts:
168
Plugin Contributions:
0

Re: admin_activity_log Error when reseting admin log on IIS Server

I got it. Thanks

13 Nov 2012, 4:08 AM
#7
su35 avatar

su35

Zen Follower

Join Date:
Oct 2011
Posts:
168
Plugin Contributions:
0

Re: admin_activity_log Error when reseting admin log on IIS Server

updated to 1.5.1. The problem is still there.
Attachment 11424
When I clicked the reset button, an error message appeared.

[13-Nov-2012 04:03:01 UTC] PHP Fatal error:  1364:Field 'gzpost' doesn't have a default value :: insert into admin_activity_log (access_date, admin_id, page_accessed, page_parameters, ip_address) values (now(), '1', 'Log reset by {su35[1]}.', '', '127.0.0.1') in H:\zencart15\includes\classes\db\mysql\query_factory.php on line 120

I had check the init_admin_history.php, it's the 1.5.1 version.

13 Nov 2012, 4:55 AM
#8
su35 avatar

su35

Zen Follower

Join Date:
Oct 2011
Posts:
168
Plugin Contributions:
0

Re: admin_activity_log Error when reseting admin log on IIS Server

I have checked the database by phpmyadmin. The logs was reset exactly.

14 Nov 2012, 7:42 AM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: admin_activity_log Error when reseting admin log on IIS Server

Do the same fix at line 264 of /admin/admin_activity.php

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

15 Nov 2012, 2:07 AM
#10
su35 avatar

su35

Zen Follower

Join Date:
Oct 2011
Posts:
168
Plugin Contributions:
0

Re: admin_activity_log Error when reseting admin log on IIS Server

Thanks DrByte.