Zen Cart Logo
Forums / Bug Reports / *[Done v1.6.0] Attributes controller fatal error after upgrade

*[Done v1.6.0] Attributes controller fatal error after upgrade

Locked

Views: 9,432

Results 21 to 23 of 23
This thread is locked. New replies are disabled.
25 Jun 2013, 10:39 AM
#21
hitch avatar

hitch

New Zenner

Join Date:
Sep 2006
Posts:
75
Plugin Contributions:
0

*[Done v1.6.0] Attributes controller fatal error after upgrade

Hey,

I get this exact error. after applying the 3 file adjustments i still get the following same error.

PHP Fatal error: 1062: Duplicate entry '0-1' for key 'PRIMARY' :: INSERT INTO products_options_values (products_options_values_id, language_id, products_options_values_name) VALUES (0, 1, 'TEXT') in C:\wamp\www\localroot\includes\classes\db\mysql\query_factory.php on line 120

Cheers for any help :-)

25 Jun 2013, 9:00 PM
#22
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: *[Done v1.6.0] Attributes controller fatal error after upgrade

If, in phpMyAdmin, you browse the table:
products_options_values

and sort on:
products_options_values_id

What records have 0 for the value?

Do they have the field:
products_options_values_name

set to, in caps, TEXT for the value if you see any where products_options_values_id is 0?

26 Jun 2013, 1:14 AM
#23
hitch avatar

hitch

New Zenner

Join Date:
Sep 2006
Posts:
75
Plugin Contributions:
0

Re: *[Done v1.6.0] Attributes controller fatal error after upgrade

Thank you so much this worked perfectly.

:-)