Zen Cart Logo
Forums / All Other Contributions/Addons / Testimonial Manager Support Thread (for ZC v1.5.x)

Testimonial Manager Support Thread (for ZC v1.5.x)

Views: 65,863

Results 101 to 120 of 263
3 Apr 2014, 1:21 AM
#101
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Testimonial Manager Support Thread (for ZC v1.5.x)

you notify them by making the necessary changes, and submit an updated version> grantopt:

So I assume this all can be deleted as it is not supposed to be here?

INSERT INTO configuration VALUES (NULL, 'Product option type Select', 'PRODUCTS_OPTIONS_TYPE_SELECT', '0', 'The number representing the Select type of product option.', 0, NULL, NULL, now(), NULL, NULL);
INSERT INTO configuration VALUES (NULL, 'Upload prefix', 'UPLOAD_PREFIX', 'upload_', 'Prefix used to differentiate between upload options and other options', 0, NULL, NULL, now(), NULL, NULL);
INSERT INTO configuration VALUES (NULL, 'Text prefix', 'TEXT_PREFIX', 'txt_', 'Prefix used to differentiate between text option values and other option values', 0, NULL, NULL, now(), NULL, NULL);
INSERT INTO configuration VALUES (NULL, 'Image Handler Version', 'IH_VERSION', '2.0', 'This is used by image handler to check if the database is up to date with uploaded image handler files.', 0, 100, NULL, now(), NULL, 'zen_cfg_textarea_small(');

> 
> I went back to the plugins section and downloaded a fresh copy of the v1.5.4.  Checking the uninstall.sql, the same 4 inserts were present.  I then figured I would check other uploaded versions.  I downloaded the latest v1.5.5 and 2 other older versions v1.5.3d and v 1.5.2.  To my surprise, ALL of them have these same 4 inserts.  
> 
> To help others who may do a uninstall how do I notify the zencart team that the uploaded uninstall.sql needs to be changed?

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

3 Apr 2014, 1:33 AM
#102
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

grantopt:

So I assume this all can be deleted as it is not supposed to be here?

INSERT INTO configuration VALUES (NULL, 'Product option type Select', 'PRODUCTS_OPTIONS_TYPE_SELECT', '0', 'The number representing the Select type of product option.', 0, NULL, NULL, now(), NULL, NULL);
INSERT INTO configuration VALUES (NULL, 'Upload prefix', 'UPLOAD_PREFIX', 'upload_', 'Prefix used to differentiate between upload options and other options', 0, NULL, NULL, now(), NULL, NULL);
INSERT INTO configuration VALUES (NULL, 'Text prefix', 'TEXT_PREFIX', 'txt_', 'Prefix used to differentiate between text option values and other option values', 0, NULL, NULL, now(), NULL, NULL);
INSERT INTO configuration VALUES (NULL, 'Image Handler Version', 'IH_VERSION', '2.0', 'This is used by image handler to check if the database is up to date with uploaded image handler files.', 0, 100, NULL, now(), NULL, 'zen_cfg_textarea_small(');

> 
> I went back to the plugins section and downloaded a fresh copy of the v1.5.4.  Checking the uninstall.sql, the same 4 inserts were present.  I then figured I would check other uploaded versions.  I downloaded the latest v1.5.5 and 2 other older versions v1.5.3d and v 1.5.2.  To my surprise, ALL of them have these same 4 inserts.  
> 
> To help others who may do a uninstall how do I notify the zencart team that the uploaded uninstall.sql needs to be changed?

The extra inserts resolve a potential problem of running the uninstall as it currently is programmmed.  If on uninstall the 'Testimonials Manager' group is not found, then the configuration_id will be set to zero. Then when the delete is run, those values will be removed. (IH4 also installs at that location.) Ideally the deletions would include a statement in the WHERE clause that the configuration_id (or if I used the wrong spelling.) !=0

This is something that has been reported as a potential issue.  Again though the fix was to restore the four known items that could get deleted, rather than prevent the deletion in the first place.

In regards to "letting the ZC Team" know about an update, well, easy to do. Make the changes, then upload the change to the forum, explain in the documentation why the change was made, how to install it, what file(s) changed, etc... And the ZC staff will be notified to activate the change, which will happen after a review.

ZC Installation/Maintenance Support <- Site
Contribution for contributions welcome...

3 Apr 2014, 1:52 AM
#103
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

Well how about this.. those extra inserts are the WRONG SOLUTION to the problem.. the RIGHT SOLUTION is to FIX the uninstall SQL..> mc12345678:

The extra inserts resolve a potential problem of running the uninstall as it currently is programmmed. If on uninstall the 'Testimonials Manager' group is not found, then the configuration_id will be set to zero. Then when the delete is run, those values will be removed. (IH4 also installs at that location.) Ideally the deletions would include a statement in the WHERE clause that the configuration_id (or if I used the wrong spelling.) !=0

This is something that has been reported as a potential issue. Again though the fix was to restore the four known items that could get deleted, rather than prevent the deletion in the first place.

In regards to "letting the ZC Team" know about an update, well, easy to do. Make the changes, then upload the change to the forum, explain in the documentation why the change was made, how to install it, what file(s) changed, etc... And the ZC staff will be notified to activate the change, which will happen after a review.

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

3 Apr 2014, 1:58 AM
#104
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

You do not want to remove these configuration_keys:
PRODUCTS_OPTIONS_TYPE_SELECT
UPLOAD_PREFIX
TEXT_PREFIX

Those are important to leave in your configuration table as they are used by Zen Cart, regardless of your add-ons ...

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

3 Apr 2014, 2:21 AM
#105
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

DivaVocals:

Well how about this.. those extra inserts are the WRONG SOLUTION to the problem.. the RIGHT SOLUTION is to FIX the uninstall SQL..

Ajeh:

You do not want to remove these configuration_keys:
PRODUCTS_OPTIONS_TYPE_SELECT
UPLOAD_PREFIX
TEXT_PREFIX

Those are important to leave in your configuration table as they are used by Zen Cart, regardless of your add-ons ...

nodding in agreement correctly repairing the uninstall.sql so that only data specifically associated with the install is deleted/modified, which means not to remove the three ZC default values and the one that is added by another plugin.

Just deleting the four inserts will not fully resolve the situation.

ZC Installation/Maintenance Support <- Site
Contribution for contributions welcome...

3 Apr 2014, 5:32 AM
#106
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

mc12345678:

nodding in agreement correctly repairing the uninstall.sql so that only data specifically associated with the install is deleted/modified, which means not to remove the three ZC default values and the one that is added by another plugin.

Just deleting the four inserts will not fully resolve the situation.

and the actual solution is SOOOOOO simple.. Remove the 4 extra insert statements (it was NEVER the right solution..) then just remove this line:

SET @configuration_group_id=0;

and you are left with the RIGHT uninstall script..

#Testimonials Manager SQL Uninstall

SELECT @configuration_group_id:= `configuration_group_id`
FROM configuration_group
WHERE configuration_group_title= 'Testimonials Manager'
LIMIT 1;

DELETE FROM configuration WHERE configuration_group_id = @configuration_group_id;
DELETE FROM configuration_group WHERE configuration_group_id = @configuration_group_id;
DELETE FROM configuration WHERE configuration_key = 'DEFINE_TESTIMONIAL_STATUS';

DROP TABLE IF EXISTS `testimonials_manager`;

DELETE FROM admin_pages WHERE page_key = 'configTestimonialsManager' LIMIT 1;
DELETE FROM admin_pages WHERE page_key = 'TestimonialsManager' LIMIT 1;

Now if anyone wants to "notify the admin" by updating the package and submitting an update.. feel free..:smile:

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

3 Apr 2014, 11:50 AM
#107
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,102
Plugin Contributions:
56

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

DivaVocals:

and the actual solution is SOOOOOO simple.. Remove the 4 extra insert statements (it was NEVER the right solution..) then just remove this line:

SET @configuration_group_id=0;

> 
> and you are left with the RIGHT uninstall script..
> 
> ```
#Testimonials Manager SQL Uninstall

SELECT @configuration_group_id:= `configuration_group_id`
FROM configuration_group
WHERE configuration_group_title= 'Testimonials Manager'
LIMIT 1;

DELETE FROM configuration WHERE configuration_group_id = @configuration_group_id AND @configuration_group_id != 0;
DELETE FROM configuration_group WHERE configuration_group_id = @configuration_group_id AND @configuration_group_id != 0;
DELETE FROM configuration WHERE configuration_key = 'DEFINE_TESTIMONIAL_STATUS';

DROP TABLE IF EXISTS `testimonials_manager`;

DELETE FROM admin_pages WHERE page_key = 'configTestimonialsManager' LIMIT 1;
DELETE FROM admin_pages WHERE page_key = 'TestimonialsManager' LIMIT 1;

Now if anyone wants to "notify the admin" by updating the package and submitting an update.. feel free..:smile:
Just a couple of minor updates, shown in red above.

3 Apr 2014, 1:08 PM
#108
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

lat9:

Just a couple of minor updates, shown in red above.

HA! Good catch!!

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

3 Apr 2014, 1:30 PM
#109
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

DivaVocals:

HA! Good catch!!

Yup.

Just a little explanation for those that may like to understand more:
That additional code will categorically prevent the need for the four inserts that were a part of the previous uninstall.sql and will prevent the deletion of the three values pointed out by ajeh.

As previously written if the @configuration_group_id wasn't present for the searched title, then it was possible that the return value would be 0, and the subsequent delete's would delete items having a value of 0 (at least the three identified by ajeh, and as well one value from the IH4 install and any other modified code that chose to use a configuration_group_id of 0) which would end up causing problems for the store if the first three were deleted.

ZC Installation/Maintenance Support <- Site
Contribution for contributions welcome...

7 May 2014, 10:53 PM
#110
dollyduke avatar

dollyduke

New Zenner

Join Date:
Apr 2014
Posts:
5
Plugin Contributions:
0

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

I have this installed and i got a Install Success but it is not showing in the Layout Box Controller so I cant turn it on so it is not showing up on my site...any help would be welcome.

8 Jul 2014, 11:11 AM
#111
jsarwar avatar

jsarwar

Zen Follower

Join Date:
Jul 2012
Posts:
347
Plugin Contributions:
0

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

Installed on ZC 1.5.3. Uploaded all files and admin does not load then removed file from admin/include/auto_loaders and admin load.
See Testimonial Manager below Tools and Configuration but TM below Configuration does not have any fields or options to edit it load blank page?
Side box is appearing in layout controller and is on but on live site it shows "WARNING: An Error occurred, please refresh the page and try again." instead of testimonials and also footer does not appear. When I delete /includes/modules/sideboxes/template/testimonials_manager.php footer does appear.
Can you please assist how I can fix both of these issues?

Thank you!

8 Jul 2014, 4:10 PM
#112
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,102
Plugin Contributions:
56

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

jsarwar:

Installed on ZC 1.5.3. Uploaded all files and admin does not load then removed file from admin/include/auto_loaders and admin load.
See Testimonial Manager below Tools and Configuration but TM below Configuration does not have any fields or options to edit it load blank page?
Side box is appearing in layout controller and is on but on live site it shows "WARNING: An Error occurred, please refresh the page and try again." instead of testimonials and also footer does not appear. When I delete /includes/modules/sideboxes/template/testimonials_manager.php footer does appear.
Can you please assist how I can fix both of these issues?

Thank you!
When you see "Warning: An Error occurred...", there's a myDEBUG*.log file present in your store's /logs directory that will have details of the error. You could post the contents of that log (making sure to xxx-out the name of your admin folder's name!).

Note also that the error is resulting in the remainder of the page not rendering; that's why you dno't see a footer.

8 Jul 2014, 5:23 PM
#113
jsarwar avatar

jsarwar

Zen Follower

Join Date:
Jul 2012
Posts:
347
Plugin Contributions:
0

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

lat9:

When you see "Warning: An Error occurred...", there's a myDEBUG*.log file present in your store's /logs directory that will have details of the error. You could post the contents of that log (making sure to xxx-out the name of your admin folder's name!).

Note also that the error is resulting in the remainder of the page not rendering; that's why you dno't see a footer.

I was upgrading from 1.3.9 to 1.5.3 and 1.3 had older version of this module so probably that was reason but I just tried to install this module on fresh ZC 1.5.3 and as soon as I upload config.tm.php to admin//includes/auto_loaders admin page does not load and give error.

and when I turn on testimonial side box "WARNING: An Error occurred, please refresh the page and try again." still appear with no site footer.

How I can fix this and get modules installed?

Log error shows
[08-Jul-2014 12:26:40] PHP Fatal error: 1136:Column count doesn't match value count at row 1 :: INSERT INTO zen_configuration VALUES (NULL, 'Number Of Testimonials to display in Testimonials Sidebox', 'MAX_DISPLAY_TESTIMONIALS_MANAGER_TITLES', '5', 'Set the number of testimonials to display in the Latest Testimonials box.', '34', 1, NULL, now(), NULL, NULL) ==> (as called by) /home/suppgeek/public_html/dem/zcadmin/includes/init_includes/init_tm_config.php on line 82 <== in /home/suppgeek/public_html/dem/includes/classes/db/mysql/query_factory.php on line 155

I am using all files from module with out any change.
Thank you

12 Jul 2014, 3:05 AM
#114
jsarwar avatar

jsarwar

Zen Follower

Join Date:
Jul 2012
Posts:
347
Plugin Contributions:
0

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

jsarwar:

I was upgrading from 1.3.9 to 1.5.3 and 1.3 had older version of this module so probably that was reason but I just tried to install this module on fresh ZC 1.5.3 and as soon as I upload config.tm.php to admin//includes/auto_loaders admin page does not load and give error.

and when I turn on testimonial side box "WARNING: An Error occurred, please refresh the page and try again." still appear with no site footer.

How I can fix this and get modules installed?

Log error shows
[08-Jul-2014 12:26:40] PHP Fatal error: 1136:Column count doesn't match value count at row 1 :: INSERT INTO zen_configuration VALUES (NULL, 'Number Of Testimonials to display in Testimonials Sidebox', 'MAX_DISPLAY_TESTIMONIALS_MANAGER_TITLES', '5', 'Set the number of testimonials to display in the Latest Testimonials box.', '34', 1, NULL, now(), NULL, NULL) ==>

I am using all files from module with out any change.
Thank you

Any one who can assist me with this?

Log error shows
[08-Jul-2014 12:26:40] PHP Fatal error: 1136:Column count doesn't match value count at row 1 :: INSERT INTO zen_configuration VALUES (NULL, 'Number Of Testimonials to display in Testimonials Sidebox', 'MAX_DISPLAY_TESTIMONIALS_MANAGER_TITLES', '5', 'Set the number of testimonials to display in the Latest Testimonials box.', '34', 1, NULL, now(), NULL, NULL) ==>

Thank you.

12 Jul 2014, 4:10 AM
#115
yaritai avatar

yaritai

Zen Follower

Join Date:
Apr 2014
Posts:
154
Plugin Contributions:
0

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

jsarwar:

Any one who can assist me with this?

Log error shows
[08-Jul-2014 12:26:40] PHP Fatal error: 1136:Column count doesn't match value count at row 1 :: INSERT INTO zen_configuration VALUES (NULL, 'Number Of Testimonials to display in Testimonials Sidebox', 'MAX_DISPLAY_TESTIMONIALS_MANAGER_TITLES', '5', 'Set the number of testimonials to display in the Latest Testimonials box.', '34', 1, NULL, now(), NULL, NULL) ==>

Thank you.

You MAY have to wait for the plugins you want to be made compatible with 1.5.3. This is always the tricky part and the reason why I don't always recommend the sites I work on to move to the newest ones IF the mods they need are not compatible yet.

12 Jul 2014, 4:15 AM
#116
jsarwar avatar

jsarwar

Zen Follower

Join Date:
Jul 2012
Posts:
347
Plugin Contributions:
0

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

I did not want to upgrade yet but there are many nice modules now which are only compatible with 1.5 so trying to keep as much as possible of old modules as my customers are used to them and adding new to improve store. I am not sql expert and beginner to learn so if you have any knowledge of it please spend sometime to adjust this module files as there are some other modules which gives same error so I think if 1 get fixed, other should be quick. I am also talking with other folks and they are looking into this. You may download module from

http://www.zen-cart.com/downloads.php?do=file&id=299

Thank you.

12 Jul 2014, 9:14 PM
#117
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

jsarwar:

I did not want to upgrade yet but there are many nice modules now which are only compatible with 1.5 so trying to keep as much as possible of old modules as my customers are used to them and adding new to improve store. I am not sql expert and beginner to learn so if you have any knowledge of it please spend sometime to adjust this module files as there are some other modules which gives same error so I think if 1 get fixed, other should be quick. I am also talking with other folks and they are looking into this. You may download module from

http://www.zen-cart.com/downloads.php?do=file&id=299

Thank you.

Having worked with jsarwar earlier today, a solution was found for the described problem at least as far as installing on ZC 1.5.0 because the error experienced appears to be SQL server related not so much ZC version; however, have not heard back if the same problem was occurring on ZC 1.5.3. Regardless a modified install and uninstall scripts are being uploaded as a patch to this plugin. Also looking through the forum to find any identified bugs that need to be incorporated.

ZC Installation/Maintenance Support <- Site
Contribution for contributions welcome...

13 Jul 2014, 2:05 PM
#118
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

jsarwar:

Any one who can assist me with this?

Log error shows
[08-Jul-2014 12:26:40] PHP Fatal error: 1136:Column count doesn't match value count at row 1 :: INSERT INTO zen_configuration VALUES (NULL, 'Number Of Testimonials to display in Testimonials Sidebox', 'MAX_DISPLAY_TESTIMONIALS_MANAGER_TITLES', '5', 'Set the number of testimonials to display in the Latest Testimonials box.', '34', 1, NULL, now(), NULL, NULL) ==>

Thank you.
Not related to v1.5.3 AT ALL..

The issue is you have a Numinix module installed which adds an additional column to the configuration table. The Testimonials module uses a shortcut in the install SQL and does not explicitly name the table column names because it assumes the table structure has not changed.. hence the "missing column" error..

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

13 Jul 2014, 2:09 PM
#119
jsarwar avatar

jsarwar

Zen Follower

Join Date:
Jul 2012
Posts:
347
Plugin Contributions:
0

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

DivaVocals:

Not related to v1.5.3 AT ALL..

The issue is you have a Numinix module installed which adds an additional column to the configuration table. The Testimonials module uses a shortcut in the install SQL and does not explicitly name the table column names because it assumes the table structure has not changed.. hence the "missing column" error..

Thank you so what need to be added to sql? Becuase if numinix module is installed that also goes under configuration and that's where Testimonial Manager goes. What is the column name numinix add?

13 Jul 2014, 2:13 PM
#120
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Testimonial Manager Support Thread (for ZC v1.5.x)

jsarwar:

Thank you so what need to be added to sql? Becuase if numinix module is installed that also goes under configuration and that's where Testimonial Manager goes.
Please re-read my post.. I state what's missing..

My Site - Zen Cart & WordPress integration specialist
I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.