Zen Cart Logo
Forums / General Questions / Can't Log in to Admin. Pretty Much URGENT

Can't Log in to Admin. Pretty Much URGENT

Views: 1,171

Results 1 to 8 of 8
15 Nov 2012, 8:47 PM
#1
lafaverp avatar

lafaverp

New Zenner

Join Date:
Sep 2011
Posts:
27
Plugin Contributions:
0

Can't Log in to Admin. Pretty Much URGENT

So I'm trying to log in to my ZC 1.5 site and I get "WARNING: An Error occurred, please refresh the page and try again." Of course this always happens (repeat "always") after updating an order. This time though it is happening when I try to log in to admin.

  • cleared cache (Chrome)
    no joy
  • tried IE and FireFox
    no joy

So basically I'm really sucking right now. I could sure use a smart person about now....please?

:yuck:

15 Nov 2012, 9:33 PM
#3
lafaverp avatar

lafaverp

New Zenner

Join Date:
Sep 2011
Posts:
27
Plugin Contributions:
0

Re: Can't Log in to Admin. Pretty Much URGENT

Here is my error_log. Does anyone speak "non-regex". I'm a bit rusty.

[Thu Nov 15 14:29:16 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.[Thu Nov 15 14:29:28 2012] [error] [client 127.0.0.1] File does not exist: /usr/local/apache/htdocs/scrape[Thu Nov 15 14:29:28 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.Use of uninitialized value $1 in concatenation (.) or string at /usr/local/cpanel/cgi-sys/fourohfour.cgi line 31.[Thu Nov 15 14:29:30 2012] [error] [client 127.0.0.1] File does not exist: /usr/local/apache/htdocs/scrapeUse of uninitialized value $1 in concatenation (.) or string at /usr/local/cpanel/cgi-sys/fourohfour.cgi line 31.[Thu Nov 15 14:29:31 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.[Thu Nov 15 14:29:36 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.[Thu Nov 15 14:29:38 2012] [error] [client 66.249.66.142] File does not exist: /usr/local/apache/htdocs/lastnewsUse of uninitialized value $1 in concatenation (.) or string at /usr/local/cpanel/cgi-sys/fourohfour.cgi line 31.[Thu Nov 15 14:29:39 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.[Thu Nov 15 14:29:57 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.[Thu Nov 15 14:29:58 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.[Thu Nov 15 14:29:58 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring![Thu Nov 15 14:29:58 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!

15 Nov 2012, 9:41 PM
#4
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Can't Log in to Admin. Pretty Much URGENT

It appears that you are using a url re-write addon

15 Nov 2012, 9:42 PM
#5
lafaverp avatar

lafaverp

New Zenner

Join Date:
Sep 2011
Posts:
27
Plugin Contributions:
0

Re: Can't Log in to Admin. Pretty Much URGENT

Ok, and???

15 Nov 2012, 9:48 PM
#6
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Can't Log in to Admin. Pretty Much URGENT

url rewriters cause issues and with the admin
Search here for others that have had similar issues

15 Nov 2012, 10:57 PM
#7
lhungil avatar

lhungil

Totally Zenned

Join Date:
Feb 2012
Location:
mostly harmless
Posts:
1,818
Plugin Contributions:
4

Re: Can't Log in to Admin. Pretty Much URGENT

As noted in the log file the web server is just ignoring the -f flag, so that is not a source of your issue.
However if you are using a URL Rewriter you may want to see if an updated version exists.

The two messages which I find interesting in your server error_log are:

[client 127.0.0.1] File does not exist: /usr/local/apache/htdocs/scrape
Use of uninitialized value $1 in concatenation (.) or string at /usr/local/cpanel/cgi-sys/fourohfour.cgi line 31.

It's pretty rare to see requests from localhost for broken files or requests to cpanel when trying to log into Zen Cart's admin interface.

What is in your error logs for Zen Cart?

15 Nov 2012, 11:04 PM
#8
lafaverp avatar

lafaverp

New Zenner

Join Date:
Sep 2011
Posts:
27
Plugin Contributions:
0

Re: Can't Log in to Admin. Pretty Much URGENT

First, thanks for the response. I have a Zen Gun Slinger on it. It may be my host (Hostmonster.com). I am unable to access my site as well. As for a url re-write addon I have no idea why I would use one. I guess that's some kind of SEO thing? I moved up from the "Share Your Server with Four Billion Other People Plan" to the Pro Plan. The difference is about $200 bucks a year. Sounds like the old "you can buy our standard version which works some of the time, or, you can get our "Pro" version which crashes less than the standard version"