Zen Cart Logo
Forums / General Questions / PHP Warnings keep piling after migration

PHP Warnings keep piling after migration

Views: 494

Results 1 to 4 of 4
1 Mar 2013, 7:46 AM
#1
hal_9000 avatar

hal_9000

New Zenner

Join Date:
Jul 2008
Posts:
1
Plugin Contributions:
0

PHP Warnings keep piling after migration

After successfully migrating an installation over to another server, seems like every page load keeps outputting the following warnings into 'error_log' (different hosting providers but former and new servers are both Linux/php5)

[01-Mar-2013 01:18:48] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/timezonedb.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/timezonedb.so: cannot open shared object file: No such file or directory in Unknown on line 0
[01-Mar-2013 01:18:48] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so: cannot open shared object file: No such file or directory in Unknown on line 0

The previous installation is still active but 'error_log' is not present in it, did I miss something?

Thanks in advance.

1 Mar 2013, 7:58 AM
#2
schoolboy avatar

schoolboy

Totally Zenned

Join Date:
Jun 2005
Location:
Cumbria, UK
Posts:
10,327
Plugin Contributions:
0

Re: PHP Warnings keep piling after migration

HAL-9000:

After successfully migrating an installation over to another server, seems like every page load keeps outputting the following warnings into 'error_log' (different hosting providers but former and new servers are both Linux/php5)

[01-Mar-2013 01:18:48] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/timezonedb.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/timezonedb.so: cannot open shared object file: No such file or directory in Unknown on line 0
[01-Mar-2013 01:18:48] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so: cannot open shared object file: No such file or directory in Unknown on line 0

> 
> The previous installation is still active but 'error_log' is not present in it, did I miss something?
> 
> Thanks in advance.

Send these errors to your host. They might have to deal with php settings.
1 Mar 2013, 11:23 PM
#3
fjavier avatar

fjavier

New Zenner

Join Date:
Jun 2006
Posts:
20
Plugin Contributions:
0

Re: PHP Warnings keep piling after migration

schoolboy:

Send these errors to your host. They might have to deal with php settings.

Thanks for your reply, I notified the webhost and they already installed missing php modules.

If I like to re-check that there are no more warnings, by any chance do you know how to clear the 'error_log' files? it seems like it has accumulated thousands of records.

2 Mar 2013, 4:10 AM
#4
swguy avatar

swguy

Administrator

Join Date:
Feb 2006
Location:
Tampa Bay, Florida
Posts:
10,706
Plugin Contributions:
56

Re: PHP Warnings keep piling after migration

Just delete them. They'll be recreated if they're needed. :)