Zen Cart Logo
Forums / Setting Up Categories, Products, Attributes / Error message when review and save changed item

Error message when review and save changed item

Views: 1,391

Results 1 to 3 of 3
28 Mar 2013, 6:33 PM
#1
portraitartist avatar

portraitartist

New Zenner

Join Date:
Mar 2006
Posts:
86
Plugin Contributions:
0

Error message when review and save changed item

Hi,
I use ZenCart since the 1.2.6 version and always updated manually to the new ones.
After I installed the 1.5.0 version I am unable to edit items because I receive this error message.

Quote:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Quote End

I created the item descriptions manually and edited when needed with the ZenCart supplied editor, that is not available anymore.
The only time the system let me go through if I take out the original description an write a new one.
Please let me figure out what is the cause of the error so i can edit the descriptions without writing a new one.

Here is a typical description

Quote:

<p>The <strong>Embroidered Border Collie HD Portrait Patches</strong> are ready to attach to garments and accessories; <br />We created the <strong>Medium Size Border Collie HD Portrait Embroidery Patch</strong> for <strong>left chest placement</strong> on T-shirts, Polo Shirts and other garments. Also <strong>good fit for tote bags</strong> and other accessories.<br /><em><u>Please scroll down for available patch colors.<br /><br /></u></em><strong>Patch Size:</strong> Approx. 4"W X 4"H (102mmX102mm)<br /><strong>More sizes:</strong> <strong> <br />6" Large Border Collie HD Portrait Embroidery Patch</strong> <a href="http://www.embroideryportraits.com/Gifts/index.php?main_page=product_info&cPath=3_52&products_id=264">Click Here To Buy</a> <br /><strong>8" Extra Large Border Collie HD Portrait Embroidery Patch</strong> <a href="http://www.embroideryportraits.com/Gifts/index.php?main_page=product_info&cPath=3_52&products_id=265">Click Here To Buy</a> <br /><strong>10" Double Extra Large Border Collie HD Portrait Embroidery Patch</strong> <a href="http://www.embroideryportraits.com/Gifts/index.php?main_page=product_info&cPath=3_52&products_id=266">Click Here To Buy</a> <br /><br /><br /><strong>How to apply:</strong> You can sew them by hand, or by machine, or glue them on with fabric glue, like Speedsew (find on:Speedsew.com) <br />(Sewing, or glueing materials are not supplied) </p><p><strong>Available Patch Colors:</strong> Blue, Gold, Grey, Red, White, <br /><font color="#ff0000">Please select patch color from the dropdown list below.</font></p> Quote End

Server Tech Data:
Apache: 2.2.22
PHP: 5.2.17
MySQL: 5.0.96-Community

Thank you Portrait Artist

28 Mar 2013, 7:37 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error message when review and save changed item

  1. Moved this out of the Bug Reports area, as it's not a ZC bug.

  2. The "Internal Server Error" is Apache error #500, and is a very generic message. The details of what exactly caused the error are never shown on-screen for security reasons ... quite often because it was triggered by security protection rules in Apache's mod_security, as managed by your hosting company. Instead of showing the actual "cause" on-screen, it simply records the details in the apache errorlog ... which your hosting company has access to.
    See this article from the FAQs area, which I looked up by searching for "internal server error": http://www.zen-cart.com/content.php?105-why-am-i-getting-500-internal-server-error

  3. Expanding on #2 above, mod_security is often configured (by your hosting company whether intentionally or by default because they're blindly using all the generic rules) to explicitly block SQL keywords such as "SELECT" when found in data submitted on the webpage. And, since your product description includes the word "select", that could very well be what's triggering it. Again, that will be detailed in the server's error logs or mod-security logs. If the logs confirm that, then as explained in the following FAQ article, your hosting company can disable the troublesome rule for your site specifically or help you add an exception within your hosting account to bypass the rule for just your admin area: http://www.zen-cart.com/content.php?294-getting-500-or-406-or-404-or-403-errors-when-submitting-product-updates-in-admin-pages

28 Mar 2013, 8:20 PM
#3
portraitartist avatar

portraitartist

New Zenner

Join Date:
Mar 2006
Posts:
86
Plugin Contributions:
0

Re: Error message when review and save changed item

Thank you Dr Byte for the fast answer,
I will check it out and post the findigns for others to see.
Update:
I chaged the word "SELECT" to CHOOSE and that solved the problem.
Thank you again Dr Byte.