New Zenner
- Join Date:
- Feb 2009
- Posts:
- 81
- Plugin Contributions:
- 0
cannot get past accepting liscense
RodG:
There is also a bit of a history to the pdo_ extensions. In the early days (<PHP 5.2 (?) this (and other extensions) needed to be specifically compiled into PHP. Later versions of PHP have them complied in by default, so with a contemporary installation your shouldn't be getting this error in the 1st place.
The portion of the error log that reads..................
Module compiled with module API=20100525
PHP compiled with module API=20090626
.............Is suggesting that there is a version mismatch between the PHP version being used and the module being used. This is usually/always the servers administrators' screwup, BUT, it can also be caused by a misconfiguration in the php.ini file (possibly because it was copied from one server to another?)So in summary, yes it is still definitely a server error, and under normal circumstances I'd be saying that only your host can resolve the problem. However, this isn't a normal circumstance... The spanner in the works is the fact that you changed hosts, and the question of whether the problem has followed your store/site or whether this a a new problem with the new host is yet to be answered.
So, since there is this little bit of doubt in my mind, and since it is possible that the problem has followed your site, I have two suggestions that may resolve the problem without getting your host involved.
Firstly, look for a file called 'php.ini' in your /public_html and/or store folders. If you find any, try renaming them (php.ini_bak) and see if the problems go away.
Secondly, log into your cPanel and look for the 'software/services' section and see if you have an option to select a different PHP version. If so, try changing to a different version and see if that takes care of the problem for you.
oh I had totally forgotten about this problem because i decided to postpone it but there you nailed it Rod!!! I did change servers because the earlier one was using previous version of PHP and the product pull script I was using was giving significant errors there , but zencart worked fine there , so i asked them if they could upgrade PHP and they refused so I switched here where the product pull scrips works PERFECT but zencart went into glitch, since i rarely need to use zencart , i did not know this until a customer caught this problem. so BRAVO! you nailed it :) i am willing to give it a try once again, I did try renaming php file, issue not fixed and i cannot change the php version but even if i did , my product pull script will go wonky again :/
btw you are right i am often driven by my emotions that is a terrible thing to do I have learned a lesson quiet well and put myself in a terrible mess :*( (not this issue) anyhow i think I am sensible now, at least I hope so
take care and Thanks :)