Zen Cart Logo
Forums / Basic Configuration / Blank admin - but normal public view

Blank admin - but normal public view

Views: 1,012

Results 1 to 6 of 6
27 Aug 2013, 11:56 PM
#1
oavs avatar

oavs

Totally Zenned

Join Date:
Jan 2006
Location:
Downunder - QLD - Gold Coast
Posts:
921
Plugin Contributions:
0

Blank admin - but normal public view

Hi

I am not sure why I can see admin login page. I have read the 'close' topic on this 'Blank admin' and followed through . I even re installed over the existing site and results are the same. Public site is fine. It can't be htaccess file or the host because I have set up zencart on the same server and other sites are fine. Ok it could be the modules may be.

my rant: I wish zencart modules can be installed and uninstalled with one click like word press plugins. It is so painful and I am left with no other choice except to wipe off all and start all over again. It is ridiculous that one single file or config can cause such a havoc and left with one single choice to fix at the end.

28 Aug 2013, 3:30 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Blank admin - but normal public view

You didn't post the contents of your /logs/myDebug-adm-xxxxxx.log files, which contain the PHP errors being encountered and triggering your blank-page problem.
http://www.zen-cart.com/content.php?124-blank-page

28 Aug 2013, 4:43 AM
#3
oavs avatar

oavs

Totally Zenned

Join Date:
Jan 2006
Location:
Downunder - QLD - Gold Coast
Posts:
921
Plugin Contributions:
0

Re: Blank admin - but normal public view

Can't see any error log file. There are only .htaccess, index.html and index.php

28 Aug 2013, 4:54 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Blank admin - but normal public view

Okay, so if the error-logging isn't happening, then you've got a problem that triggers so early that the error-logging hasn't even been enabled. Or you've turned it off.
When this happens in the Admin, if the issue is actually in Zen Cart or PHP, the cause is:

  • the /admin/includes/application_top.php is damaged, altered, or not being loaded
  • the /admin/includes/auto_loaders/ folder contents have been altered
  • the /admin/includes/extra_configures/ contents have been tampered with
  • the /admin/includes/extra_datafiles/ contents have been tampered with
  • the /logs/ folder isn't writable
  • the /admin/includes/configure.php has been damaged or its permissions are set so low that it can't be read and is triggering a fatal PHP error preventing execution

Fastest way to fix a code-related cause is:

  • undo whatever changes you just made between when it was working correctly and when it quit
  • compare the files against a known working set of files (such as the original ZC zip, or one of the many other working sites you said you have)
  • restore from backup
  • replace the files with originals, and recreate your configure.php with valid contents

You implied that these symptoms are related to plugins you've had trouble installing. Perhaps something's awry in the steps being followed to install them.

28 Aug 2013, 5:31 AM
#5
oavs avatar

oavs

Totally Zenned

Join Date:
Jan 2006
Location:
Downunder - QLD - Gold Coast
Posts:
921
Plugin Contributions:
0

Re: Blank admin - but normal public view

Hi , I have done all this without any success. I will wipe and re start all over again. Your 'fastest way' is my slowest.

28 Aug 2013, 6:49 AM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Blank admin - but normal public view

oavs:

Hi , I have done all this without any success.
So, which line of application_top is failing to execute properly?
Which auto-loader step is failing to run?
Is the "blank page" actually returning a 500 INTERNAL SERVER ERROR from Apache? Or is it getting a normal 200 OK response?
Is this particular server one that disallows files/folders to be set to 777 permissions, but since you're using 777 on some admin files or folders it's dying due to the server's security rules?
In the server's PHP error logs, what PHP errors are recorded there? How about in Apache's error_log?