Zen Cart Logo
Forums / Installing on a Linux/Unix Server / install just showing text (looks like php)

install just showing text (looks like php)

Views: 1,807

Results 1 to 6 of 6
16 Sep 2013, 8:56 PM
#1
kurtrr avatar

kurtrr

New Zenner

Join Date:
Sep 2013
Location:
Yukon, Oklahoma, USA
Posts:
10
Plugin Contributions:
0

install just showing text (looks like php)

I think I've installed all the prereq's but when i go to zencart (http://localhost/~kurtrr/zencart/) i get a page of text. And when I go to http://localhost/~kurtrr/zencart/zc_install it opens up another text page. I'm using Ubuntu 13.04 with the prereq software loaded from it's app source.

http://localhost/~kurtrr/zencart/ has the following as the first few lines:*
Load application_top.php - see {@tutorial initsystem}
*
Set main language directory based on $_SESSION['language']
*
Load all *header_php.php files from includes/modules/pages/PAGE_NAME/
*
Load html_header.php (this is a common template file)
*
Load main_template_vars.php (this is a common template file)
*
Load on_load scripts (page based and site wide)
*
Load tpl_main_page.php (this is a common template file)
*
Load application_bottom.php

and http://localhost/~kurtrr/zencart/zc_install has for the first few lines:
0) { for ($i=1;$i<$argc;$i++) { $it = preg_split("/=/",$argv[$i]); $_GET[$it[0]] = $it[1]; // parse_str($argv[$i],$tmp); // $_REQUEST = array_merge($_REQUEST, $tmp); } } if (!isset($_GET) && isset($_SERVER["argc"]) && $_SERVER["argc"] > 1) { for($i=1;$i<$_SERVER["argc"];$i++) { list($key, $val) = explode('=', $_SERVER["argv"][$i]); $_GET[$key] = $_REQUEST[$key] = $val; } } } // init vars: $zc_first_field = ''; // begin processing page-specific actions if (!isset($_GET['main_page']) || !z

The install went fine on my laptop which is also U13.04.
thanks, kurtRR

16 Sep 2013, 9:18 PM
#2
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: install just showing text (looks like php)

Create a file named php-info.php with only this content:

<?php phpinfo(); ?>

Then drop that file into /var/www and load http://localhost/php-info.php

See if the output shows any errors.

Also check the Apache2 error log located in /var/log/apache2 for any errors.

NOTE: We are sorry that Frank is no longer with us.
We are grateful for all his contributions to the Zen Cart community.

16 Sep 2013, 9:29 PM
#3
kurtrr avatar

kurtrr

New Zenner

Join Date:
Sep 2013
Location:
Yukon, Oklahoma, USA
Posts:
10
Plugin Contributions:
0

Re: install just showing text (looks like php)

Thanks for the quick response. I already did php-info. I checked it again and don't recognize any errors. Is there anyting that you want me to post?
The apache2 error.log had a few errors for today when I tried zen cart again. It's errors were for being unable to find the /favicon.ico.
The access.log seems to be OK too.

16 Sep 2013, 9:50 PM
#4
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: install just showing text (looks like php)

kurtrr:

Thanks for the quick response. I already did php-info. I checked it again and don't recognize any errors. Is there anyting that you want me to post?
The apache2 error.log had a few errors for today when I tried zen cart again. It's errors were for being unable to find the /favicon.ico.
The access.log seems to be OK too.

I suggest you either wipe out this install and start fresh with a newly downloaded ZC 1.5.1 file set or go the tedious way in comparing your current install with a stock ZC file set.

You may also want to try and do a new installation in /var/www instead of you home directory.

Cheers / Frank

NOTE: We are sorry that Frank is no longer with us.
We are grateful for all his contributions to the Zen Cart community.

19 Sep 2013, 5:33 PM
#5
kurtrr avatar

kurtrr

New Zenner

Join Date:
Sep 2013
Location:
Yukon, Oklahoma, USA
Posts:
10
Plugin Contributions:
0

Re: install just showing text (looks like php)

Got this resolved.

Didn't have to reload had to change apache2's php5 configuration

in /etc/apache2/mods-enabled/php5.conf the last several line are:

Running PHP scripts in user directories is disabled by default

To re-enable PHP in user directories comment the following lines

(from <IfModule ...> to </IfModule>.) Do NOT set it to On as it

prevents .htaccess files from disabling it.

#<IfModule mod_userdir.c>

<Directory /home/*/public_html>

php_admin_value engine Off

</Directory>

#</IfModule>
As you see I commented them the reloaded the apache2 configuration:
service apache2 reload

Now it works as it should.

19 Sep 2013, 5:55 PM
#6
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,843
Plugin Contributions:
17

Re: install just showing text (looks like php)

Still probably a good idea to move to the www. Will just keep messin' with you.

Need a hand with Zen Cart? Hire the team at myZenCartZone.com for upgrades, repairs, and custom plugins.
Zen Cart Certified hosting at myZenCartHost.com