Forums / General Questions / PHP versions prior to 5.3.12 and 5.4.2 are vulnerable.

PHP versions prior to 5.3.12 and 5.4.2 are vulnerable.

Locked

Started by jetx on 9 Apr 2014, 12:36 AM · Views: 1,315

Results 1 to 8 of 8
This thread is locked. New replies are disabled.
9 Apr 2014, 12:36 AM
#1
jetx avatar

jetx

Zen Follower

Join Date:
Apr 2006
Posts:
425
Plugin Contributions:
0

PHP versions prior to 5.3.12 and 5.4.2 are vulnerable.

  1. PHP CGI Bug - http://arstechnica.com/security/2014...-22-months-on/ --- PHP versions prior to 5.3.12 and 5.4.2 are vulnerable.

As I still have a zencart site left I need to ask for clarification on this post by DrByte today. I understand that 1.51 does not work under php 5.4 without code modification. I do not see exactly what modifications are required.

secondly, does the Dr mean (versions prior to 5.3.12 and 5.4.2 are vulnerable) therefore any version prior to 5.4.2 is vulnerable?.

9 Apr 2014, 3:32 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,511
Plugin Contributions:
176

Re: PHP versions prior to 5.3.12 and 5.4.2 are vulnerable.

jetx:

does the Dr mean (versions prior to 5.3.12 and 5.4.2 are vulnerable) therefore any version prior to 5.4.2 is vulnerable?.
My understanding of the statement (it wasn't mine, I was only quoting it) is that PHP 5.3.1 thru 5.3.11 are vulnerable, and 5.4.0 and 5.4.1 are vulnerable. The quoted article makes no mention of PHP 5.2.xxx versions specifically, but I haven't pursued that further; you may wish to.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

9 Apr 2014, 8:54 PM
#3
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: PHP versions prior to 5.3.12 and 5.4.2 are vulnerable.

PHP V5.2.X is reaching end of life. There are multiple vulnerabilities. The URL below lists them. This URL is specifically for v5.2.17 which is/was the default version used by a number of distribution of the time and is still in widespread use :-(
http://www.cvedetails.com/vulnerability-list/vendor_id-74/product_id-128/version_id-106044/PHP-PHP-5.2.17.html

NOTE: We are sorry that Rod is no longer with us.
We are grateful for all his contributions to the Zen Cart community.

Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.

10 Apr 2014, 1:16 AM
#4
jetx avatar

jetx

Zen Follower

Join Date:
Apr 2006
Posts:
425
Plugin Contributions:
0

Re: PHP versions prior to 5.3.12 and 5.4.2 are vulnerable.

My issue is whether upgrading php to 5.5. will break zencart. Does anyone know what, if any, files are going to require code edits. Thanks.

note: besides timezone.

10 Apr 2014, 1:30 AM
#5
jetx avatar

jetx

Zen Follower

Join Date:
Apr 2006
Posts:
425
Plugin Contributions:
0

Re: PHP versions prior to 5.3.12 and 5.4.2 are vulnerable.

From this: http://www.zen-cart.com/entry.php?6-Is-your-plugin-code-safe-for-PHP-5-4-and-5-5-and-5-6

I would suspect that many mods will not function correctly under php 5.5.

List of current mods (if anybody knows, please comment). I really don't want to upgrade and find the site is broken.

discount mod, table discounts (swguy)
COWOA
Ceon Manual Card
Cross Sell Advanced (prowebs)
Direct Bank Deposit
Testimonial Manager

10 Apr 2014, 2:25 AM
#7
jetx avatar

jetx

Zen Follower

Join Date:
Apr 2006
Posts:
425
Plugin Contributions:
0

Re: PHP versions prior to 5.3.12 and 5.4.2 are vulnerable.

So, to run securely I would need to recompile php as an apache module rather than cgi? Just confirming, thanks.

10 Apr 2014, 5:40 AM
#8
jetx avatar

jetx

Zen Follower

Join Date:
Apr 2006
Posts:
425
Plugin Contributions:
0

Re: PHP versions prior to 5.3.12 and 5.4.2 are vulnerable.

Upgraded php to 5.3.28, deprecated but I suppose better than what I had (5.2.1.7). Thanks for the link DrB.