smarmyclothes:
I don't appear to have a /images/index.html file
I can only guess it has been deleted at some time. This has been a part of the zencart installation files since at least V1.3.7.
It's probably not important that its missing. I was thinking that this could be where the "Under Maintenance" text was coming from. Since the file doesn't exist it can't be coming from there.
smarmyclothes:
All of the owner/group settings are 500 501 for both the files and directories.
Alas, I am unable to tell you if this is correct or not. This will be different from server to server and owner to owner. The important thing in this case is that they are consistent. )bad files and good files).
smarmyclothes:
Changing the file and directory permissions to 666 and 777 respectively did not work.
This comes as a little bit of a surprise. I would suggest you leave them this way, at least until the issue has been solved (just in case there is a combination of factors at play, with this being one of them)
smarmyclothes:
Here's an image I uploaded last night that works:
http://whatthecraft.com/shop/bmz_cache/2/265a975ce0ca9b1889c195e6894c971e.image.750x728.jpg
However, only the bmzcache version works. The actual file gives the same error:
http://whatthecraft.com/shop/images/patterns14/retro_rockabilly_swing_dress_pattern_03.jpg
This is exactly what I was going to be looking for. You've saved me the trouble. :)
smarmyclothes:
I uploaded the images via FTP.
You should double check that the uploads are being successfully completed.. (Compare the filesizes)
smarmyclothes:
The bmzcache issue makes me think something is going on with Image Handler- though I'm not sure if I have two separate problems (Image Handler not caching some images AND something with the permissions) or just one.
This is also my line of thought, but the two could be related... if IH4 can't read the /images/ files it won't be able to create the cached versions, so only the previously cached versions will be shown... BUT, my thoughts are that since the images can't be viewed via a direct link due to the permissions error then this is most likely to be the source of the problem, so in my mind, step#1 to resolving the issue is to get the files readable via a direct link (and hopefully that would also allow IH4 to read and cache them)... problem solved - Well, that was my theory.
smarmyclothes:
I've been trying to figure out if there's a pattern, and I finally noticed one: all of the images that have no cached version are short. Most of my images are similar width-wise, but the ones that don't work are all under a certain number of pixels in height.
I've never heard about this happening before, and I'm not saying you are wrong.... I'm still at the stage of trying to figure out why none of the files in the /images/ folder are readable via a direct link. Or am I mistaken here? I am somewhat limited in my testing here because I can only test using the names of the files that you've told me about. Having said that, I did try using a couple of 'known' images (call_for_price.jpg and no_picture.gif) with very confusing results.
In both cases, the main page gets displayed rather than the actual images. ZenCart doesn't generally do this (in my experience), which leads me back to thinking that there is a redirect/rewrite going on (.htaccess file?) or perhaps some processing that your WP is doing(???). This is why I suggested you rename or delete the .htaccess file so as to eliminate this possibility.
The other oddity I noticed was that a request to view the 'call_for_price.jpg file gives the following error:
Resource interpreted as Image but transferred with MIME type text/html:
--------------------------------------------------------------------------------------
The no_picture.gif has the same redirect going on, but without any error being reported.
I haven't quite figured out what this means yet, but I'm convinced it is somehow relevant to the problem(s)
smarmyclothes:
Alright, I posted too soon. When I reinstalled IH4, I forgot to set "IH resizes images" to Yes. So my images are showing up again- still having the issues with the actual image URLS not working, just the bmzcache versions show up.
Are all the images now showing, or is it still only the ones that have been previously cached?
smarmyclothes:
Also, I tried increasing the size of one of the "short" images, as I mentioned above, and that image (bmz cache version) works now. So I don't know why the pixel height matters, but for some reason, it does.
Very interesting. I don't suppose you've figured out at exactly what pixel height it fails? (I'm not sure how important this could be, but if you find it needs to be under (say) 10px, then perhaps searching through the code for this value may determine if a coded limitation has been met. (Clutching at straws here).
Another thing I would suggest would be to disable/uninstall IH4 and see what happens. Although I've never actually found IH4 to be the cause of any issues, in a case like this it will be prudent to at least get things working without this add-on. If you can do this, and then find the problem returns when re-installed we can then concentrate solely on what IH4 is doing without concerning ourselves with possible permissions errors. If you still have the problem without IH4 we would have eliminated this as having any bearing on the matter, which will reduce the number of places to look for the apparent size related matter.
So there you have it.
Remove/delete your .htaccess file. Remove or disable IH4, and that will give us a pretty good place for further diagnosis.
Its the old Sherlock Holmes adage. "when you have eliminated the impossible, whatever remains, however improbable, must be the truth".
What we are doing is eliminating as much as we can to narrow down the cause.
Cheers
RodG