Forums / Bug Reports / Admin page access fails with too many redirects

Admin page access fails with too many redirects

Views: 5,686

Results 21 to 29 of 29
14 Jan 2015, 6:41 PM
#21
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Admin page access fails with too many redirects

Hello DrByte,

thanks ever so much for taking the time to reply to me. Please bear with me, I am just going to confirm the last two details. I think I know but I am not 100%.

  • what ZC version are you using?
    I upgraded to 1.5.3, then from there to 1.5.4. I applied sql patches before the admin went awry thankfully, so that is set
  • which init_cache_key_check.php file are you now using
    I am using the one on this thread, before that it was the 1.5.4 version, before that it was 1.5.3
  • are you actually getting just "blank page"? or are you really getting the "too many redirects"?
    What I think happened, is upgraded to 1.5.3 then saw blank page. I had a break then went back to it the other day and still blank. So I saw change log and thought there might be a strong chance it may be fixed in 1.5.4 so upgraded to that. I had someone trying to figure it out, and they notified it was redirect loop and been ever since.
14 Jan 2015, 7:46 PM
#22
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: Admin page access fails with too many redirects

  • Is your webserver running Linux/Ubuntu/CentOS/Windows/...
    Architecture x86_64
    Operating System linux

  • what's your PHP version? Is it running "PHP as CGI"? or "suPHP"? or simply as an Apache module?

PHP Version 5.3.28 - for the second part I will update this post accordingly, just wanted to get a reply to you as soon as I knew. I am sure it is either PHP or CGI though.

16 Jan 2015, 3:07 PM
#25
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Admin page access fails with too many redirects

HeathenMagic:

Also, is there a way to disable the function of this file init_cache_key_check? I have cache folder with sub folders for modules. Would that be messing with this file somehow?
You could just empty out the file contents, or comment-out all the code in the file.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

16 Jan 2015, 5:17 PM
#26
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: Admin page access fails with too many redirects

Hello DrByte,

I emptied the file and encountered some errors similar to this:-

[16-Jan-2015 11:38:33 America/New_York] PHP Warning: mysql_list_fields() [<a href='function.mysql-list-fields'>function.mysql-list-fields</a>]: Access denied for user 'nobody'@'localhost' (using password: NO) in /

I had a module that was displaying similar on the catalog itself but no fatal error. So regards to the admin, I found the files these logs were from and removed them and could get to the admin.

Regarding the file I emptied as you suggested, I tried the file again with code but it still does redirects. So obviously there is something it doesn't like about my server or something else its not giving clues to (admin only).

Thanks for the help! Appreciate it. And if anybody is having the same issue after trying the above fix, it is Numinix modules in the admin that were giving errors and error logs as a secondary error. With regards to that, I suspect it is deprecated MySQL code in those files perhaps.

16 Jan 2015, 5:33 PM
#27
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Admin page access fails with too many redirects

HeathenMagic:

it is Numinix modules in the admin that were giving errors and error logs as a secondary error. With regards to that, I suspect it is deprecated MySQL code in those files perhaps.
Yes. All "mysql_" function calls need to be rewritten to use the built-in Zen Cart database function calls, else they won't work beyond PHP 5.3 or Zen Cart 1.5.1.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

16 Jan 2015, 5:47 PM
#28
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Admin page access fails with too many redirects

HeathenMagic:

Hello DrByte,

I emptied the file and encountered some errors similar to this:-

I had a module that was displaying similar on the catalog itself but no fatal error. So regards to the admin, I found the files these logs were from and removed them and could get to the admin.

Regarding the file I emptied as you suggested, I tried the file again with code but it still does redirects. So obviously there is something it doesn't like about my server or something else its not giving clues to (admin only).

Thanks for the help! Appreciate it. And if anybody is having the same issue after trying the above fix, it is Numinix modules in the admin that were giving errors and error logs as a secondary error. With regards to that, I suspect it is deprecated MySQL code in those files perhaps.

DrByte:

Yes. All "mysql_" function calls need to be rewritten to use the built-in Zen Cart database function calls, else they won't work beyond PHP 5.3 or Zen Cart 1.5.1.

I.e. Basically the plugin would need to be updated to a version that supports ZC 1.5.2/1.5.3+ as part of the upgrade/new installation... Numinix product/code is typically maintained up-to-date either here on ZC, on github or at their site... Without identifying the plugins as requested by the posting tips, further (specific) assistance on this issue is not possible.

ZC Installation/Maintenance Support <- Site
Contribution for contributions welcome...

16 Jan 2015, 6:13 PM
#29
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: Admin page access fails with too many redirects

Thanks DrByte! It makes sense regarding the separate errors I was getting. It is a shame I wasn't able to figure out what is making init_cache_key_check.php cause redirects, but making empty is making admin accessible :-)

Regarding Numinix, all modules are current on the site in question. I checked just now, and one has been updated today, mentioning 1.5.3 compatibility as a feature. Probably just a case of waiting for the others to be updated one at a time by Numinix.