Zen Cart Logo
Forums / General Questions / Blank screen but admin working.

Blank screen but admin working.

Views: 1,796

Results 1 to 18 of 18
6 Oct 2014, 8:06 PM
#1
glamourdolleyes avatar

glamourdolleyes

New Zenner

Join Date:
Mar 2009
Posts:
86
Plugin Contributions:
0

Blank screen but admin working.

Some back details:

  • Just moved from HostGator to GoDaddy on Sunday, September 28th.
  • Using version v1.5.1
  • Admin section is working fine
  • Customers are experiencing blank pages. The website works and then all of the sudden it doesn't work, getting blank pages and some even get server error.
  • I have gotten many successful orders since transferring so it's not happening all the time.

I contacted GoDaddy and they say everything is working properly on their side and to contact Zen Cart. I contacted the guy who did my transfer and he says it's an issue with my hosting. I don't know what to do now. I am losing customers.

I have looked in the DEBUG files:
[06-Oct-2014 19:59:22 UTC] PHP Fatal error: Cannot redeclare zen_create_random_value() (previously declared in /home/xxxxx/public_html/includes/functions/functions_general.php:614) in /home/xxxxx/public_html/includes/functions/password_funcs.php on line 86
[06-Oct-2014 19:59:22 UTC] PHP Warning: require(includes/classes/db/mysql/query_factory.php): failed to open stream: No such file or directory in /home/xxxxx/public_html/includes/functions/sessions.php on line 54
[06-Oct-2014 19:59:22 UTC] PHP Warning: require(includes/classes/db/mysql/query_factory.php): failed to open stream: No such file or directory in /home/xxxxx/public_html/includes/functions/sessions.php on line 54
[06-Oct-2014 19:59:22 UTC] PHP Fatal error: require(): Failed opening required 'includes/classes/db/mysql/query_factory.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/xxxxx/public_html/includes/functions/sessions.php on line 54

My website is glamourdolleyes.com.

Any suggestions? I am completely at a loss.

6 Oct 2014, 8:27 PM
#2
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,806
Plugin Contributions:
15

Re: Blank screen but admin working.

glamourdolleyes:

Some back details:

  • Just moved from HostGator to GoDaddy on Sunday, September 28th. My Condolences, out of the frying pan, into the fire.
  • Using version v1.5.1
  • Admin section is working fine
  • Customers are experiencing blank pages. The website works and then all of the sudden it doesn't work, getting blank pages and some even get server error.
  • I have gotten many successful orders since transferring so it's not happening all the time.

I contacted GoDaddy and they say everything is working properly on their side and to contact Zen Cart. I contacted the guy who did my transfer and he says it's an issue with my hosting. I don't know what to do now. I am losing customers.

I have looked in the DEBUG files:
[06-Oct-2014 19:59:22 UTC] PHP Fatal error: Cannot redeclare zen_create_random_value() (previously declared in /home/xxxxx/public_html/includes/functions/functions_general.php:614) in /home/xxxxx/public_html/includes/functions/password_funcs.php on line 86
[06-Oct-2014 19:59:22 UTC] PHP Warning: require(includes/classes/db/mysql/query_factory.php): failed to open stream: No such file or directory in /home/xxxxx/public_html/includes/functions/sessions.php on line 54
[06-Oct-2014 19:59:22 UTC] PHP Warning: require(includes/classes/db/mysql/query_factory.php): failed to open stream: No such file or directory in /home/xxxxx/public_html/includes/functions/sessions.php on line 54
[06-Oct-2014 19:59:22 UTC] PHP Fatal error: require(): Failed opening required 'includes/classes/db/mysql/query_factory.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/xxxxx/public_html/includes/functions/sessions.php on line 54

My website is glamourdolleyes.com.

Any suggestions? I am completely at a loss.

Notice the path (above in red) that is repeated. That tells me that your includes/configure.php has a bad listing.```php
/*************** NOTE: This file is similar, but DIFFERENT from the "admin" version of configure.php. /
/
**** The 2 files should be kept separate and not used to overwrite each other. ***********/

// Define the webserver and path parameters
// HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com
// HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com
define('HTTP_SERVER', 'http://yoursite.com');
define('HTTPS_SERVER', 'https://yoursite.com');

// Use secure webserver for checkout procedure?
define('ENABLE_SSL', 'true');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
// these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
define('DIR_WS_CATALOG', '/');
define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');
define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/');

6 Oct 2014, 8:32 PM
#3
glamourdolleyes avatar

glamourdolleyes

New Zenner

Join Date:
Mar 2009
Posts:
86
Plugin Contributions:
0

Re: Blank screen but admin working.

HostGator was a NIGHTMARE so anything GoDaddy does couldn't be any worse, but I digress.

I looked in my configure file and it matches everything above:

// Define the webserver and path parameters
  // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com
  // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com
  define('HTTP_SERVER', 'http://www.glamourdolleyes.com');
  define('HTTPS_SERVER', 'https://www.glamourdolleyes.com');

  // Use secure webserver for checkout procedure?
  define('ENABLE_SSL', 'true');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
  // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
  define('DIR_WS_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');

  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
  define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');
  define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/');
6 Oct 2014, 8:38 PM
#4
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Blank screen but admin working.

glamourdolleyes:

Some back details:

  • Just moved from HostGator to GoDaddy on Sunday, September 28th.
  • Using version v1.5.1
  • Admin section is working fine
  • Customers are experiencing blank pages. The website works and then all of the sudden it doesn't work, getting blank pages and some even get server error.
  • I have gotten many successful orders since transferring so it's not happening all the time.

I contacted GoDaddy and they say everything is working properly on their side and to contact Zen Cart. I contacted the guy who did my transfer and he says it's an issue with my hosting. I don't know what to do now. I am losing customers.

I have looked in the DEBUG files:
[06-Oct-2014 19:59:22 UTC] PHP Fatal error: Cannot redeclare zen_create_random_value() (previously declared in /home/xxxxx/public_html/includes/functions/functions_general.php:614) in /home/xxxxx/public_html/includes/functions/password_funcs.php on line 86
[06-Oct-2014 19:59:22 UTC] PHP Warning: require(includes/classes/db/mysql/query_factory.php): failed to open stream: No such file or directory in /home/xxxxx/public_html/includes/functions/sessions.php on line 54
[06-Oct-2014 19:59:22 UTC] PHP Warning: require(includes/classes/db/mysql/query_factory.php): failed to open stream: No such file or directory in /home/xxxxx/public_html/includes/functions/sessions.php on line 54
[06-Oct-2014 19:59:22 UTC] PHP Fatal error: require(): Failed opening required 'includes/classes/db/mysql/query_factory.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/xxxxx/public_html/includes/functions/sessions.php on line 54

My website is glamourdolleyes.com.

Any suggestions? I am completely at a loss.

My guess is that the content of functions_general.php exists in at least a second location loaded by ZC. Specifically that the content of the file is in a "backup" of the file that has an extension of .php.

One way to identify this (and because you have admin access it is much easier) is to goto tools->developer's toolkit and in the lower left corner type in:
Function zen_create_random_value

Then in the next dropdown identify catalog, then select the search button on the right of that side.

You are likely to find two files with that information. Then via ftp, goto the directory where that file is located and see if there are other files renamed the same way. The file expected to keep is the one named functions_general.php; however, the existence of the duplicate file is a question related to the developer if there really is such a second file. (Remember this is all based on my assumption of such based on the initial error.)

Other such errors may still occur if some form of similar search and replace is not performed. The extension must not end in .php if to be omitted, and it is recommended that it not end in .old or .bak. Technically should be removed entirely.

6 Oct 2014, 8:42 PM
#5
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,806
Plugin Contributions:
15

Re: Blank screen but admin working.

I sincerely hope you feel the same in a year.

But... I digress.

Do you know if any of those having problems might have flash disabled? I just doesn't mix well with Zen Cart anyway. The iframes can help or kill.

6 Oct 2014, 8:47 PM
#6
glamourdolleyes avatar

glamourdolleyes

New Zenner

Join Date:
Mar 2009
Posts:
86
Plugin Contributions:
0

Re: Blank screen but admin working.

@mc12345678

Not the issue

Attachment 14574

6 Oct 2014, 8:48 PM
#7
glamourdolleyes avatar

glamourdolleyes

New Zenner

Join Date:
Mar 2009
Posts:
86
Plugin Contributions:
0

Re: Blank screen but admin working.

I have always had flash there, even on the old server without any issues so I doubt that.

dbltoe:

I sincerely hope you feel the same in a year.

But... I digress.

Do you know if any of those having problems might have flash disabled? I just doesn't mix well with Zen Cart anyway. The iframes can help or kill.

6 Oct 2014, 8:50 PM
#8
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,097
Plugin Contributions:
56

Re: Blank screen but admin working.

Never mind, not pertinent.

6 Oct 2014, 9:05 PM
#9
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Blank screen but admin working.

dbltoe:

I sincerely hope you feel the same in a year.

But... I digress.

Do you know if any of those having problems might have flash disabled? I just doesn't mix well with Zen Cart anyway. The iframes can help or kill.

I haven't looked to see how the iframes are used, but would support that the use of ZC in iframes is not supported and has been reported as causing sites not to display.

Fyi,

:/usr/lib/php:/usr/local/lib/php
Shows two unique path locations not a single location duplicated, one under usr/lib, the other under user/local/lib, but that part of the issue/potential has been eliminated much like my theory of the same file existing twice, though there may still be some duplicate call being made as a require instead of a require_once call to that file (possibly by the iframe usage or another factor not yet identified by the time I started writing this.)

6 Oct 2014, 9:06 PM
#10
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Blank screen but admin working.

lat9:

Never mind, not pertinent.

Your plugin? :) was thinking of suggesting, but intermittent cause?

7 Oct 2014, 12:39 PM
#11
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,097
Plugin Contributions:
56

Re: Blank screen but admin working.

mc12345678:

Your plugin? :) was thinking of suggesting, but intermittent cause?
No plugin, but what was posted for the debug-log contents doesn't map with the results of the Developer's Tool Kit. Although, the OP indicated that the admin works and the store-side doesn't which is most likely a result of a correct path within the admin's configure.php file and an incorrect one in the store's.

@glamourdolleyes, would you post the contents of /YOUR_ADMIN/includes/configure.php and /includes/configure.php ... making sure to xxxx-out any database credentials?

8 Oct 2014, 6:01 PM
#12
glamourdolleyes avatar

glamourdolleyes

New Zenner

Join Date:
Mar 2009
Posts:
86
Plugin Contributions:
0

Re: Blank screen but admin working.

The guy who transferred my site fixed the last error. He said that GoDaddy was pulling from a configure.bak file and not configure.php

But now I am getting this error:

PHP Fatal error: 2013:Lost connection to MySQL server during query :: select value
from sessions
where sesskey = 'e0060f7693c79c38b44d8088dab859d8'
and expiry > '1412791082' in /home/glamourdolleyes/public_html/includes/classes/db/mysql/query_factory.php on line 101

12 Oct 2014, 1:51 PM
#13
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Blank screen but admin working.

glamourdolleyes:

The guy who transferred my site fixed the last error. He said that GoDaddy was pulling from a configure.bak file and not configure.php

Apologies for being blunt, but what the guy said is BS.

glamourdolleyes:

But now I am getting this error:
PHP Fatal error: 2013:Lost connection to MySQL server during query :: select value
from sessions
where sesskey = 'e0060f7693c79c38b44d8088dab859d8'
and expiry > '1412791082' in /home/glamourdolleyes/public_html/includes/classes/db/mysql/query_factory.php on line 101

When and where are you getting this error? Although not good, this kind of error is usually of a transient nature that generally occurs if/when the SQL server is being overloaded.

More info needed.

Cheers
RodG

12 Oct 2014, 1:58 PM
#14
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Blank screen but admin working.

glamourdolleyes:

The guy who transferred my site fixed the last error. He said that GoDaddy was pulling from a configure.bak file and not configure.php

RodG:

Apologies for being blunt, but what the guy said is BS.

Personally, I was thinking of the two sides to every story aspect and well because I had previously targetted the possibility of renamed files that still end in .php, thought that perhaps there was a misunderstanding of what was said. For all we know there was a local/configure.php file and in the discussion it was called a backup nd that translated to configure.bak. Good ole' phone tree game give a message to the first of many people and see what comes out t the end.

12 Oct 2014, 3:29 PM
#15
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Blank screen but admin working.

mc12345678:

Good ole' phone tree game give a message to the first of many people and see what comes out t the end.

You're too nice. :)

What happened to the old computing adage "Garbage in, Garbage out".

I do understand what you are saying, but I get so frustrated that no one seems to want to be definitive these days (especially with computing). It's like a schoolkid answering a question 1 + 1 = 3 and instead of being told that the answer is wrong they get told that under some special conditions it may in fact be right. OK, so it may save a few hurt feelings, but it's really not doing anyone any long term favours.

Why not call a spade a spade?

Cheers
RodG

12 Oct 2014, 4:14 PM
#16
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Blank screen but admin working.

RodG:

You're too nice. :)

What happened to the old computing adage "Garbage in, Garbage out".

I do understand what you are saying, but I get so frustrated that no one seems to want to be definitive these days (especially with computing). It's like a schoolkid answering a question 1 + 1 = 3 and instead of being told that the answer is wrong they get told that under some special conditions it may in fact be right. OK, so it may save a few hurt feelings, but it's really not doing anyone any long term favours.

Why not call a spade a spade?

Cheers
RodG

May have been too nice, but problem is that don't know who was really wrong, the OP for stating that the third person told them that, or that the third person actually said it. Big thing out of it is that the answer provided here was believed to be true which is in no way a function of a standard ZC install to load configure.bak. So that spade is definitely a spade. How it came to be a spade, well that's up to the parties involved as far as I am concerned.

It does further indicate the lack of understanding of the system, the setup, and what has been done to get the site where it is today. But that is basically in the past and though in some ways relevant to solve the issues is pretty much important to know for that purpose at this time. None of the described error messages are "typical" situations (duplicately loaded functions, database intermittently disconnecting, extra configure files of any type, etc...)

So, yeah, the statement was wrong regarding a ZC obtained copy of ZC trying to load configure.bak and causing the initially reported error.

13 Oct 2014, 8:09 AM
#17
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Blank screen but admin working.

mc12345678:

May have been too nice, but problem is that don't know who was really wrong, the OP for stating that the third person told them that, or that the third person actually said it.

I don't see how this makes a difference, BS is BS regardless of its source.

If it originated from 'the guy that did the transfer' then the OP has a right to know that they've been told porkies.

If it originated from the OP as a result of misunderstanding what was said it isn't fair to leave the OP with the impression that the statement made is actually possible. It is better that they know nothing than believe a falsehood.

Cheers
RodG

13 Oct 2014, 3:06 PM
#18
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Blank screen but admin working.

RodG:

I don't see how this makes a difference, BS is BS regardless of its source.

If it originated from 'the guy that did the transfer' then the OP has a right to know that they've been told porkies.

If it originated from the OP as a result of misunderstanding what was said it isn't fair to leave the OP with the impression that the statement made is actually possible. It is better that they know nothing than believe a falsehood.

Cheers
RodGnods in agreement:yes:

As my husband says "same thing is the same thing"..