Zen Cart Logo
Forums / General Questions / My Server Migrated - No more store

My Server Migrated - No more store

Views: 2,315

Results 1 to 13 of 13
23 Oct 2014, 7:28 PM
#1
davidwm avatar

davidwm

New Zenner

Join Date:
Apr 2012
Posts:
17
Plugin Contributions:
0

My Server Migrated - No more store

My hosting company recently migrated their server, and now my zen cart is no longer showing. All they told me was:

“Your new home directory is: /home/theo
Database (MySQL/PostgreSQL) Hostname: localhost
There may be changes to the database name/username of your databases, please double check all of your software that uses any database to confirm that they are working properly. You may need to update the configuration of your software when necessary for the new database name/username.”

I had/have my zen cart in a folder I will call store.
After reading much in the forums, I have made the following edits to my:
public_html/includes/CONFIGURE.PHP:

define('DIR_WS_CATALOG', '/store/');
define('DIR_WS_HTTPS_CATALOG', '/store/');

define('DIR_FS_CATALOG', 'home/theo/public_html/store/');
define('DIR_FS_SQL_CACHE', 'home/theo/public_html/store/cache');

And the following edits to my:
Public_html/store/includes/CONFIGURE.PHP:

define('DIR_WS_HTTPS_CATALOG', '/store/');

define('DIR_FS_CATALOG', 'home/theo/ public_html/store/');
define('DIR_FS_SQL_CACHE', 'home/theo/store/cache');

Still no website. Am I missing something… a slash in the wrong place, or a misguided directory path? Are there other files I will need to edit?

Note I do NOT seem to have an ADMIN folder appearing in this newly migrated server and my DIR_FS_ADMIN is not defined. If I indeed need this file, then I must have had one before when it was working before migration? What could have happened to it?
Any help would be appreciated!

23 Oct 2014, 7:43 PM
#2
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: My Server Migrated - No more store

So if you're store truly was in a directory called store, the the first file would have been

Public_html/store/includes/CONFIGURE.PHP:

And the second would have been
Public_html/store/MYSECRETADMIN/includes/CONFIGURE.PHP:

But if your new store is not in a directory, then remove /store from all locations.

The notification also addressed changes to the database. Values for that are also entered in the same two files, should be the same in both and should match the settings found in your cPanel for your database.

23 Oct 2014, 8:29 PM
#3
davidwm avatar

davidwm

New Zenner

Join Date:
Apr 2012
Posts:
17
Plugin Contributions:
0

Re: My Server Migrated - No more store

I do have a store directory and I'm calling it store here for the sake of privacy.
My only 2 configure.php files are located in
public_html/includes/
and
public_html/store/includes/

I do not appear to have an Admin folder of any kind under public_html/store... nothing that was renamed either that contains another includes folder and configure file.
My ecommerce site had been up and functional for the past 2 years until this migration, so I would assume that I must have had an admin folder at one point? Could it have been wiped out during their migration?

23 Oct 2014, 8:31 PM
#4
davidwm avatar

davidwm

New Zenner

Join Date:
Apr 2012
Posts:
17
Plugin Contributions:
0

Re: My Server Migrated - No more store

Site is https://www.thedealsdiscount.com. I am getting the start-up screen.

23 Oct 2014, 9:02 PM
#5
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,097
Plugin Contributions:
56

Re: My Server Migrated - No more store

You need to check your /includes/configure.php and/or /YOUR_ADMIN/includes/configure.php as the install screen being displayed indicates:

Your /includes/configure.php and/or /admin/includes/configure.php file contains invalid path information and/or invalid database-connection information.
23 Oct 2014, 9:42 PM
#6
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: My Server Migrated - No more store

If ZC is infact in public_html, and "store" is your admin directory, then the values such as:

define('DIR_WS_CATALOG', '/store/');
define('DIR_WS_HTTPS_CATALOG', '/store/');

define('DIR_FS_CATALOG', 'home/theo/public_html/store/');
define('DIR_FS_SQL_CACHE', 'home/theo/public_html/store/cache');

Should be changed to:

define('DIR_WS_CATALOG', '/');
define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_FS_CATALOG', 'home/theo/public_html/');
define('DIR_FS_SQL_CACHE', 'home/theo/public_html/cache');

Notice like I said earlier, remove /store from the paths... The admin path is autogenerated based on whereever the admin files are, so there is no change needed for that one (really two) variables that contain the word ADMIN.

There is still question about whether your database information is correct based on the original message, but if your setup is as described, the above modifications to both configure.php files will resolve at least half of the problem.

23 Oct 2014, 10:55 PM
#7
davidwm avatar

davidwm

New Zenner

Join Date:
Apr 2012
Posts:
17
Plugin Contributions:
0

Re: My Server Migrated - No more store

IT WORKED!! (Almost)
I made the changes, and then discovered that I needed to add a slash at the beginning of the path as follows:
define('DIR_FS_CATALOG', '**/home/theo/public_html/');
define('DIR_FS_SQL_CACHE', '
/**home/theo/public_html/cache');

Thank you so much, I'm back in business!
Dave

23 Oct 2014, 11:01 PM
#8
davidwm avatar

davidwm

New Zenner

Join Date:
Apr 2012
Posts:
17
Plugin Contributions:
0

Re: My Server Migrated - No more store

Well... my site is back up but I am not able to get into my Zen Admin.
The message I am getting is:
Secure Connection Failed

"An error occurred during a connection to https://www.thedealsdiscount.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified."

Do I need to go in and redefine any direction to my admin files?

23 Oct 2014, 11:07 PM
#9
davidwm avatar

davidwm

New Zenner

Join Date:
Apr 2012
Posts:
17
Plugin Contributions:
0

Re: My Server Migrated - No more store

Tried to "check-out" on an item as well and get the same error message...

24 Oct 2014, 1:21 AM
#10
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: My Server Migrated - No more store

DavidWM:

Well... my site is back up but I am not able to get into my Zen Admin.
The message I am getting is:
Secure Connection Failed

"An error occurred during a connection to www.thedealsdiscount.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified."

Do I need to go in and redefine any direction to my admin files?

DavidWM:

Tried to "check-out" on an item as well and get the same error message...
Those messages mean your hosting company has not correctly configured your SSL certificate.
Log a ticket with them to fix it.
In the meantime, set ENABLE_SSL and ENABLE_SSL_ADMIN and ENABLE_SSL_CATALOG to 'false' in your configure.php files.
(That will of course mean all your customer logins and checkouts, and your admin logins, will not be encrypted, until you get it fixed.)
Then once your hosting company has correctly installed your SSL certificate, you can put those settings back to 'true'.

24 Oct 2014, 5:02 AM
#11
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: My Server Migrated - No more store

Be advised (and documentation about this is clear) that when you re-enable SSL that you will have to change your password. (The system notifies you of that on the first login after enabling it.) Just offering so there are no surprises, it is the way the software rightfully works to ensure the security of the store.

24 Oct 2014, 12:44 PM
#12
davidwm avatar

davidwm

New Zenner

Join Date:
Apr 2012
Posts:
17
Plugin Contributions:
0

Re: My Server Migrated - No more store

It works! My host company fixed it.

One last question: In one of those 2 Configure.php files, both of those lines:
ENABLE_SSL and ENABLE_SSL_ADMIN and ENABLE_SSL_CATALOG are, and always have been, set to "false". Yet everything works. I'm not sure if changing them to "true" would do anything, but SHOULD they both be set to "true" ?????

Thanks again!

24 Oct 2014, 1:41 PM
#13
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: My Server Migrated - No more store

DavidWM:

It works! My host company fixed it.

One last question: In one of those 2 Configure.php files, both of those lines:
ENABLE_SSL and ENABLE_SSL_ADMIN and ENABLE_SSL_CATALOG are, and always have been, set to "false". Yet everything works. I'm not sure if changing them to "true" would do anything, but SHOULD they both be set to "true" ?????

Thanks again!

If you have a certificate, wish to use it, and to have it applied where it offers the intended improved security, then yes it should be set to yes for all three.