Zen Cart Logo
Forums / Addon Shipping Modules / Blank Admin / Module page after new install page

Blank Admin / Module page after new install page

Views: 1,808

Results 1 to 7 of 7
5 Nov 2014, 1:57 PM
#1
sstreich avatar

sstreich

New Zenner

Join Date:
Nov 2014
Location:
PA
Posts:
36
Plugin Contributions:
0

Blank Admin / Module page after new install page

I am in the process of building a ZC site working with V153.
I downloaded the latest shipping Mod and installed per instruction. In the admin Mods > Shipping when I clicked on Shipping there was a long pause and then a blank screen, none of the stock modules would show either.
I manually uninstalled that Mod and used an earlier version. I manually removed all references in the DB configuration table and the files uploaded for the install.
After another new fresh mod install same issues. However I can completely configure the setting in the DB configuration table and the mod functions as expected on the front end. I also discovered that by disabling the mod in the configuration table the mods do show in the admin area and I can work with the settings fine up until I enable the mod.
Checking the server logs shows no errors however the ZC logs show a PHP error:
[04-Nov-2014 20:40:32 America/New_York] PHP Warning: file_get_contents(http://www.zen-cart.com/downloads.php?do=versioncheck&id=1292%29: failed to open stream: Operation timed out in /usr/local/www/data-dist/demo/includes/functions/plugin_support.php on line 38
[04-Nov-2014 20:40:32 America/New_York] PHP Warning: in_array() expects parameter 2 to be array, null given in /usr/local/www/data-dist/demo/includes/functions/plugin_support.php on line 42

It appears the version check is somehow not functioning correctly for this mod, version check does work ok from the admin ZC verion check button.
Not sure if this is a mod problem or I missed something in the settings. I haven't been able to locate it as everything I looked at seems to be properly written.
Suggestions are much appreciated.
Thanks Steve

5 Nov 2014, 2:20 PM
#2
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,100
Plugin Contributions:
56

Re: Blank Admin / Module page after new install page

I'm not able to reproduce this issue with the USPS shipping method on a clean Zen Cart v1.5.3 install. I first copied the 9/7 K5 version of USPS, configured and then removed, copied the K6 version of the shipping method and reinstalled. Perhaps your internet burped?

5 Nov 2014, 3:39 PM
#3
sstreich avatar

sstreich

New Zenner

Join Date:
Nov 2014
Location:
PA
Posts:
36
Plugin Contributions:
0

Re: Blank Admin / Module page after new install page

No it definitely wasn't an internet connection problem, I ruled that out first, as that's what it looked like to me also.
I think it may be something I missed during setup, or didn't get configured correctly.
For the plugin_support.php lines 38 & 42 what are they actually suppose to be calling up. I want to check those and make sure they're set correctly in the DB.
Also MODULE_SHIPPING_USPS_VERSION shows 2014-09-07 this dosen't have the K# included is that a correct setting ?
I also ran the curltester.php and first 2 lines show:
Connecting to Zen Cart Support Server (http) ...
Error 28: getpeername() failed with errno 57: Socket is not connected

Connecting to Zen Cart Support Server (https) ...
Error 28: getpeername() failed with errno 57: Socket is not connected

Everything else "GOOD"

5 Nov 2014, 5:38 PM
#4
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,100
Plugin Contributions:
56

Re: Blank Admin / Module page after new install page

MODULE_SHIPPING_USPS_VERSION for the most recent version should show 2014-10-30.

The content that is being called up on line 38 is http://www.zen-cart.com/downloads.php?do=versioncheck&id=1292, which loads just fine. The warning on line 42 is due to the previous failure.

Would you go to your admin's Tools->Server/Version Information and search for the setting of allow_url_fopen? I'm guessing that it's Off, explaining the behavior you're seeing on the file_get_contents call.

5 Nov 2014, 5:50 PM
#5
sstreich avatar

sstreich

New Zenner

Join Date:
Nov 2014
Location:
PA
Posts:
36
Plugin Contributions:
0

Re: Blank Admin / Module page after new install page

No it's on. Both local and master values. However allow_url_include is Off in local and master.
Out put from curltester.php
Connecting to Zen Cart Support Server (http) ...
Error 28: getpeername() failed with errno 57: Socket is not connected

Connection Details:
Array
(
[url] => "http://www.zen-cart.com/testcurl.php"
[content_type] =>
[http_code] => 0
[header_size] => 0
[request_size] => 212
[filetime] => -1
[ssl_verify_result] => 0
[redirect_count] => 0
[total_time] => 15.001366
[namelookup_time] => 2.8E-5
[connect_time] => 2.501305
[pretransfer_time] => 2.501393
[size_upload] => 37
[size_download] => 0
[speed_download] => 0
[speed_upload] => 2
[download_content_length] => -1
[upload_content_length] => 37
[starttransfer_time] => 0
[redirect_time] => 0
[certinfo] => Array
(
)

[redirect_url] => 

)

I thought it may be a curl issue, but overall it seems to be working fine other the with just this one mod.
Connecting to USPS (port 80)...
GOOD: CURL Connection successful.

Connection Details:
Array
(
[url] => "http://production.shippingapis.com/shippingapi.dll"
[content_type] => text/xml
[http_code] => 200
[header_size] => 358
[request_size] => 226
[filetime] => -1
[ssl_verify_result] => 0
[redirect_count] => 0
[total_time] => 0.117949
[namelookup_time] => 2.3E-5
[connect_time] => 0.055792
[pretransfer_time] => 0.055853
[size_upload] => 37
[size_download] => 212
[speed_download] => 1797
[speed_upload] => 313
[download_content_length] => 212
[upload_content_length] => 37
[starttransfer_time] => 0.117931
[redirect_time] => 0
[certinfo] => Array
(
)

[redirect_url] => 

)

6 Nov 2014, 12:20 AM
#6
sstreich avatar

sstreich

New Zenner

Join Date:
Nov 2014
Location:
PA
Posts:
36
Plugin Contributions:
0

Re: Blank Admin / Module page after new install page

I guess we can mark this as solved :smile:
The issue was at sometime in the past I had added 50.22.0.0/15 to my firewall, 50.22.228.179 is part of that range. Now if that won't drive a guy nuts for awhile.
At least I know my firewall works :laugh:

6 Nov 2014, 12:49 PM
#7
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,100
Plugin Contributions:
56

Re: Blank Admin / Module page after new install page

That must have been a bug-a-boo to hunt down ... but I'm glad you found it!