Zen Cart Logo
Forums / General Questions / suddenly back to first page after install, same with admin page, where to start?

suddenly back to first page after install, same with admin page, where to start?

Views: 901

Results 1 to 5 of 5
6 Nov 2014, 11:10 PM
#1
wenez avatar

wenez

New Zenner

Join Date:
Nov 2014
Location:
australia, nsw
Posts:
15
Plugin Contributions:
0

suddenly back to first page after install, same with admin page, where to start?

hi,
i am wondering if anyone ever had something like this. i was working on my own template for a few days now, slowly got the idea, made nice progress. the last thing i did was just changing the css to add another header logo - went back to the shop, k r i e g s f o t o s d o t o r g and could not believe it, the first page that comes up after you install zen cart came up. i changed the few things i changed in the css file back to what it was before, but it stayed that way. also when i looked on the admin page, i got the same page.
I installed zen cart on dreamhost with one click install and i know they just recently update to the newest version of php, but after they did that everything still worked ok. i found one error log in the dreamhost logs:

[Wed Nov 05 06:44:08 2014] [error] [client ip] File does not exist: /home/me/my_domain/vtigercrm
[Wed Nov 05 06:44:08 2014] [error] [client ip] File does not exist: /home/me/my_domain/missing.html

have i been hacked? any help would be great. i really do not know where to start or what to do at all.

7 Nov 2014, 1:08 PM
#2
stevesh avatar

stevesh

Black Belt

Join Date:
Feb 2005
Location:
Lansing, Michigan USA
Posts:
19,793
Plugin Contributions:
2

Re: suddenly back to first page after install, same with admin page, where to start?

Seeing that page almost always means the path information in your configure.php file(s) is wrong. I can't offer any suggestions as to how it got that way, but check that file (includes/configure.php) first.

The error message suggests that you have other software installed in the root of your site. Use your FTP program to take a look.

8 Nov 2014, 11:29 AM
#3
wenez avatar

wenez

New Zenner

Join Date:
Nov 2014
Location:
australia, nsw
Posts:
15
Plugin Contributions:
0

Re: suddenly back to first page after install, same with admin page, where to start?

thank you for your reply. i checked the configure.php files and they look ok. because i did not touch them i think that is not the cause for my problem. in my site root i cannot find any other software, or did you mean in the root of my webserver on dreamhost? i do have a few other sites installed there. could that cause anything for this site? i have written to dreamhost to find out if they did anything after updating to the new php version. thank you for trying to help me.

8 Nov 2014, 11:04 PM
#4
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: suddenly back to first page after install, same with admin page, where to start?

Could have something in the .htaccess file in the directory above where your store is at that could be causing a problem. Especially if you host multiple sites from the same area.

ZC Installation/Maintenance Support <- Site
Contribution for contributions welcome...

8 Nov 2014, 11:45 PM
#5
wenez avatar

wenez

New Zenner

Join Date:
Nov 2014
Location:
australia, nsw
Posts:
15
Plugin Contributions:
0

Re: suddenly back to first page after install, same with admin page, where to start?

thank you all for looking at my problem. i solved it. i did something wrong with the installation of the language pack. i just did not notice, because the last things i did did not have anything to do with that. so this can be closed now. thanks again