Your images are triggering a "500 Internal Server Error", presumably because someone has done something on your site to set exclusion rules for files in your /images folder.
Example: http://thehandsomewoodman.com/images/1-13-2011%20woodyDSC_0447.jpg ... visiting that URL displays the error.
Probable cause: I'm guessing someone has altered the /images/.htaccess file or has added a /.htaccess file which blocks images from displaying.
Zen Cart comes with a /images/.htaccess file (and similar (but different) .htaccess files exist in many other Zen Cart subdirectories. But Zen Cart does NOT come with one in the "root" folder, ie: your public_html or www folder where the top of all your Zen Cart files are located. If there's a /.htaccess file there then that was added by you or someone with access to your server.
.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole
Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.