irishshopper:
We just could not crack it so deleted everything and did a fresh install of V 1.5.4.
We do however have quite a few ZenCarts V1.3.9 we need to upgrade to V1.5.4 and not looking forward to this.
Have discovered an added problem in that V1.5.4 needs PHP V.5.4 but versions 1.3.9 will NOT work with this so upgrading the server to PHP5.4 will knock out all older versions of ZenCart.
The work around is to alter the .htaccess file and add in a php.ini file. All an added complication.
We host with Bluehost but they won't discuss any ZenCart problems with you unless you installed ZenCart using their MOJO software and will not support any installations done manually with FTP upload (we use CoreFTP).
As we take payments by PayPal Express and Nochex we never receive any of our customers payment details ourselves so don't need a Certificate but Bluehost do everything they can to force us to buy one but having over 30 ZenCarts this would add to our costs considerably each year.
They tried putting one of our ZenCarts onto a VPS where we were entitled to a free certificate but we found while we could access the storefront the link to the admin area no longer worked so had to revert back to a shared system.
There are ways to allow ZC 1.5.4 to function and operate using PHP versions as low as 5.2.17, but upon the earliest opportunity, the version should be upgraded. Ideally, perhaps it all could be done using 5.3.x. Suggest beginning the upgrade relatively soon for all of those sites because word on the street is that the server push to remove versions such as 5.2.17 is coming...
ZC Installation/Maintenance Support <- Site
Contribution for contributions welcome...