Zen Cart Logo
Forums / Upgrading to 1.5.x / v1.5.4 install - blank admin page

v1.5.4 install - blank admin page

Locked

Views: 1,155

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
18 Jan 2015, 11:44 PM
#1
jclavin avatar

jclavin

New Zenner

Join Date:
Jan 2010
Posts:
2
Plugin Contributions:
0

v1.5.4 install - blank admin page

I am having an issue with a blank admin page when installing 1.5.4
1.3.9h was running fine - upgrade to 1.5.4 gives blank admin page
I did 2 completely clean test installs of 1.3.9h and 1.5.4 into separate directories (cart3 and cart5 on the same website. Each was installed using their own unique databases. 1.3.9h runs fine, 1.5.4 - admin blank page.
On another of my websites (same server) I did the same identical installs cart3 and cart5 with their own databases and both installs work fine.

From the log file in the problem site:
[18-Jan-2015 08:01:15] PHP Parse error: syntax error, unexpected T_STATIC in D:\hshome\c281575\sheptapes.com\cart5\admin\includes\classes\class.admin.zcObserverLogEventListener.php on line 118

Website installations:
v1.3.9h: http://sheptapes.com/cart3/
v1.5.4: http://sheptapes.com/cart5/

I will supply admin info and access privately if necessary. These are just for test.

Windows server versions according to provider:
PHPmyadmin on your account runs version: 4.0.10.7
MYSQL: Version 5.0.67
PHO versions:
PHP 4.4.9
PHP 5.2.17
PHP 5.3.20
PHP 5.4.10

19 Jan 2015, 12:40 AM
#2
lhungil avatar

lhungil

Totally Zenned

Join Date:
Feb 2012
Location:
mostly harmless
Posts:
1,818
Plugin Contributions:
4

Re: v1.5.4 install - blank admin page

Please create a file on the server experiencing issues to display the output from phpinfo(). Either post a link or post the output in this thread (use ```
[code][/code]

19 Jan 2015, 1:20 AM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: v1.5.4 install - blank admin page

JClavin:

[18-Jan-2015 08:01:15] PHP Parse error: syntax error, unexpected T_STATIC in D:\hshome\c281575\sheptapes.com\cart5\admin\includes\classes\class.admin.zcObserverLogEventListener.php on line 118
Simple: Your site is using the very old PHP 5.2 version, and is tripping over an incompatibility bug.

Solution:

  1. BEST solution: upgrade to a modern PHP version ... 5.5 recommended.
  2. Or temporarily apply this fix until you can properly get your PHP upgraded: http://www.zen-cart.com/showthread.php?215694-Known-Bugs-%28and-fixes%29-with-v1-5-4&p=1268233#post1268233
19 Jan 2015, 2:04 PM
#4
jclavin avatar

jclavin

New Zenner

Join Date:
Jan 2010
Posts:
2
Plugin Contributions:
0

Re: v1.5.4 install - blank admin page

DrByte:

Simple: Your site is using the very old PHP 5.2 version, and is tripping over an incompatibility bug.

Solution:

  1. BEST solution: upgrade to a modern PHP version ... 5.5 recommended.
  2. Or temporarily apply this fix until you can properly get your PHP upgraded: http://www.zen-cart.com/showthread.php?215694-Known-Bugs-%28and-fixes%29-with-v1-5-4&p=1268233#post1268233

Upgraded php to 5.4.10 and all is well - thanks very much for the help.