Zen Cart Logo
Forums / Upgrading to 1.5.x / After upgrade only header shows, no errors in logs

After upgrade only header shows, no errors in logs

Locked

Views: 1,334

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
24 Jan 2015, 2:13 AM
#1
aestheticdesign avatar

aestheticdesign

New Zenner

Join Date:
Aug 2011
Posts:
29
Plugin Contributions:
0

After upgrade only header shows, no errors in logs

Upgrade from 1.5.0 to 1.5.4
PHP v. 5.4 on a linux box

I installed a fresh copy of 1.5.4 in a new directory.
Then imported database files from current live 1.5.0 site.
Ran zc_install to update database.

So far so good.

Then I started going through the directories and files copying the theme files, plugin files, and other files that had been modified. In the case of core files that were modified, I was careful to merge my changes into the 1.5.4 files rather than replacing them.

When I loaded the site in the browser, only the header displayed. I looked at the files in the log directory and found two files I missed for the editable sidebox. So I copied those two files and reloaded. The home page looked good. But I noticed the EZ pages still had the same problem of just the header displaying.

I looked at the logs directory and no new errors were listed. But then even weirder, when I wen back to the other pages that were displaying ok, they're all now displaying just the header as before. I don't get it because I didn't even change anything between when the home page worked and when it stopped working again.

Without seeing any error messages in the browser or having any log files to go off of, where do I go from here?

24 Jan 2015, 7:03 AM
#2
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: After upgrade only header shows, no errors in logs

Could you post the content of your includes/configure.php file without specific database information (ie. password obscured for example).

How are you with using phpMyAdmin? Does your admin side work? Do any of the following apply to your situation?

http://www.zen-cart.com/showthread.php?215694-Known-Bugs-%28and-fixes%29-with-v1-5-4

ZC Installation/Maintenance Support <- Site
Contribution for contributions welcome...

24 Jan 2015, 8:50 AM
#3
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: After upgrade only header shows, no errors in logs

aestheticdesign:

Upgrade from 1.5.0 to 1.5.4 PHP v. 5.4 on a linux box I installed a fresh copy of 1.5.4 in a new directory. Then imported database files from current live 1.5.0 site. Ran zc_install to update database. So far so good. Then I started going through the directories and files copying the theme files, plugin files, and other files that had been modified. In the case of core files that were modified, I was careful to merge my changes into the 1.5.4 files rather than replacing them. When I loaded the site in the browser, only the header displayed. I looked at the files in the log directory and found two files I missed for the editable sidebox. So I copied those two files and reloaded. The home page looked good. But I noticed the EZ pages still had the same problem of just the header displaying. I looked at the logs directory and no new errors were listed. But then even weirder, when I wen back to the other pages that were displaying ok, they're all now displaying just the header as before. I don't get it because I didn't even change anything between when the home page worked and when it stopped working again. Without seeing any error messages in the browser or having any log files to go off of, where do I go from here?

What happens if you change your template in admin to 'Classic'?

NOTE: We are sorry that Frank is no longer with us.
We are grateful for all his contributions to the Zen Cart community.

24 Jan 2015, 9:55 PM
#4
aestheticdesign avatar

aestheticdesign

New Zenner

Join Date:
Aug 2011
Posts:
29
Plugin Contributions:
0

Re: After upgrade only header shows, no errors in logs

Got it solved. I was copying files from the production directory to the test. In one case I accidentally did a move instead of a copy. Then I broke the production site, which I didn't notice I was looking at. Found the problem this morning and fixed it and everything is running fine so far on 1.5.4 on the test account.

I guess I shouldn't have been working on this while suffering from the flu.

Thank you both for responding though.