Zen Cart Logo
Forums / All Other Contributions/Addons / Numinix Product Fields

Numinix Product Fields

Views: 12,419

Results 61 to 69 of 69
20 Oct 2016, 6:08 PM
#61
athena avatar

athena

Totally Zenned

Join Date:
Jan 2006
Location:
NM
Posts:
740
Plugin Contributions:
0

Numinix Product Fields

You must be exhausted, notageek... I have been hacking zencart versions over the years to work for us since 2004 and now upgrading to 1.5.4 because some of the mods we use can only go that high for now. This mod is a nightmare to install. I've done it before, always having to tweek it and I'm on day 3 now with no success. My IP says the sql should work by itself it that is how it was designed, but no. Uninstalled and reinstalled and matched and corresponded all files at least three times, and I did rename the YOUR_ADMIN and ran the sql through zen admin tool, but still nothing shows in the list except an empty page under the numinix product fields page Admin > config. So no reply from numinix. I'd pay for help at this point but no reply. Maybe the server time is lagging but this is day three now and I don't see a thing wrong with any of the installations. NOTE: when I ran the uninstall sql to start over it removed files for ImageHandler. I guess this could be server lag time between my mod installs and the execution but I can see the files on the server clearly there in all the right places. The core file error I get when I look at the zen log is: ```
[20-Oct-2016 11:32:16 America/Denver] PHP Warning: /includes/npf_includes/npf_templates/description2): failed to open stream: No such file or directory in /includes/modules/product/collect_info.php on line 514
[20-Oct-2016 11:32:16 America/Denver] PHP Warning: include(): Failed opening 'includes/npf_includes/npf_templates/description2' for inclusion (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in includes/modules/product/collect_info.php on line 514


I guess a good question would be if there are any other sql statements in the code i can run to take the place of that which is not self installing?
22 Oct 2016, 2:23 PM
#62
enzo_ita avatar

enzo_ita

Zen Follower

Join Date:
Jul 2009
Posts:
402
Plugin Contributions:
0

Re: Numinix Product Fields

Hi,
I installed this plug in and everithing seem to work as expected but for the upc field. When I try to add it I get the following error The selected field was unable to be installed due to insufficient server permissions, please contact your host.
Can someone point me in the right direction about this problem?
Thanks
ciao from Italy
enzo

25 Nov 2016, 6:31 PM
#63
csgodeimos avatar

csgodeimos

Zen Follower

Join Date:
May 2016
Posts:
191
Plugin Contributions:
0

Re: Numinix Product Fields

enzo-ita:

Hi,
I installed this plug in and everithing seem to work as expected but for the upc field. When I try to add it I get the following error The selected field was unable to be installed due to insufficient server permissions, please contact your host.
Can someone point me in the right direction about this problem?
Thanks
ciao from Italy
enzo

Hey Enzo,

I had this exact same issue, I was instructed to do the following by a Numinix Administrator on their site

Look inside YOUR_ADMIN/includes/npf_includes/prebuilt_fields/ and copy the files to the respective path under YOUR_ADMIN. There will be an install.sql file that you can use to patch you database IN ADMIN > TOOLS > INSTALL SQL PATCHES.

This has partially worked, the UPC field shows for me but it's not updating on the product page. If I find out how to get passed that problem, I'll let you know so you can do the same.

http://www.youtube.com/c/csgodeimos - New Videos Wednesday & Saturday
Gaming Content / Deimos

5 Dec 2016, 2:15 PM
#64
csgodeimos avatar

csgodeimos

Zen Follower

Join Date:
May 2016
Posts:
191
Plugin Contributions:
0

Re: Numinix Product Fields

enzo-ita:

Hi,
I installed this plug in and everithing seem to work as expected but for the upc field. When I try to add it I get the following error The selected field was unable to be installed due to insufficient server permissions, please contact your host.
Can someone point me in the right direction about this problem?
Thanks
ciao from Italy
enzo

If you still need help with this I managed to get it to work with help from other people. I can tell you how I fixed it if needed.

http://www.youtube.com/c/csgodeimos - New Videos Wednesday & Saturday
Gaming Content / Deimos

14 Dec 2016, 8:51 PM
#65
csgodeimos avatar

csgodeimos

Zen Follower

Join Date:
May 2016
Posts:
191
Plugin Contributions:
0

Re: Numinix Product Fields

Okay, now I'm trying to find a way to get products_condition to show up as New by default. If anyone knows how to do that, I'd appreciate the help as I'm lost.

http://www.youtube.com/c/csgodeimos - New Videos Wednesday & Saturday
Gaming Content / Deimos

23 Dec 2016, 10:36 PM
#66
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,567
Plugin Contributions:
58

Re: Numinix Product Fields

CSGODeimos:

Okay, now I'm trying to find a way to get products_condition to show up as New by default. If anyone knows how to do that, I'd appreciate the help as I'm lost.

You could write a simple SQL query to populate the field for all products:

UPDATE products SET products_condition = 'New';

14 Mar 2017, 8:34 PM
#67
ropelocker avatar

ropelocker

New Zenner

Join Date:
Nov 2007
Posts:
9
Plugin Contributions:
0

Re: Numinix Product Fields

CSGODeimos:

If you still need help with this I managed to get it to work with help from other people. I can tell you how I fixed it if needed.

Hi CSGODeimos

I realise this was a few months ago for you but can you share your fix or identify the problem? I am having the same frustrating problem.

Thanks

18 Mar 2017, 10:09 PM
#68
numinix avatar

numinix

Totally Zenned

Join Date:
Apr 2007
Location:
Vancouver, Canada
Posts:
1,567
Plugin Contributions:
58

Re: Numinix Product Fields

Ropelocker:

Hi CSGODeimos

I realise this was a few months ago for you but can you share your fix or identify the problem? I am having the same frustrating problem.

Thanks

The files can be manually copied from the prebuilt_fields directory. The files within each sub-directory are in the same structurer as Zen Cart (just rename YOUR_ADMIN to your customer admin directory name). Then manually run install.sql.

This issue happens if PHP doesn't have ownership privledges to move files within your server. Often your host can sort it out if you share your admin login info with them.