Forums / Installing on a Linux/Unix Server / Unable to Connect to Database on New Install

Unable to Connect to Database on New Install

Views: 1,047

Results 1 to 2 of 2
15 Jul 2015, 3:29 PM
#1
mshultise avatar

mshultise

Zen Follower

Join Date:
Feb 2005
Location:
Captain Cook, Hawaii
Posts:
172
Plugin Contributions:
0

Unable to Connect to Database on New Install

I have installed a "boatload" (a technical term) of Zencarts over the years.

When I tried to install a new copy of 1.5.4 I kept getting "Unable to connect to the database" error. I triple checked the database names and password and "localhost" but it would not connect.

I logged in to phpmyadmin and was able to create an drop a table.

Then I remembered an issue I had on another site a while back with upgrading.

My PHP level was set to 5.5 which is an acceptable level for Zen-Cart 1.5.4. As soon as I dropped it to PHP 5.4 the install went through.

I seem to remember some issues with PHP versions and password encryption, etc.

Anyway, just a post to show how I got past the error.

Current version that allowed install: 5.4.39 (Zend: 2.4.0)
Version that did not: some version of 5.5. Unable to get into Zencart with whatever version of 5.5 they have.

Aloha from Hawaii! (its a dirty job, but SOMEBODY has to live here...)

15 Jul 2015, 4:19 PM
#2
mshultise avatar

mshultise

Zen Follower

Join Date:
Feb 2005
Location:
Captain Cook, Hawaii
Posts:
172
Plugin Contributions:
0

Re: Unable to Connect to Database on New Install

FYI, the install version I used that failed was zen-cart-v1.5.4-12302014

Aloha from Hawaii! (its a dirty job, but SOMEBODY has to live here...)