Zen Cart Logo
Forums / Addon Payment Modules / WorldPay Module version 3.0 - Support thread

WorldPay Module version 3.0 - Support thread

Views: 37,829

Results 1 to 20 of 117
25 Jul 2015, 4:11 PM
#1
countrycharm avatar

countrycharm

Totally Zenned

Join Date:
Jul 2007
Posts:
2,179
Plugin Contributions:
2

WorldPay Module version 3.0 - Support thread

For Zen Cart v1.5.x ONLY.**
This is the NEW support thread for the latest version WorldPay 3.0.

I will not be supporting this thread. Just trying to be a good citizen starting a new thread for the current version of WorldPay

Things that were added and removed:**

v3.0 Updated by
Countrycharm And Bottyz v3.0 - 7/25/2015

  • Removed: YOUR_ADMIN/includes/boxes/extra_boxes/worldpay_response_customers_dhtml.php. These folders and file was dropped as it wasn't necessary for zen cart v1.5+
  • Removed: includes/templates/YOUR_TEMPLATE/templates/tpl_checkout_payment_default.php. This file was dropped as it wasn't necessary.
  • Added a full_uinstall_sql_patche.sql statement for fully un-installing the WorldPay module.
  • Added Optional tweak that allows for stating of actual card type within order history, customers account and email. To do this there were two new folders and file created. includes/auto_loader/config.worldpay.php and includes/init_includes/init_worldpay.php.
  • Updated cards Accepted as some of them have now been discontinued.
  • Added new credit card images for sidebox.
  • Added two new folders and files includes/auto_loader/config.worldpay.php and includes/init_includes/init_worldpay.php for the optional tweak that allows for stating of actual card type within order history, customers account and email.
  • Fixed WorldPay page not showing under customers on zen cart v1.5+ admin.
  • Updated WorldPay payments URL: Changes affected your connection with WorldPay because they are no longer part of RBS. Modified includes/modules/payment/worldpay.php.
  • New addition added to increase session time to reduce time outs and 302s.
  • Now auto registers the admin-->customers--> worldpay admin page automatically when module is installed.
  • Now auto deletes the admin-->customers-->worldpay admin page automatically when module is Removed.
  • Updated the _doc to reflect the changes.
  • Change WorldPay version number to v3.0

If you are using Zen Cart v1.3.x:
**Please DO NOT post questions regarding the ****v1.3.x versions of this add-on in this support thread.
**
Questions regarding the v1.3.x versions of this add-on should be directed to this support thread HERE: https://www.zen-cart.com/showthread.php?112021-WorldPay-Module-version-2-0-Support-thread

When posting bugs/issues about WorldPay v3.0, it's more helpful to resolve them if you post details. Just saying "it's broken" or "doesn't work" does not provide nearly enough information to help YOU resolve YOUR issue.

Is your site Upgraded to the current version 1.5.4 Yet?
zencart-upgrades-website-installation

25 Jul 2015, 6:38 PM
#2
bottyz avatar

bottyz

New Zenner

Join Date:
Mar 2010
Location:
Nottingham UK
Posts:
90
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

Hi all,

Contrycharm and I have spent a good few hours to bring this mod back up to a useable level. We've tested it on a couple of shops and I have it running on a live one with no issues.

You will have to reselect the card types you use on your shop when reinstalling the module as some of the old one were obselete. You'll also need to ensure you select the appropriate payment zone before using.

If you do encounter any issues please post as much info as you can here about what happened (never a debug log with your password and installation info) and what steps you took to create the issue and I'll do my best to offer advice and assistance where possible.
Please bear in mind though that I'm not on here everyday owing to other work commitments (currently a new vps and website to sort) so I may not reply quickly.

However, I'm sure contrycharm will be keeping an eye out once in a while too.

27 Jul 2015, 1:43 PM
#4
explorer1979 avatar

explorer1979

Inactive

Join Date:
Jan 2007
Posts:
377
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

I am full following the Manual to install this module, but still experience callback fail problems.

Here are the log WorldPay give to me

== BoF Testing Shop Log
Transaction ID: 41xxx63xxx (Security Reason Changed to some x)
Cart ID: 8exe7bxxd2xx5a15f862cb6exxxxxxx (Security Reason Changed to some x)
Installation ID: 1xxxxx (Security Reason Changed to some x)

Error reported: Callback to http://www.shop.com/test708/index.php?zenid=8exe7bxxd2xx5a15f862cb6exxxxxxx&main_page=wp_callback: NOT OK, recevied HTTP status: 302
Server Reference: ukdc2-pz-pay01:callbackFailureEmail-1xxxxx:MerchReq-17-95
== EoF Testing Shop Log

== Callback response data ==
HTTP/1.1 302 Moved Temporarily
Date: Mon, 27 Jul 2015 09:26:03 GMT
Server: Apache/2.4.10 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 mod_fcgid/2.3.9
X-Powered-By: PHP/5.4.35
location: http://www.shop.com/
Content-Length: 0
Connection: close
Content-Type: text/html
== Callback response data ==

== BoF Live Shop Log
[2015-07-22 16:41:28.288 (TID:msg1Conn9-211795)] Callback handling failed
[2015-07-22 16:41:28.285 (TID:msg1Conn9-211795)] Callback Failed: Callback to: http://www.shop.com/store/index.php?zenid=0440xxxeafxx5a710294xx9bea14fxxx&main_page=wp_callback: failed CAUSED BY The maximum limit of 131072 bytes has been exceeded.
[2015-07-22 16:41:01.469 (TID:msg1Conn9-211795)] Callback suspended, but retrying (attempt 145)
== EoF Live Shop Log

Where my shop URL is like this
Using cPanel Redirect setting / will be from
for example
http://www.shop.com
redirect to
http://www.shop.com/store

And WP Official Back End setting are
Enter the Shopper Redirect URL:
http://www.shop.com/store/index.php?main_page=checkout_success

All other setting such as
Payment Response enabled? - ensure this is ticked.
Enable Recurring Payment Response? - ensure this is ticked.
Enable the Shopper Response? - ensure this is ticked.
Suspension of Payment Response? - ensure this is NOT ticked (it automatically selects if callback fails).
Click 'Payment Response Password - enter your password. (and then again to validate, do not tick use default as it will reset password fields) Make this secure using numbers and letters. You only have to remember it long enough to enter it in your Zen Cart Worldpay module configuration.
MD5 secret for transactions - enter a pass phrase which can be up to 16 characters long and include spaces. (and then again to validate, do not tick use default as it will reset password fields).

I am all following with the WorldPay 3.0 doc step still out of luck, any suggestion how to check/debug what is wrong on the
HTTP 302 Error and
failed CAUSED BY The maximum limit of 131072 bytes has been exceeded.

Both callback failed if take care of WorldPay log, URL, it include the zendid like this
index.php?zenid=0440xxxeafxx5a710294xx9bea14fxxx

Do it is the problems source?

Thank you.

27 Jul 2015, 3:23 PM
#5
bottyz avatar

bottyz

New Zenner

Join Date:
Mar 2010
Location:
Nottingham UK
Posts:
90
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

explorer1979:

I am full following the Manual to install this module, but still experience callback fail problems.

Here are the log WorldPay give to me

== BoF Testing Shop Log
Transaction ID: 41xxx63xxx (Security Reason Changed to some x)
Cart ID: 8exe7bxxd2xx5a15f862cb6exxxxxxx (Security Reason Changed to some x)
Installation ID: 1xxxxx (Security Reason Changed to some x)

Error reported: Callback to http://www.shop.com/test708/index.php?zenid=8exe7bxxd2xx5a15f862cb6exxxxxxx&main_page=wp_callback: NOT OK, recevied HTTP status: 302
Server Reference: ukdc2-pz-pay01:callbackFailureEmail-1xxxxx:MerchReq-17-95
== EoF Testing Shop Log

== Callback response data ==
HTTP/1.1 302 Moved Temporarily
Date: Mon, 27 Jul 2015 09:26:03 GMT
Server: Apache/2.4.10 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 mod_fcgid/2.3.9
X-Powered-By: PHP/5.4.35
location: http://www.shop.com/
Content-Length: 0
Connection: close
Content-Type: text/html
== Callback response data ==

== BoF Live Shop Log
[2015-07-22 16:41:28.288 (TID:msg1Conn9-211795)] Callback handling failed
[2015-07-22 16:41:28.285 (TID:msg1Conn9-211795)] Callback Failed: Callback to: http://www.shop.com/store/index.php?zenid=0440xxxeafxx5a710294xx9bea14fxxx&main_page=wp_callback: failed CAUSED BY The maximum limit of 131072 bytes has been exceeded.
[2015-07-22 16:41:01.469 (TID:msg1Conn9-211795)] Callback suspended, but retrying (attempt 145)
== EoF Live Shop Log

Where my shop URL is like this
Using cPanel Redirect setting / will be from
for example
http://www.shop.com
redirect to
http://www.shop.com/store

And WP Official Back End setting are
Enter the Shopper Redirect URL:
http://www.shop.com/store/index.php?main_page=checkout_success

All other setting such as
Payment Response enabled? - ensure this is ticked.
Enable Recurring Payment Response? - ensure this is ticked.
Enable the Shopper Response? - ensure this is ticked.
Suspension of Payment Response? - ensure this is NOT ticked (it automatically selects if callback fails).
Click 'Payment Response Password - enter your password. (and then again to validate, do not tick use default as it will reset password fields) Make this secure using numbers and letters. You only have to remember it long enough to enter it in your Zen Cart Worldpay module configuration.
MD5 secret for transactions - enter a pass phrase which can be up to 16 characters long and include spaces. (and then again to validate, do not tick use default as it will reset password fields).

I am all following with the WorldPay 3.0 doc step still out of luck, any suggestion how to check/debug what is wrong on the
HTTP 302 Error and
failed CAUSED BY The maximum limit of 131072 bytes has been exceeded.

Both callback failed if take care of WorldPay log, URL, it include the zendid like this
index.php?zenid=0440xxxeafxx5a710294xx9bea14fxxx

Do it is the problems source?

Thank you.

Hi explorer,

Sorry to hear you're still having issues. I think its got to be something with the settings in the merchant interface. I've attached a screenshot of my production merchant interface screen (obviously with the private stuff blanked out) and I can see a couple of differences.

Attachment 15473

  1. I don't have the 'shopper redirect url' box. I never have had that, its something me and countrycharm discussed as his client had it too. Have you tried leaving that box empty?
  2. I don't have enable recurring payments ticked. Again something that has always differed from the worldpay mod docs.

I'm assuming you've had the above results in the test mod of the worldpay module?

27 Jul 2015, 4:19 PM
#6
countrycharm avatar

countrycharm

Totally Zenned

Join Date:
Jul 2007
Posts:
2,179
Plugin Contributions:
2

Re: WorldPay Module version 3.0 - Support thread

bottyz:

Hi explorer,

Sorry to hear you're still having issues. I think its got to be something with the settings in the merchant interface. I've attached a screenshot of my production merchant interface screen (obviously with the private stuff blanked out) and I can see a couple of differences.

Attachment 15473

  1. I don't have the 'shopper redirect url' box. I never have had that, its something me and countrycharm discussed as his client had it too. Have you tried leaving that box empty?
  2. I don't have enable recurring payments ticked. Again something that has always differed from the worldpay mod docs.

I'm assuming you've had the above results in the test mod of the worldpay module?

I have spent many hour with explorer over email trying to solve this problem. No they didn't have those boxes tick at first. I showed the them the same image I showed you about the setting. That's when they ticked the shopper redirect url' and enable recurring payments.

There problem seems more complicated. They have hundreds of error in there worldpay admin and they need to get worldpay to rest there account before they ever get it to redirect back to there site.

Is your site Upgraded to the current version 1.5.4 Yet?
zencart-upgrades-website-installation

27 Jul 2015, 4:27 PM
#7
countrycharm avatar

countrycharm

Totally Zenned

Join Date:
Jul 2007
Posts:
2,179
Plugin Contributions:
2

Re: WorldPay Module version 3.0 - Support thread

explorer1979:

I am full following the Manual to install this module, but still experience callback fail problems.

Here are the log WorldPay give to me

== BoF Testing Shop Log
Transaction ID: 41xxx63xxx (Security Reason Changed to some x)
Cart ID: 8exe7bxxd2xx5a15f862cb6exxxxxxx (Security Reason Changed to some x)
Installation ID: 1xxxxx (Security Reason Changed to some x)

Error reported: Callback to http://www.shop.com/test708/index.php?zenid=8exe7bxxd2xx5a15f862cb6exxxxxxx&main_page=wp_callback: NOT OK, recevied HTTP status: 302
Server Reference: ukdc2-pz-pay01:callbackFailureEmail-1xxxxx:MerchReq-17-95
== EoF Testing Shop Log

== Callback response data ==
HTTP/1.1 302 Moved Temporarily
Date: Mon, 27 Jul 2015 09:26:03 GMT
Server: Apache/2.4.10 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 mod_fcgid/2.3.9
X-Powered-By: PHP/5.4.35
location: http://www.shop.com/
Content-Length: 0
Connection: close
Content-Type: text/html
== Callback response data ==

== BoF Live Shop Log
[2015-07-22 16:41:28.288 (TID:msg1Conn9-211795)] Callback handling failed
[2015-07-22 16:41:28.285 (TID:msg1Conn9-211795)] Callback Failed: Callback to: http://www.shop.com/store/index.php?zenid=0440xxxeafxx5a710294xx9bea14fxxx&main_page=wp_callback: failed CAUSED BY The maximum limit of 131072 bytes has been exceeded.
[2015-07-22 16:41:01.469 (TID:msg1Conn9-211795)] Callback suspended, but retrying (attempt 145)
== EoF Live Shop Log

Where my shop URL is like this
Using cPanel Redirect setting / will be from
for example
http://www.shop.com
redirect to
http://www.shop.com/store

And WP Official Back End setting are
Enter the Shopper Redirect URL:
http://www.shop.com/store/index.php?main_page=checkout_success

All other setting such as
Payment Response enabled? - ensure this is ticked.
Enable Recurring Payment Response? - ensure this is ticked.
Enable the Shopper Response? - ensure this is ticked.
Suspension of Payment Response? - ensure this is NOT ticked (it automatically selects if callback fails).
Click 'Payment Response Password - enter your password. (and then again to validate, do not tick use default as it will reset password fields) Make this secure using numbers and letters. You only have to remember it long enough to enter it in your Zen Cart Worldpay module configuration.
MD5 secret for transactions - enter a pass phrase which can be up to 16 characters long and include spaces. (and then again to validate, do not tick use default as it will reset password fields).

I am all following with the WorldPay 3.0 doc step still out of luck, any suggestion how to check/debug what is wrong on the
HTTP 302 Error and
failed CAUSED BY The maximum limit of 131072 bytes has been exceeded.

Both callback failed if take care of WorldPay log, URL, it include the zendid like this
index.php?zenid=0440xxxeafxx5a710294xx9bea14fxxx

Do it is the problems source?

Thank you.

You need to get worldpay to reset your account because of all repeated failures of Callback errors which seems to have blocked, or frozen your return from worldpay to your shop success page. Some form of loop generating too much data in the return template.

1.) Too many bytes or data form your template

or

2.) Your PHP settings are causing this to happen.

Until you do this the callback system will not work on your end. No other help can be offered.

Is your site Upgraded to the current version 1.5.4 Yet?
zencart-upgrades-website-installation

27 Jul 2015, 5:05 PM
#8
bottyz avatar

bottyz

New Zenner

Join Date:
Mar 2010
Location:
Nottingham UK
Posts:
90
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

OK, I didn't know you'd already been emailing. I did see the bytes too long part but thought suggesting the obvious first might be an idea.
If doing what countrycharm suggested doesn't fix the issue I would also recommend setting up a new zencar and adding the module to see if it still fails on a new install. If it doesn't it's certainly likely oneof your customisationson the current cart is conflicting.

29 Jul 2015, 10:03 AM
#9
explorer1979 avatar

explorer1979

Inactive

Join Date:
Jan 2007
Posts:
377
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

Hi Bottyz,

I make a new ZC 1.5.1 + WP 3.0 + Default Themes
Then re enter all my account and PW on it.

Tested it work!

So ...
What will make the "failed CAUSED BY The maximum limit of 131072 bytes has been exceeded"?

The Old Themes or Module?

Any idea to fast check this?

Thank you.

29 Jul 2015, 10:31 AM
#10
bottyz avatar

bottyz

New Zenner

Join Date:
Mar 2010
Location:
Nottingham UK
Posts:
90
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

explorer1979:

Hi Bottyz,

I make a new ZC 1.5.1 + WP 3.0 + Default Themes
Then re enter all my account and PW on it.

Tested it work!

So ...
What will make the "failed CAUSED BY The maximum limit of 131072 bytes has been exceeded"?

The Old Themes or Module?

Any idea to fast check this?

Thank you.

Hi Explorer,

That's great news. So its unlikely the worldpay module itself is causing the issue. It'll more likely be something on your live cart that is conflicting and causing extra bytes to be passed. Maybe even a corruption in your database.

Unfortunately, there is no fast way of testing. However, the way I would do it would be to to work logically through adding modules, settings, etc... one by one from your live zen cart to the new test version and check after each addition to see if the worldpay module still works.
If you then add something and it suddenly causes that error, you'll be able to pinpoint what it is that causes the issue and you can then investigate further in correcting the problem.

I hope this helps. Please do post on here if you find out what it was causing this issue, so that other users with the same problem can see in future what you found.

If you need any more advice please post on here.

Good luck

P.S. is there a reason you tried a new test cart using v1.5.1, you'd be better off upgrading to the latest v1.5.4 as it'll stop you needing to upgrade twice.

6 Aug 2015, 9:20 AM
#11
explorer1979 avatar

explorer1979

Inactive

Join Date:
Jan 2007
Posts:
377
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

bottyz:

Hi Explorer,

That's great news. So its unlikely the worldpay module itself is causing the issue. It'll more likely be something on your live cart that is conflicting and causing extra bytes to be passed. Maybe even a corruption in your database.

Unfortunately, there is no fast way of testing. However, the way I would do it would be to to work logically through adding modules, settings, etc... one by one from your live zen cart to the new test version and check after each addition to see if the worldpay module still works.
If you then add something and it suddenly causes that error, you'll be able to pinpoint what it is that causes the issue and you can then investigate further in correcting the problem.

I hope this helps. Please do post on here if you find out what it was causing this issue, so that other users with the same problem can see in future what you found.

If you need any more advice please post on here.

Good luck

P.S. is there a reason you tried a new test cart using v1.5.1, you'd be better off upgrading to the latest v1.5.4 as it'll stop you needing to upgrade twice.

Hi Bottyz,

I restore the MySQL DB to test it again

Here are my test environment ZC 1.5.1 + WP 3.0 + Default Themes + Restore MySQL DB (DB copy from Live Shop), but without any images (FTP haven't upload all Live Shop Image on it)

Then re enter all my account and PW on it and buy something on front end

Tested it work!

This mean our DB haven't any problems

My next test plan is replace the Default ZC Themes with our themes see what will happened.

Why I not using ZC 1.5.4 since the Super Order and Edit Order Module, special the Super Order it not work with ZC 1.5.3 that can download from Official Zen Cart (countrycharm already give me a GitHub link to the more new version, I will make a test later on when free.)

Thank you all in there help and suggestion for me. I will post my test result once done.

25 Aug 2015, 2:13 PM
#12
robo26 avatar

robo26

New Zenner

Join Date:
Feb 2008
Posts:
20
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

I am having problems with the Worldpay module installed on a customers website.

Bellow are the setup screen from WorldPay admin and an error log from WorldPay for a transaction I ran to test it.

The customer is using Zen Cart 1.5.4 and WorldPay module 3.0

WorldPay worked fine prior to a new build of the website and a move of servers.

I have removed all redirects from the .htaccess file as it seems that the redirect url being presented is different from the one sent. I have also ensured that the site is set as http://www.domain-url.co.uk in both normal configure.php and the one in admin.

Hitting a brick wall with WorldPay as they say that it is a Zen Cart problem. I have also tested the issue with the standard template to ensure there is nothing in the new template causing the issue.

All help will be gratefully appreciated.

I should add, whilst this is a move to a new server, the site is a new build (the customer, orders and products tables were imported to the new database only - all other tables are from the new build).

Attachment 15557
Attachment 15558

4 Jan 2016, 9:29 AM
#13
explorer1979 avatar

explorer1979

Inactive

Join Date:
Jan 2007
Posts:
377
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

Hi,

Long time ago I am try to make WP 3.0 work on my ZC 1.5.1, it callback failed, but, after I change my server's PHP POST size from 2M to 2040M, it can work again with my ZC 1.5.1...

But... now I am starting on processing the ZC 1.5.4 upgrade integration, the same callback oversize error again (Yes, ZC version is different, and yes, new themes, but, if using new themes without restore the ZC 1.5.1 DB (Run the ZC install DB upgrade), mean new install, no addition modules, it can work!!!

But it confused me again is, the ZC 1.5.1 work again, why same DB (actually the PHP files many haven't add the modules, I just want to quick test with WP, so using ZC 1.5.1 DB, then run the ZC 1.5.4 upgrade PHP script, it sucessful, then test buy, it not work again)

Now, I look for the worldpay module PHP files, have some idea, but ..... but ... since I am not programmer, I am from IT Pro field more than from programming filed, so my PHP is still learning more more on it ....

My idea is ...
look on /includes/modules/payment/wordlpay.php
Line about 195 to 203

function _build_callback(){

        $ssl = (defined('ENABLE_SSL') && ENABLE_SSL == true) ? 'SSL' : 'NONSSL' ;
        $sid = ( defined('SID') && zen_not_null(SID) ) ? false : true ;
        $callback_url = str_replace( array('http://','https://'),'', zen_href_link(FILENAME_WP_CALLBACK, zen_session_name().'='.zen_session_id() , $ssl, $sid));

        return $callback_url ;
      
      }

I am wonder, how to add some PHP coding that can output the '$callback_url' and 'return $callback_url' to the ZC's buildin logs folder /logs with a new filename like worldpay_callback.txt etc?? Or "Catch" it $_POST array value to the same /logs/worldpay_callback.txt for troubleshoot why it error over size The maximum limit of 131072
bytes has been exceeded

Thank you.

4 Jan 2016, 10:26 AM
#14
explorer1979 avatar

explorer1979

Inactive

Join Date:
Jan 2007
Posts:
377
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

And one more inform, I enabled the WorldPay debug log, see some diff, but I am don't know why like this

Here are the key diff part that I am using WinMerge to compare two file ... hope someone here can post me to a direction how to check why no value ...

the work one

    [navigation] => navigationHistory Object
        (
            [path] => Array
                (
                    [0] => Array
                        (
                            [page] => index
                            [mode] => NONSSL
                            [get] =>
                            [post] => Array
                                (
                                )

                        )

                    [1] => Array
                        (
                            [page] => checkout_shipping
                            [mode] => NONSSL
                            [get] =>
                            [post] => Array
                                (
                                )

                        )

                    [2] => Array
                        (
                            [page] => checkout_payment
                            [mode] => NONSSL
                            [get] =>
                            [post] => Array
                                (
                                )

                        )

                    [3] => Array
                        (
                            [page] => checkout_confirmation
                            [mode] => NONSSL
                            [get] =>
                            [post] => Array
                                (
                                )

                        )

                    [4] => Array
                        (
                            [page] => wp_callback
                            [mode] => NONSSL
                            [get] => Array
                                (
                                    [installation] => 1xxxxx
                                    [zenid] => ef7566e8ec4a39377f7c88fa8efc2910
                                    [msgType] => authResult
                                )

                            [post] => Array
                                (
                                )

                        )

                )

            [snapshot] => Array
                (
                )

        )

the not work one

[navigation] => navigationHistory Object
        (
            [path] => Array
                (
                    [0] => Array
                        (
                            [page] => index
                            [mode] => NONSSL
                            [get] =>
                            [post] => Array
                                (
                                )

                        )

                    [1] => Array
                        (
                            [page] => wp_callback
                            [mode] => NONSSL
                            [get] => Array
                                (
                                    [installation] => 1xxxxx
                                    [zenid] => 3599c4d20d33a49110bf3665f6df79c3
                                    [msgType] => authResult
                                )

                            [post] => Array
                                (
                                )

                        )

                )

            [snapshot] => Array
                (
                )

        )
13 Jan 2016, 3:53 AM
#15
explorer1979 avatar

explorer1979

Inactive

Join Date:
Jan 2007
Posts:
377
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

Hi all,

I final find the problems source!!!!!

It is from Products Tables (Maybe)

I using a new install with themes and WorldPay 3.0, but export the bad DB tables one by one, then using those tables as unit by group, for example, customers, shipping etc restore one by one (Or groups, since ZC have relationship with multi tables) ...

OK, then after I am restore

  • Test Products -
    products
    products_attributes
    products_attributes_download
    products_description
    products_discount_quantity
    products_notifications
    products_options
    products_options_types
    products_options_values
    products_options_values_to_products_options
    products_to_categories
    product_music_extra
    product_types
    product_types_to_category
    product_type_layout

featured

specials

those of above tables ...
The stop redirect problems come again, so I know the problems from there.

OK, then I go to back end Disable them all Categories, then try just enable one or two Main Categories, IT CAN WORK!!!!

Then I enable more Categories, then try again, this time STOP WORK!!!!!

Then I review the Categories, inside it have many sub-categories, and .... totals Products (Many with Link) over 7000 ....

So .... I thinking this maybe why WorldPay Log have
wp_callback: failed CAUSED BY The maximum limit of 131072 bytes has been exceeded.

But .... if same DB with other themes on ZC 1.5.1, it can work .....
Or ZC back end have value control Categories send data max size??

So, ZC 1.5.4 changed many??? Or any idea are welcome ....

Thank you.

13 Jan 2016, 8:36 PM
#16
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: WorldPay Module version 3.0 - Support thread

explorer1979:

So, ZC 1.5.4 changed many???
No, not likely.

explorer1979:

The maximum limit of 131072 bytes has been exceeded.
That sort of message is usually a PHP max memory_limit problem. Change your PHP configuration in php.ini and set memory_limit to 128M

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

14 Jan 2016, 9:38 AM
#17
explorer1979 avatar

explorer1979

Inactive

Join Date:
Jan 2007
Posts:
377
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

Dr. Byte,

Thx for your kindly reply, but my server PHP.ini is using 512MB already before this problems coming ...
PHP File Uploads: On Max Size: 2048M POST Max Size: 2040M
PHP Version: 5.4.35 (Zend: 2.4.0) PHP Memory Limit: 512M
HTTP Server: Apache/2.4.10 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 mod_fcgid/2.3.9
PHP Safe Mode: Off

This server it is on USA Godaddy VPS Hosting
This VPS Server is 4G RAM, cPanel

It real make me trouble many time and I am used few month to try fix it. (Include hired at least 3 person to fix, no one find the problems where come from).

Until now I restore the mysql tables one by one then test on a new install ZC 1.5.4, and now lock down on all products tables and categories .. so I know it is the problems from there.

Or how about we hired and payment you for help if you can? (PM me if you can, other detail can talk by SkyPe)

And I have a new post here
https://www.zen-cart.com/showthread.php?219261-Hide-All-Categories-on-index-page-while-WorldPay-Callback

Maybe you can help to teach me how to rewrite ....

Thank you

28 Jun 2016, 3:23 PM
#18
bonheddwr avatar

bonheddwr

Zen Follower

Join Date:
Jun 2007
Location:
Cymru
Posts:
124
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

Hi. I'm trying to integrate Worldpay with two Zen Cart based websites. I already have two Worldpay Ecommerce accounts ready, but after installing this module, and trying my best to integrate my Zen Cart stores with Worldpay, I've come to the conclusion that I will not be able to do this without help. Can anyone suggest companies that provide this service for a fee? Feel free to DM me.

29 Jun 2016, 11:34 AM
#19
bonheddwr avatar

bonheddwr

Zen Follower

Join Date:
Jun 2007
Location:
Cymru
Posts:
124
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

Hi, has anyone got a link to a working version of this mod on their site so that we can see exactly how it works from a custtomer perspective?

Many Thanks.

29 Jun 2016, 12:15 PM
#20
bottyz avatar

bottyz

New Zenner

Join Date:
Mar 2010
Location:
Nottingham UK
Posts:
90
Plugin Contributions:
0

Re: WorldPay Module version 3.0 - Support thread

bonheddwr:

Hi. I'm trying to integrate Worldpay with two Zen Cart based websites. I already have two Worldpay Ecommerce accounts ready, but after installing this module, and trying my best to integrate my Zen Cart stores with Worldpay, I've come to the conclusion that I will not be able to do this without help. Can anyone suggest companies that provide this service for a fee? Feel free to DM me.

Hi Bonheddwr,

What kind of issues are you experiencing when installing the module? I can confirm I have it working in v1.5.5a of zen cart.