Derek Bryant:
thanks everyone - am trying out moving to a new server at Hostroute which supports php versions 5.4 to 5.6 currently set at 5.4 with one of my Zen Cart sites
Am trying to do a fresh install of Zen 138H on the new server but am getting a white screen plus the following log error message:
[24-Aug-2015 16:36:01 Europe/London] PHP Fatal error: session_start(): Failed to initialize storage module: memcache (path: /var/sites/b/website.co.uk/public_html/cache) in /var/sites/b/website.co.uk/public_html/zc_install/includes/functions/sessions.php on line 92
any help much appreciated
Part of the reason to do the upgrade is to take advantage of the additional security by the more recent PHP versions... Problem with that though is that an old version of ZC doesn't work on a new version of PHP... Beyond that... The old files will serve you well for comparison to an old clean set of files (able to find/identify the changes that were made to give what you had), but they will not offer a functional view if the PHP version is beyond the capabilities of the code (though still have your old site it seems?)... The database; however, which is all of the product and other settings that you've had, can be updated/upgraded using the zc_install process from a newly installed version of ZC...
May I suggest looking at: https://www.zen-cart.com/entry.php?3 which provides instruction about how to rebuild your site on a new version of ZC instead of stepping through the "upgrade" process... (The rebuild is mostly file related to obtain the functionality that you once had or wish to now have...)