Zen Cart Logo
Forums / General Questions / Emails from store suddenly stopped working

Emails from store suddenly stopped working

Views: 1,328

Results 1 to 9 of 9
27 Aug 2015, 6:34 PM
#1
sle39lvr avatar

sle39lvr

Zen Follower

Join Date:
Jan 2011
Posts:
196
Plugin Contributions:
0

Emails from store suddenly stopped working

Emails from my Zen Cart stopped going through. Any emails I send from "Contact us" section on my Zen Cart are not going through at all.

Info
Zen Cart 1.5.1
Database Patch Level: 1.5.1
Server OS: Linux 2.6.18-371.6.1.el5
PHP Version: 5.4.40 (Zend: 2.4.0)
Database: MySQL 5.5.42-cll

Email Settings
E-Mail Transport Method PHP
E-Mail Linefeeds LF Info
Use MIME HTML When Sending Emails true Info
Send E-Mails true Info
Email Archiving Active? true Info
E-Mail Friendly-Errors false Info

Emails must send from known domain? Yes Info
Email Admin Format? HTML Info

How can I diagnose this?

27 Aug 2015, 7:50 PM
#2
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Emails from store suddenly stopped working

Since archiving is true, can first check to make sure that emails are prepped to leave your store by either reviewing the phpmyadmin table associated or installing email manager from plugins.

Could also try changing the Email transport method to smtpauth and entering the credentials that are used to send/receive email as suggested by the emal "carrier" for smtp email such as usng outlook or other email programs. Thereis a faq (sorry didn't look it up) on email setup and such similar issue(s).

Also could identify here your email carrier and maybe someone could provide more detailed instructions specific to that email carrier.

27 Aug 2015, 8:01 PM
#3
sle39lvr avatar

sle39lvr

Zen Follower

Join Date:
Jan 2011
Posts:
196
Plugin Contributions:
0

Re: Emails from store suddenly stopped working

When I go back and check the logs, this crash lines up with one change I did with MySQL. I changed the TEXT to TEXTMEDIUM in product description table in order to gain higher capacity for product descriptions. Any connection there?

27 Aug 2015, 8:21 PM
#4
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Emails from store suddenly stopped working

sle39lvr:

When I go back and check the logs, this crash lines up with one change I did with MySQL. I changed the TEXT to TEXTMEDIUM in product description table in order to gain higher capacity for product descriptions. Any connection there?

None that I can think of. Would check your logs folder also though for posterity.

31 Aug 2015, 2:20 PM
#5
sle39lvr avatar

sle39lvr

Zen Follower

Join Date:
Jan 2011
Posts:
196
Plugin Contributions:
0

Re: Emails from store suddenly stopped working

I am seeing this in the logs:

[27-Aug-2015 18:17:04 America/New_York] ERROR: Failed sending email to: "Sales [email protected]" <> with subject: "Website Inquiry from My Domain" (failed validation)

31 Aug 2015, 2:35 PM
#6
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Emails from store suddenly stopped working

sle39lvr:

I am seeing this in the logs:

[27-Aug-2015 18:17:04 America/New_York] ERROR: Failed sending email to: "Sales [email protected]" <> with subject: "Website Inquiry from My Domain" (failed validation)

Still using php transport method? What changes have been made besides the modification of TEXT to TEXTMEDIUM as identified above? It sounds as if in order for the email to be sent through your domain that there needs to be some form of validation that it is originating from a "trusted" source... Don't know if this is a new factor as a result of changes made since this discussion started, or if it is acting the same as it has since the cause of the issue... Your review of the data and information would answer that. Also not sure if the < and > are "where" they ought to be... I seem to recall at one point that if the email attributes are opened and < or > were showing in the text that if they are again saved with that instead of being replaced with < or > then there might be an issue, but that may be unrelated...

31 Aug 2015, 3:40 PM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Emails from store suddenly stopped working

sle39lvr:

I am seeing this in the logs:

[27-Aug-2015 18:17:04 America/New_York] ERROR: Failed sending email to: "Sales [email protected]" <> with subject: "Website Inquiry from My Domain" (failed validation)

First quick fix I'd suggest is to go to Admin->Configuration->Email Options, and find the "Contact-Us Pulldown" settings, and blank-it-out, ie: leave it empty.
Then check whether those emails work properly again.

You titled this post as "emails stopped working", but then you only talked about contact-us emails. So does that mean it's ONLY the contact-us emails that have stopped? Or what other information is missing from this discussion?

23 Nov 2015, 7:06 PM
#8
sle39lvr avatar

sle39lvr

Zen Follower

Join Date:
Jan 2011
Posts:
196
Plugin Contributions:
0

Re: Emails from store suddenly stopped working

Retyping emails addresses under for contact us, fixed the issue. However, I still get the special characters forced in there if I go back after saving. for example < turns in to <

What could be the cause for this?

Thanks in advance.