Zen Cart Logo
Forums / General Questions / Easy Populate error 1062:Duplicate entry '1369-1'.

Easy Populate error 1062:Duplicate entry '1369-1'.

Views: 2,027

Results 1 to 20 of 29
21 Oct 2015, 4:05 AM
#1
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Easy Populate error 1062:Duplicate entry '1369-1'.

I brought a new template and upgraded my site to zencart 1.5.4 all categories and products are displaying correctly.

I have installed the latest version of easy populate. I can export fine, but when I import I am getting an error PHP Fatal error: 1062:Duplicate entry '1369-1'.

I believe the cause is when I upgraded my site and brought it over to the new database it is being looked at as a duplicate or something.

Can someone assist me or lead me the right direction in solving this issue.

21 Oct 2015, 4:57 AM
#2
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

Unfortunately there is/has been more than one version of EasyPopulate. Could you be more descriptive and provide possibly a link to the forum/download of the version installed? Also, it always helps those reading in the future to provide the specific version number as the issue may relate to someone else and they may not be able to tell without that information.

21 Oct 2015, 5:04 AM
#3
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

the download url: https://www.zen-cart.com/downloads.php?do=file&id=868
version downloaded: easy_populate_csv_for_zencart_v1.5.x_v1.2.6

"mc12345678" do you have any ideas why I am having these issues

21 Oct 2015, 12:53 PM
#4
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

chadlly2003:

the download url: https://www.zen-cart.com/downloads.php?do=file&id=868
version downloaded: easy_populate_csv_for_zencart_v1.5.x_v1.2.6

"mc12345678" do you have any ideas why I am having these issues

So I don't know the specific reason for that error, but it appears that the software is attempting to populate the database with information that already exists. This issue is probably best addressed in the forum for this plugin.

Would also note that it appears the error message has been truncated and that there might be additional info that could help troubleshoot it. But remember when posting to not include YOUR_SECRET_ADMIN folder name or database password if present.

21 Oct 2015, 2:00 PM
#5
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

"but it appears that the software is attempting to populate the database with information that already exists." This statement is true because of the upgrade process. I need to keep the same url and categories structure.......

Here is the full error

[21-Oct-2015 15:56:13 Europe/Berlin] PHP Fatal error: 1062:Duplicate entry '1369-1' for key 'PRIMARY' :: INSERT INTO products_description SET
products_id = '1369',
language_id = '1',
products_name = 'AXS Port OutBack Modbus/TCP Interface Device',
products_description = 'The AXS Port Modbus TCP, now OPTICS RE compatible, is a powerful and economical tool that allows installers and system owners the ability to monitor and control system status from any location.<br /><br />\n \n \n When paired with OPTICS RE, the AXS Port interface offers advanced monitoring and control features including\n <ul>\n \n \n <li>Real-Time PV/Solar System Performance Monitoring via Intuitive Dashboard Interface From any Internet-Connected Device</li>\n <li>Efficient Management of Multiple OutBack Power System Installations Under One Account</li>\n <li>Remote Troubleshooting</li>\n <li>Reduced Onsite Service Calls and System Downtime</li>\n </ul>\n \n \n The AXS Port makes it possible to create custom user interfaces for systems using the advanced API program development kit* and download system data logs using Modbus-read or FTP transfer. All user-configurable values are backed up with non-volatile memory, ensuring stable performance and system recovery. An optional remote temperture-sensing function provides a simple, low-cost tool for capturing and reporting ambient temperture or other critical thermal information records.<br /><br />\n\nThe AXS Port is a SunSpec compliant device**, which means it speaks the renewable energy industry's common language used to drive data and interoperability standards for plug-and-play operation between components and management systems.<br /><br />\n \n <strong>Product Highlights</strong>\n \n <ul>\n <li>Remote system control and monitoring via web interface with OPTICS RE</li>\n <li>SunSpec-compliant device for interoperability and plug-and-play and operation</li>\n <li>Over two years of data logging</li>\n <li>Accessories include MicroSD memory and DIN-rail mounting clip</li>\n <li>Product Specifications | <a href="http://www.invertersupply.com/media/data/axsport_specsheet.pdf" target="_blank" ><span class="d_link">Download</span></a></li>\n<li> Product Manual | <a href="http://www.invertersupply.com/media/data/axsss_manual.pdf" target="_blank" ><span class="d_link">Download</span></a></li>\n </ul>\n<table class="zebra">\r\n<thead>\r\n<tr><th colspan="3">AXS Port Specifications</th></tr>\r\n</thead>\r\n<tbody>\r\n<tr>\r\n<td colspan="2">Power</td>\r\n<td>Supplied by Outback device</td>\r\n</tr>\r\n<tr>\r\n<td colspan="2">Status Indicators</td>\r\n<td>Seven LED indicators</td>\r\n</tr>\r\n<tr>\r\n<td colspan="2">Clock</td>\r\n<td>On-board real-time clock with battery backup</td>\r\n</tr>\r\n<tr>\r\n<td colspan="2">Internet Standards</td>\r\n<td>TCP/IP, DNS, SMTP, FTP, DHCP, NTP</td>\r\n</tr>\r\n<tr>\r\n<td rowspan="3">Ports</td>\r\n<td>HUB/Device</td>\r\n<td>RJ-45</td>\r\n</tr>\r\n<tr>\r\n<td>Communications</td>\r\n<td>RJ-45</td>\r\n</tr>\r\n<tr>\r\n<td>Temperature Sensor</td>\r\n<td>RJ-11</td>\r\n</tr>\r\n<tr>\r\n<td colspan="2">Communication Protocol</td>\r\n<td>Modbus TCP to the SunSpec standard</td>\r\n</tr>\r\n<tr>\r\n<td colspan="2">OutBack Device Interface</td>\r\n<td>OutBack Proprietary</td>\r\n</tr>\r\n<tr>\r\n<td colspan="2">PC Interface</td>\r\n<td>10/100 Ethernet</td>\r\n</tr>\r\n<tr>\r\n<td colspan="2">Mounting</td>\r\n<td>DIN clip (provided) or surface mounting</td>\r\n</tr>\r\n<tr>\r\n<td colspan="2">Environmental Rating</td>\r\n<td>Indoor Type 1 (IP 30)Non-condensing</td>\r\n</tr>\r\n<tr>\r\n<td rowspan="2">Temperature Ranges</td>\r\n<td>AXS Port</td>\r\n<td>-40C to 75C</td>\r\n</tr>\r\n<tr>\r\n<td>SD Card</td>\r\n<td>-25C to 75C</td>\r\n</tr>\r\n<tr>\r\n<td rowspan="2">Weight</td>\r\n<td>Unit</td>\r\n<td>0.5 lbs / 0.23 kg</td>\r\n</tr>\r\n<tr>\r\n<td>Shipping</td>\r\n<td>2.1 lbs / 0.95 kg</td>\r\n</tr>\r\n<tr>\r\n<td rowspan="2">Dimensions H x W x D</td>\r\n<td>Unit</td>\r\n<td>1.29 x 3.5 x 4.99 / 3.3 x 8.9 x 12.7 cm</td>\r\n</tr>\r\n<tr>\r\n<td>Shipping</td>\r\n<td>3.25 x 9 x 13.5 / 19 x 22.9 x 34.3 cm</td>\r\n</tr>\r\n<tr>\r\n<td colspan="2">SD Card Size</td>\r\n<td>2 GB capacity</td>\r\n</tr>\r\n<tr>\r\n<td colspan="2">Options</td>\r\n<td>Outback RTS</td>\r\n</tr>\r\n<tr>\r\n<td colspan="2">Certifications</td>\r\n<td>FCC Part 15 subpart B, CE, RoHS, SunSpec</td>\r\n</tr>\r\n</tbody>\r\n</table>',

								products_url			=	''
								 ==> (as called by) C:\xampp\htdocs\zencart.com\power\easypopulate.php on line 2009 <== in C:\xampp\htdocs\zencart.com\includes\classes\db\mysql\query_factory.php on line 155
21 Oct 2015, 3:28 PM
#6
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

This is a slightly different issue than I was thinking, but same problem.

I thought the issue was related to installation, not to operation...

If you do wish to continue using this version of easypopulate then the issue should be investigated by review of the above thread and if a solution is not already posted there, then to inquire further. The problem seen is that when the csv has data for an a product that exists in the database, the product information is attempted to be inserted instead of updated...

If you wish to use a different version, then may I suggest EasyPopulate v4?

21 Oct 2015, 3:47 PM
#7
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

I downloaded your recommendation and have the same issue. It will export but will not import. When I do the import it says successfull but nothing happens..

"I thought the issue was related to installation, not to operation..." correct the products are already in the database I just cant update anything but i can export.

21 Oct 2015, 4:00 PM
#8
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

chadlly2003:

I downloaded your recommendation and have the same issue. It will export but will not import. When I do the import it says successfull but nothing happens..

"I thought the issue was related to installation, not to operation..." correct the products are already in the database I just cant update anything but i can export.

Sorry to be a pain aboout terminology, but different issue.

Are you sure you fully followed through? Upload is different that import. Also, the version currently available from the first post of that forum doesn't yet support import by products_id. There is a test version with that functionality available from http://github.com/mc12345678 and requires a few setting changes in the configuration panel to support such functionality.

Results of an import are provided at the bottom of the screen below the box of filenames.

21 Oct 2015, 4:47 PM
#9
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

Okay you were right https://github.com/chaddro/EasyPopulate-4.0 this seems to work. The only thing now is I am getting an error regarding maximum execution time. I changed the necessary files in my php.ini and restarted server and still getting this error. "though we are getting close"

[21-Oct-2015 18:44:41 Europe/Berlin] PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\zencart.com\includes\classes\db\mysql\query_factory.php on line 43

[21-Oct-2015 18:44:41 Europe/Berlin] PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\zencart.com\includes\functions\sessions.php on line 55

21 Oct 2015, 6:03 PM
#10
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

hmm i changed my max-execution time via the php.ini file and I am still timing out. Is this an issue with script or am i missing something hear.

21 Oct 2015, 6:22 PM
#11
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

okay problem solved. I didn't realize in the backend there was a drop down under configuration - easy populate. That is where i changed the Max-excution-time.

Thank you for your help. I have been zend....

21 Oct 2015, 6:28 PM
#12
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

chadlly2003:

okay problem solved. I didn't realize in the backend there was a drop down under configuration - easy populate. That is where i changed the Max-excution-time.

Thank you for your help. I have been zend....

Glad you found it. :) also, how many lines were involved with the import?

21 Oct 2015, 11:11 PM
#13
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

2200 items have been imported...

I did some testing and found one issue.. When I export the product feed via easy populate it duplicates the products within the excel sheet. In the database all is good. **Note it only duplicates on the excel sheet when I export.... Import process looks good. I'm scratching my head on this one.

21 Oct 2015, 11:48 PM
#14
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

I found one more thing. When I export the product feed I noticed that there is a section for v_categories_name_1

On my old feed I had v_categories_name_2 which is not present on the new export. Therefore my categories are not correct. I think this may be the cause of the duplicate when i export.

Sorry for all the post just that i am on a dead line and this is the final step....

21 Oct 2015, 11:55 PM
#15
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

also note that the products don't seem to be going in the categories but seems to be linking with the yellow mark as "link products"

22 Oct 2015, 12:12 AM
#16
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

So would need to know about your setting in the configuration->EP4 section, also when indicating export using EP are you still just using this version or more than one version?
The answer to the first question will reveal a lot about what else is going on.
The difference of the end of the file from _2 to _1 is because your language assignment went from 2 to 1. This is also one reason that a plan is in place to instead of using the numerical value in the database to instead use the language abbreviation for the applicable language, although even that wouldn't solve your problem.

22 Oct 2015, 12:34 AM
#17
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

If I understand you correctly i am using Easy Populate version 4.0.30 - Beta 06-27-2015. I exported the configurations from my database. Let me know if that is what you are looking for.

primary issue "that the products don't seem to be going in the categories but seems to be linking with the yellow mark as "link products"

*Configuration setting

2673 Show all EP4 Filetypes with Files EP4_SHOW_ALL_FILETYPES TRUE When looking at the EP4 Tools screen, should the filename prefix for all specific file types be displayed for all possible file types (True [default]), should only the method(s) that will be used to process the files present be displayed (False), or should there be no assistance be provided on filenaming on the main page (Hidden) like it was until this feature was added? (True, False, or Hidden) 91 25 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("True", "False", "Hidden"), General
2672 Export URI with Prod and or Cat EASYPOPULATE_4_CONFIG_EXPORT_URI 0 Export the current products or categories URI when exporting data? (Yes - 1 or no - 0) 91 19 10/22/2015 2:11 10/22/2015 2:02 NULL zen_cfg_select_option(array("0", "1"), General

2670 Enable Products Music Data EASYPOPULATE_4_CONFIG_MUSIC_DATA 0 Enable Products Music Data Columns (default 0).<br><br>0=Disable<br>1=Enable 91 17 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("0", "1"), General

2671 User Defined Products Fields EASYPOPULATE_4_CONFIG_CUSTOM_FIELDS voltage,length,width,thickness,cost User Defined Products Table Fields (comma delimited, no spaces) 91 18 10/22/2015 2:03 10/22/2015 2:02 NULL NULL General

2669 Enable Products Meta Data EASYPOPULATE_4_CONFIG_META_DATA 1 Enable Products Meta Data Columns (default 1).<br><br>0=Disable<br>1=Enable 91 16 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("0", "1"), General

2668 Convert Character 0x92 EASYPOPULATE_4_CONFIG_CHAR_92 1 Convert Character 0x92 characters in Product Names & Descriptions (default 1).<br><br>0=No Change<br>1=Replace with Standard Single Quote<br>2=Replace with HMTL equivalant 91 15 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("0", "1", "2"), General

2667 Convert Curly Quotes, etc. EASYPOPULATE_4_CONFIG_CURLY_QUOTES 0 Convert Curly Quotes, Em-Dash, En-Dash and Ellipsis characters in Products Description (default 0).<br><br>0=No Change<br>1=Replace with Basic Characters<br>3=Replace with HMTL equivalants 91 14 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("0", "1", "2"), General

2666 Script Execution Time EASYPOPULATE_4_CONFIG_EXECUTION_TIME 6000 Number of seconds for script to run before timeout. May not work on some servers. (default: 60). 91 13 10/22/2015 2:03 10/22/2015 2:02 NULL NULL General

2665 Split On Number of Records EASYPOPULATE_4_CONFIG_SPLIT_RECORDS 2000 Number of records to split csv files. Used to break large import files into smaller files. Useful on servers with limited resourses. (default: 2000). 91 12 NULL 10/22/2015 2:02 NULL NULL General

2664 Maximum Quantity Discounts EASYPOPULATE_4_CONFIG_MAX_QTY_DISCOUNTS 3 Maximum number of quantity discounts (price breaks). Is the number of discount columns in downloaded file (default: 3). 91 11 NULL 10/22/2015 2:02 NULL NULL General

22 Oct 2015, 12:37 AM
#18
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

here is the rest of the configurations i forgot to add

2663 Debug Logging EASYPOPULATE_4_CONFIG_DEBUG_LOGGING TRUE Allow Easy Populate to generate an error log on errors only (default: true) 91 10 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("true", "false"), General

2662 Advanced Smart Tags EASYPOPULATE_4_CONFIG_ADV_SMART_TAGS FALSE Allow the use of complex regular expressions to format descriptions, making headings bold, add bullets, etc. Note: legacy code is disabled until further review. (default: false). 91 9 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("true", "false"), General

2660 Make Zero Qty Products Inactive EASYPOPULATE_4_CONFIG_ZERO_QTY_INACTIVE FALSE When uploading, make the status Inactive for products with zero qty (default: false). 91 7 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("true", "false"), General

2661 Smart Tags Replacement of Newlines EASYPOPULATE_4_CONFIG_SMART_TAGS TRUE Allows your description fields in your uploads file to have carriage returns and/or new-lines converted to HTML line-breaks on uploading, thus preserving some rudimentary formatting - Note: this legacy code is disabled until further review. (default: true). 91 8 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("true", "false"), General

2659 Verbose Feedback EASYPOPULATE_4_CONFIG_VERBOSE TRUE When importing, report all messages. Set to false for only warnings and errors. (default: true). 91 6 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("true", "false"), General

2658 Upload/Download Prices Include Tax EASYPOPULATE_4_CONFIG_PRICE_INC_TAX FALSE Choose to include or exclude tax, depending on how you manage prices outside of Zen Cart. 91 5 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("true", "false"), General

2657 Default Raw Time EASYPOPULATE_4_CONFIG_DEFAULT_RAW_TIME 9:00:00 If no time value stipulated in upload file, use this value. Useful for ensuring specials begin after a specific time of the day (default: 09:00:00) 91 2 NULL 10/22/2015 2:02 NULL NULL General

2655 Uploads Directory EASYPOPULATE_4_CONFIG_TEMP_DIR temp/ Name of directory for your uploads (default: temp/). 91 0 NULL 10/22/2015 2:02 NULL NULL General

2656 Upload File Date Format EASYPOPULATE_4_CONFIG_FILE_DATE_FORMAT m-d-y Choose order of date values that corresponds to your uploads file, usually generated by MS Excel. Raw dates in your uploads file (Eg 2005-09-26 09:00:00) are not affected, and will upload as they are. 91 1 NULL 10/22/2015 2:02 NULL zen_cfg_select_option(array("m-d-y", "d-m-y", "y-m-d"), General

22 Oct 2015, 12:55 AM
#19
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

Just wanted to add if we can get the category_2 in there that should solve the issue. Just trying to give you some more information

22 Oct 2015, 1:40 AM
#20
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

Just an FYI if I export the product feed using easy populate all is good. When I import the same file with no adjustments it links the products and displays the yellow box by the product and category. "I should have no linked products"