Zen Cart Logo
Forums / General Questions / Easy Populate error 1062:Duplicate entry '1369-1'.

Easy Populate error 1062:Duplicate entry '1369-1'.

Views: 2,027

Results 21 to 29 of 29
22 Oct 2015, 1:56 AM
#21
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Easy Populate error 1062:Duplicate entry '1369-1'.

chadlly2003:

Just wanted to add if we can get the category_2 in there that should solve the issue. Just trying to give you some more information

This is a database issue not an EP4 issue... You would need to modify your language to be language_id 2 instead of 1, or change your other export/import functionality to accept a _1 or have the column fields modified....

That said, I could possibly suggest this... 1) be sure that you have applied the patches identified in the known issues for ZC 1.5.4 related to languages. 2) Install any alternate language than your current default. 3) change the default language to this second language. 3) delete the first language, 4) change the details of this second language to correspond to what was the first language. (ie. en, english, etc...) I think this is somewhat a necessary process because I believe there are other database references that are made based on the language_id and because your previous store (which apparently wasn't upgraded using the ZC upgrade process) used 2 as the primary language, the same setup needs to happen on this store to fit the other setup you have.

I provide the above as a somewhat thought experiment.. Backup before doing anything above..

22 Oct 2015, 2:01 AM
#22
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

chadlly2003:

Just an FYI if I export the product feed using easy populate all is good. When I import the same file with no adjustments it links the products and displays the yellow box by the product and category. "I should have no linked products"

Linking occurs when there are two or more items having the same model#... So, upon export of the data, recommend sorting by model number, then perform a simple database calculation to show where the same model# is listed 2 or more times... Anywhere that the same model# is used then if that model # is assigned to a category that does not already have that model, the product becomes linked by entering that product into the next category... Also at the same time, the other product related data will be updated to reflect the last entry of the import file that has that model#. This is why EP4 has historically required that model# be unique for all product. A sample/test version (4.0.31) has been developed that allows storing the data by product_id instead of model #.... There are cautions though about how that is used because it is more intrusive than using the "generic" model # and more capable of directly modifying a specific product.

22 Oct 2015, 2:42 AM
#23
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

For example if I had to make a pricing update via easy populate. Using the same model number should just update it rather than linking the product. Am I missing something here.

22 Oct 2015, 2:54 AM
#24
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

chadlly2003:

For example if I had to make a pricing update via easy populate. Using the same model number should just update it rather than linking the product. Am I missing something here.

If the categories column was omitted from the import then correct... But, if there are more than one product that has the same model # then every product that has that same model # gets updated with whatever data is provided in the import... EP4 up to version 4.0.30 is based on product having a unique model # for each and every product or else an upload of data for a model# used on multiple product will affect all product with that model #... Beginning in version 4.0.31 (location provided a few posts back) it is possible to upload with the products_id being the primary key and therefore an export that is again imported will go back literally one for one regardless of the model#...

22 Oct 2015, 1:44 PM
#25
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

I figured my issue out I just wanted to say thank you guys for the excellent support.

22 Oct 2015, 2:58 PM
#26
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

chadlly2003:

I figured my issue out I just wanted to say thank you guys for the excellent support.

To possibly help those that think there is a solution to this same issue here, would you mind identifying what was resolved and what was done to do so? Even if that is to indicate that I led you down a wrong path or something. No harm in me learning something from the whole thing. :)

22 Oct 2015, 5:59 PM
#27
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

The initial issue easy Populate error 1062:Duplicate entry '1369-1'. was solved my updating to easy populate version 4.0.30. As for the category issue was my mistake. I was importing the old file from the original ezpopulate into the new database not realizing that some of the table fields were changed for example Cat_1 Cat_2. That is what was causing my issue regarding the linking issue. If I would have just exported the updated excel file from the new installed easy populate version 4 I would have solved all my issues and saw that some of the tables did in fact change. There were also some minor issues with special pricing and dates from my old database. I just removed those fields from the excel file and re uploaded it and all is good. I believe at one point we may have lost track in the conversation but it did lead me in the right direction and for that i thank you for the support.

22 Oct 2015, 10:04 PM
#28
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

Good information to have.

Based on system response, it does make me wonder if the import operation needs a small tweak this could be supported if you could provide some additional information to resolve the following:

It appears that a discrepancy between the database and the import file was not handled properly. In the file was a presence of a language id that did not exist in the database. It further appears that the program did something with that data, though I'm not yet clear what t actually did (testing needed, but the following questions should help with that.)

  1. So, your import file indiicated a language using what suffix(es) (_1, _2, etc...)
  2. Your destination database has how many languages and what number is assigned to each? (Easy to see on the EP4 tools screen upper right side, mid screen)
  3. This was occurring with a file that had a name causing it to be treated as a full upload?
  4. Anything that can be provided to clarify what was happening as a result of the above mismatch...
23 Oct 2015, 2:48 PM
#29
chadlly2003 avatar

chadlly2003

Totally Zenned

Join Date:
Jan 2015
Posts:
777
Plugin Contributions:
0

Re: Easy Populate error 1062:Duplicate entry '1369-1'.

In this posting I am showing you the difference regarding the database between my zencart 1.5.1 and zencart 1.5.4. As you can see some of the tables have changed. For example the V_category_name 1 and 2 is now just v_categories_name_1 and uses a “v” to separate the categories. If I uploaded the original file from V1.5.1 using easy populate 1.5x into the new zencart 1.5.4 using easy populate4 that is where my issue came into play. What I had to do to solve my issue was do a standard upgrade from 1.5v to 1.5.4v. Then I installed easy populate4 and exported the database. This gave me the correct fields and format to use.

Though, I did notice that v_special_price seems to have some discrepancies. This is caused by the dates I put in for the fields v_specials_date_avail, v_specials_expires_date. To solve this issue I just clear out those tables and the special price now appears. A little different then the older version where a date had to be inputted in order to display the special price.

NOTE: Note also added custom fields: all Seems good with that……

I hope this posting gives you a better idea on how I tackled this issue.

Categories from Easy Populate for Zencart V1.5.1 database
v_products_model
v_products_image
v_products_name_1
v_products_description_1
v_products_url_1
v_specials_price
v_specials_last_modified
v_specials_expires_date
v_products_price
v_products_weight
v_last_modified v_date_added
v_products_quantity
v_manufacturers_name
v_categories_name_1
v_categories_name_2
v_tax_class_title
v_status
v_metatags_products_name_status
v_metatags_title_status v_metatags_model_status
v_metatags_price_status
v_metatags_title_tagline_status
v_metatags_title_1
v_metatags_keywords_1
v_metatags_description_1

Categories from Easy Populate For Zencart V1.5.4 Easy Populate 4.0.30 - Beta 06-27-2015
v_products_model
v_products_type
v_products_image
v_products_name_1
v_products_description_1
v_products_url_1
v_specials_price
v_specials_date_avail
v_specials_expires_date
v_products_price
v_products_group_a_price
v_products_group_b_price
v_products_group_c_price
v_products_group_d_price
v_product_is_call
v_products_sort_order
v_products_quantity_order_min
v_products_quantity_order_units
v_products_priced_by_attribute
v_product_is_always_free_shipping
v_date_avail
v_date_added
v_products_quantity
v_manufacturers_name
v_categories_name_1
v_tax_class_title
v_status
v_metatags_products_name_status
v_metatags_title_status
v_metatags_model_status
v_metatags_price_status
v_metatags_title_tagline_status
v_metatags_title_1
v_metatags_keywords_1
v_metatags_description_1

As for question #2
Configuration Settings
Upload Directory: temp/
Verbose Feedback: TRUE
Split Records: 2000
Execution Time: 6000
Convert Curly Quotes: No Change
Convert Char 0x92: Basic
Enable Products Metatags: 1
Enable Products Music: 0

Custom Products Fields
Product Short Descriptions: FALSE
Product Unit of Measure: FALSE
Product UPC Code: FALSE
Google Product Category: FALSE
Manufacturer's Suggested Retail Price: FALSE
Manufacturer's Advertised Price: FALSE
Group Pricing Per Item: TRUE
Exclusive Products Mod: FALSE
Stock By Attributes Mod: FALSE
CEON URI Rewriter Mod: FALSE
Dual Pricing Mod: FALSE

User Defined Products Fields:
voltage: TRUE
length: TRUE
width: TRUE
thickness: TRUE
cost: TRUE

Installed Languages
1-en: English
Default Language: 1-English
Internal Character Encoding: UTF-8
DB Collation: utf8

Database Field Lengths
categories_name:32
manufacturers_name:32
products_model:32
products_name:5000