Zen Cart Logo
Forums / Upgrading to 1.5.x / password not accepted for upgrade

password not accepted for upgrade

Views: 1,923

Results 1 to 13 of 13
29 Nov 2015, 5:39 PM
#1
joseph_heinen avatar

joseph_heinen

New Zenner

Join Date:
Jun 2007
Posts:
65
Plugin Contributions:
0

password not accepted for upgrade

I am upgrading from 1.3.9h to 1.5.4.

I installed 1.5.4 with the demo database. Modified things to "look" like the original site. Everything worked great. So I went to the new database and dropped the table and then imported the live database. Everything went well. so I ran zc_install to upgrade the database. But it won't accept the password.

29 Nov 2015, 6:14 PM
#2
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,809
Plugin Contributions:
15

Re: password not accepted for upgrade

Is the password different in the two databases? If so, then the password needed is the one for the current database. If the new is replaced with the old, the old password is needed for update.

29 Nov 2015, 6:20 PM
#3
joseph_heinen avatar

joseph_heinen

New Zenner

Join Date:
Jun 2007
Posts:
65
Plugin Contributions:
0

Re: password not accepted for upgrade

they are the same.

I did the upgrade exactly the same way to a different site on this server and it worked fine

29 Nov 2015, 6:46 PM
#4
carlwhat avatar

carlwhat

zennedOut

Join Date:
Nov 2005
Location:
los angeles
Posts:
2,965
Plugin Contributions:
8

Re: password not accepted for upgrade

from what i remember, at one point the upgrade asks for the password to the admin section to do the upgrade (in addition to the db credentials). i would re-examine that information just to be sure...

in addition, if the server has phpmyadmin installed, you can easily check the login credentials that way.

29 Nov 2015, 6:53 PM
#5
joseph_heinen avatar

joseph_heinen

New Zenner

Join Date:
Jun 2007
Posts:
65
Plugin Contributions:
0

Re: password not accepted for upgrade

Thanks
I looked at the password in the new store and the live store with phpmyadmin and they are the same

30 Nov 2015, 3:46 AM
#6
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: password not accepted for upgrade

What admin_profile value is assigned to the problem admin account? Is it 0? How many admin users are listed?

After loading in the database to be upgraded, before any attempt to login using the new fileset have you tried the actions of creating an admin user following the sql instructions for ZC 1.3.9 and below found at: http://www.zen-cart.com/content.php?44 and then used those new credentials to perform the database only upgrade?

30 Nov 2015, 2:19 PM
#7
joseph_heinen avatar

joseph_heinen

New Zenner

Join Date:
Jun 2007
Posts:
65
Plugin Contributions:
0

Re: password not accepted for upgrade

There was 2 admins. I got rid of one and tried again. It worked!

But I get the following error

SKIPPED: Cannot drop index page_accessed on table admin_activity_log because it does not exist.
SKIPPED: Cannot drop index access_date on table admin_activity_log because it does not exist.

SKIPPED: Cannot add index idx_page_accessed_zen to table admin_activity_log because it already exists.
SKIPPED: Cannot add index idx_access_date_zen to table admin_activity_log because it already exists.

30 Nov 2015, 3:22 PM
#8
carlwhat avatar

carlwhat

zennedOut

Join Date:
Nov 2005
Location:
los angeles
Posts:
2,965
Plugin Contributions:
8

Re: password not accepted for upgrade

you can safely ignore those 4 errors.

you should be good to go.

30 Nov 2015, 5:17 PM
#9
joseph_heinen avatar

joseph_heinen

New Zenner

Join Date:
Jun 2007
Posts:
65
Plugin Contributions:
0

Re: password not accepted for upgrade

everything works.

I was trying to install the "recover cart sales module. When I try to install the sql patch I get this error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

30 Nov 2015, 5:27 PM
#10
carlwhat avatar

carlwhat

zennedOut

Join Date:
Nov 2005
Location:
los angeles
Posts:
2,965
Plugin Contributions:
8

Re: password not accepted for upgrade

is there a log file in the zen-cart logs directory? if so, please post the contents....

30 Nov 2015, 6:05 PM
#11
joseph_heinen avatar

joseph_heinen

New Zenner

Join Date:
Jun 2007
Posts:
65
Plugin Contributions:
0

Re: password not accepted for upgrade

[30-Nov-2015 13:04:44] PHP Warning: extract(): First argument should be an array in /home/cps/public_html/catalog/includes/templates/classic/common/html_header.php on line 51

30 Nov 2015, 6:20 PM
#12
joseph_heinen avatar

joseph_heinen

New Zenner

Join Date:
Jun 2007
Posts:
65
Plugin Contributions:
0

Re: password not accepted for upgrade

[30-Nov-2015 13:04:44] PHP Warning: extract(): First argument should be an array in /home/cps/public_html/catalog/includes/templates/classic/common/html_header.php on line 51

30 Nov 2015, 10:39 PM
#13
joseph_heinen avatar

joseph_heinen

New Zenner

Join Date:
Jun 2007
Posts:
65
Plugin Contributions:
0

Re: password not accepted for upgrade

turns out that it wa being blocked by mod_security.